Moving news

  • luigi69

    luigi69 - 2013-05-31


    I would like to move all my RSSOwl data form Windows to Linux. I know there is an export option, but I need to transfer also all fetched news, with their status (marked as read or not). That's about 5k of records.

    How could I make this possible?
    I've tried to just copy the profile folder, or the database file itself but doesn't work.

    Last edit: luigi69 2013-05-31
  • luigi69

    luigi69 - 2013-05-31

    I'm very sorry, I picked up wrong forum and don't know how to change it now. Should be help.

  • Anonymous - 2013-06-01

    hm, try copy the .rssowl2 folder in home. that should work.

  • luigi69

    luigi69 - 2013-06-05

    When I try to switch .rssowl2 folder to that from another OS I get an error.
    Here is generated metadata/log:

    Is there a way to fix this, should I provide any more info?

    Last edit: luigi69 2013-06-05
  • genodeftest

    genodeftest - 2013-06-06

    Does RSSOwl start on the second OS without a .rssowl2 folder ("clean installation")?
    The log shows an XPCOM error from XULRunner which means that some binaries could not be found - AFAIK this is completely unrelated to anything stored in the .rssowl2 folder.

  • luigi69

    luigi69 - 2013-06-06

    Yest it does start on clean installation (it creates its own .rssowl2 folder then) and works normaly. There also is xulrunner folder in the package (download for Linux 64).

  • luigi69

    luigi69 - 2013-06-27

    Any help? Any ideas how could I fix this?

  • sg2002

    sg2002 - 2013-09-30

    Try moving just .rssowl\metadata.plugins\org.rssowl.core\rssowl.db over a clean installtion.

  • luigi69

    luigi69 - 2014-07-11

    Hello again and sory for such a late response, but the problem persists. I've been struggling with this bug from time to time without effects.
    I think the problem is somewhere in the db file itself, since the solution @sg2002 propsed didn't work. The only file I swap is the rssowl.db and it breaks the program. I'm not familiar with this type of database. I've opened it and searched a little, but no clues where to look for this kind of settings. Any ideas? It is the only application I've got, which doesn't support copying settings/user data to Linux (Ubuntu 12.04).

    In the meantime I've had a need to migrate to Mac OS X - and that worked like a charm. Same data, and no errors. I still would like to copy my data to Linux thou :(

    Last edit: luigi69 2014-07-11
  • Anonymous - 2014-07-11

    Thats weird, especially since it worked for Mac. I am not aware of something on Linux that would prevent this from working.

  • luigi69

    luigi69 - 2014-07-15

    @Benjamin Pasero I now know what is the reason of my problem.

    I was wondering could it be somehowe specific to Ubuntu 12.04, so I created few VM's with different Linux distros, including Ubuntu 14.04 32 and 64 bit versions.

    So here's the thing - exporting to 32 bit Ubuntu 14.04 works, exporting to 64 bit Ubunu 14.04 doesn't. I guess it's because the folder comes from Windows OS - which has a 32 bit client - compatible with 64 bit Windwos, but still treated as a 32 bit program, right?

    Do you maybe have an idea how to convert my .rssowl2 folder (I guess just fixing the db file might do the trick) to be compatible with a 64 bit Linux RSSOWL version? What should I change, and which tool should I use?

    Last edit: luigi69 2014-07-15
  • Anonymous - 2014-07-15

    Right, this might indeed be the problem. I am not aware of a way to convert .rssowl2 between 32 and 64 bits, sorry.

  • luigi69

    luigi69 - 2014-07-15

    Noooo ;( Don't crush my hope just like that.

  • luigi69

    luigi69 - 2014-07-15

    Do the databases differ in structure? Could I maybe export data from 32 bit with a query and import it to 64 bit?

  • sg2002

    sg2002 - 2014-07-15

    @Benjamin Pasero: what would be the problem with different systems?

    @luigi69: Have you tried deleting all other files from that folder, just moving only rssowl.db?

    If anything, I have a script that allows migrating data from one rssowl db, to another, I posted it here. It's a bit rusty, but worked last time I checked.

    Update: Decided to investigate further into your issue. Took my huge db and moved it onto a 64bit VirtualBox VM running OpenSuse. Worked with no problems. I just took my .rssowl folder from windows and moved it into my ~ in linux.

    Last edit: sg2002 2014-07-16
  • Anonymous - 2014-07-16

    Well there is no code in RSSOwl that does something different when you run with 64bit, but I am not entirely sure about the DB we are using...

  • luigi69

    luigi69 - 2014-07-16

    @sg2002 I have tried deleting all other files from that folder, just moving only rssowl.db. Doesn't help. Please check out my windows 7 .rssowl2 folder on the OpenSuse 64 VM machine you have:

    I left only one rss channel, and deleted rest to make it light, but it serves well for testing purposes. Doesn't work on my OpenSuse 64 VM (fresh install), I've just tested it.

    I'll check out the script you've wrote later.

    Last edit: luigi69 2014-07-16
  • sg2002

    sg2002 - 2014-07-16

    Hello. I've tried your database. From what I could see - it's ok.

    Are you sure that your problems are db related? Have you tried creating a new database on that machine, adding feeds and browsing them there? Maybe you don't have xulrunner set up or something like that?

    BTW, how did you set up xulrunner, if you did? The bundled one does not work for me, and there's no 1.9.2 in the repos anymore.

  • luigi69

    luigi69 - 2014-07-19

    Oh, I'm such a "genious".

    I just haven't tried to add a feed item on a fresh install before, so thought it was all working besides data import. But you are right, @sg2002. It's not the database fault.

    Anyway, @sg2002 - could you please tell me what do you do, step by step, to make RSSOwl run properly?

    I just did this:
    - installed fresh linux Ubuntu 14.04 64 bit on a VM
    - sudo apt-get update && sudo apt-get upgrade
    - downloaded RSSOwl for linux 64 (link from
    - unpacked the package
    - tried to run it, didn't work - because there was no Java on board
    - sudo apt-get install default-jre, to get java
    - ./RSSOwl - now it's is running, but crashies when I create a news feed and try to browse an item

    I've tried to setup xulrunner 1.9.2, but either I'm doing something wrong, or something else is bad here...

    Here's what I did:
    - downloaded xulrunner (link from
    - unpacked the package
    - ./xulrunner -v, gives me an error:

    ./ 143: exec: ./xulrunner-bin: not-found

    It's strange - two days ago (just after your resopnse) I was fiddling with the xulrunner stuff, and It wasn't throwing this error. To make it work however I've had to download 4 or 5 i386 packages (libsound2 for example). Even when the downloaded xulrunner was working, it didn't seem to make a diffrence for RSSOwl. I've passed the parameter mentioned in docs (Dorg.eclipse.swt.browser.XULRunnerPath).

    I'm probably doing something wrong here ;/

    Yeah, I know what I did to make xulrunner runnable:

    $ sudo dpkg --add-architecture i386
    $ sudo apt-get update
    $ sudo apt-get install libc6:i386 libncurses5:i386 libstdc++6:i386
    $ sudo apt-get install libgtk2.0-0:i386
    $ sudo apt-get install libasound2:i386
    $ sudo apt-get install libxt6:i386


    $ /home/luigi/Downloads/xulrunner/xulrunner -v
    $ Mozilla XULrunner - 20110707195905

    However when I launch RSSOwl it stil crashes in the same way. Here's how I lanuch it:

    $ /home/luigi/Downloads/rssowl/RSSOwl -Dorg.eclipse.swt.browser.XULRunnerPath=/home/luigi/Downloads/xulrunner/
    Last edit: luigi69 2014-07-19
  • sg2002

    sg2002 - 2014-07-21

    Hello again.

    The thing you're doing wrong here, is trying to install 32 bit xulrunner for 64 bit RSSOwl. You have to use a 64 bit version. Which is packaged with RSSOwl.

    Now, on how to get it running. On my Suse machine the only thing missing was a library called hunspell, and it wasn't really missing - there was a newer version, but xulrunner wasn't looking for it. So, the only thing I had to do was:
    sudo ln -s /usr/lib64/ /usr/lib64/

    Hope this helps.

    @Benjamin Pasero: Maybe it's a good idea to clarify in FAQ that for RSSOwl x64 you have to use x64 xulrunner?

  • luigi69

    luigi69 - 2014-07-26

    Hi :)

    @sg2002 - To make RSSOwl work I've had to do the libhunspell symlink trick just like you've wrote and also change file permissions to 755 for


    Now RSSOwl actually works fully with default config on Linux 64 (I've tested this both on Open Suse and Ubuntu). I've imported propsed news feeds and browsed feed items sccessfully.

    However when I tried to import data from my Windows instance, by switching the ~/.rssowl2/.metdata/.plugins/org.runtime.core/rssowl.db file to this from the link I've posted before it still crashes. It's broken in a different way tho. When I launch the program, loading screen is shown, and after the progress bar reaches 100% everything dissapears. No program windows are visible, althrough the process is still running. Here's the log left after such crash:

    !SESSION 2014-07-26 02:37:36.061
    java.vendor=Oracle Corporation
    BootLoader constants: OS=linux, ARCH=x86_64, WS=gtk, NL=en_US
    Command-line arguments:  -os linux -ws gtk -arch x86_64
    !ENTRY org.rssowl.ui 1 0 2014-07-26 02:37:37.504
    !MESSAGE RSSOwl Starting Up (RSSOwl/ (X11; U; en))
    !ENTRY org.rssowl.ui 1 0 2014-07-26 02:37:41.978
    !MESSAGE Error loading system default XULRunner
    !ENTRY org.rssowl.ui 1 0 2014-07-26 02:39:37.010
    !MESSAGE RSSOwl Shutting Down (emergency)

    Are you sure, @sg2002 that my rssowl.db file works fine on your instance, and that you've described all steps you've did? It is impossible that by reproducing same steps it would work on your VM and not on mine.

    Last edit: luigi69 2014-07-26
  • sg2002

    sg2002 - 2014-07-26

    It's quite possible that it would work on my vm, but not on your - I'm using an older opensuse 12.3.

    I have not done anything apart from the hunspell thing.

    Also, I moved the whole folder from your archive.

    Since the process is running, I have one guess - maybe you're using some different DE? When I open RSSOwl with your .rssowl, it immediately minimizes to tray after load. Maybe the same thing, but with your DE the tray icon does not show itself? I used KDE.

  • luigi69

    luigi69 - 2014-07-27

    Thank you for your help and interest, @sg2002.

    You were right, the app is running fine - it's just tray icon issue with Unity / Gnome 3 that I've encountered. KDE doesn't have this problem.

    Quick search shows that this is a common problem for many apps, but it's outside of this topics scope.

    Thanks again, now I can go Linux :)

    Last edit: luigi69 2014-07-27

Log in to post a comment.

Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:

No, thanks