Trouble trying to add new root CA certificate

Help
2005-12-02
2012-08-29
  • Tim Diggins

    Tim Diggins - 2005-12-02

    Hi -

    I'm trying to add a newsfeed which is delivered by https, and uses a self-signed CA Root Authority. Typically with Firefox/Thunderbird, etc. there is a Manage Certificates option which allows one to import trusted CA root authorities. I've tried doing this in the Java plugin (which has a gui to do this) and also using the java command line. (I have no real way to test whether these attempts were successful, but they completed without errors).

    Anyway, RSSOwl still displays the same errors for these feeds: "Unable to locate that file. . RSA premaster secret error" which sounds to me like the Root CA is still not imported. Can you let me know how RSSOwl finds its Trusted Root CAs and how I can add one (and test that I have!).

    Many thanks

    Tim

     
    • Anonymous - 2005-12-03

      RSSOwl is not handling with certificates in anyway, it should just allow to pass through anything that comes via a SSL connection.

      Ben

       
      • Tim Diggins

        Tim Diggins - 2005-12-03

        I finally figured out the problem - and just for anyone else's benefit - it turns out to be an issue with the difference between "strong" cryptography (as issued in java 1.5) and "unlimited" cryptography (as in the JCE (java cryptography extension), downloadable separately from java 1.5) -- but it was very tricky to find that out!

         

Log in to post a comment.