Ubuntu Linux - Mozilla 1.7, doesn't work.

Help
2005-01-20
2012-08-29
  • Nicolas Mommaerts

    I tried setting the env variables as said in some threads, but it just doesn't work. What's even more irritating is that I get NO error message whatsoever. How can I debug this?

    This is a real pitty as in my opinion rssowl is the best rssreader there is out there (or that I know of at least)

     
    • Lasse Pommerenke

      I made sure of that and now it works. and there I was certain I had unchecked that checkbox before, but maybe it helped to close and restart owl after hanging that option...

       
    • Anonymous - 2005-01-21

      Hi Nicolas,
      I am sorry to hear that.

      Here are some things that might help:
      FAQ about this issue is available at http://dev.eclipse.org/viewcvs/index.cgi/~checkout~/platform-swt-home/faq.html#browserlinuxrcp

      Did you install Mozilla 1.7 downloaded from Mozilla? It is important that Mozilla was compiled with GTK 2+.

      You should look in the logfile of RSSOwl that is located in ~/.rssowl/logs. Maybe something is written into it, that shows the problem.

      Ben

       
    • Anonymous - 2005-01-21

      Ah, and you are using latest RSSOwl 1.0?

       
    • Nicolas Mommaerts

      Hey Benjamin, thanks for the help. I am using the latest version, 1.0. I'm using the Mozilla version that came with Ubuntu, but since Ubuntu's default desktop is Gnome, I'm fairly confident the Mozilla build was compiled using Gtk 2+. I didn't know about the location of the log files, I checked them and I see an exception, stating that SWT didn't find Mozilla because of MOZILLA_FIVE_HOME isn't set (although I did that).

      So probably I did something wrong with the environment variables, I'll try again later this evening. I'll post my results.

      Thanks,
      Nico

       
    • Nicolas Mommaerts

      That is weird, the logs only contain 2 exceptions from the first time I started RssOwl. When I start it now, with or without the MOZILLA_FIVE_HOME variables, nothing is logged, and the internal browser still doesn't work.
      How can I be sure my Mozilla was built with Gtk2+?

       
    • Nicolas Mommaerts

      typing about:buildconfig in the mozilla url bar gave me all the options used to configure the build for mozilla

      This was among them: --enable-default-toolkit=gtk2
      So I guess it is built with gtk2.

       
    • Nicolas Mommaerts

      I just installed Mozilla 1.6 with Gtk2, doesn't work either :(

       
    • Anonymous - 2005-01-22

      Hm that is weird. RSSOwl should log any attempts that fail to load the internal browser.

      When you do as follows, the logfile should get a new entry (maybe delete all old logs before doing this):

      Start RSSOwl, open a newsfeed and select a news. Hit Ctrl+B to switch to the browser mode. Now, does a dialog popup that tells that its not possible to use your installed Mozilla as internal browser?

      Now quit RSSOwl and have a look at the logfile. Anything in there?

      Ben

      PS: Thanks for your donation :)

       
    • Nicolas Mommaerts

      Steps: open RSS Owl with:

      !/bin/sh

      export MOZILLA_FIVE_HOME=/home/nico/apps/mozilla
      export LD_LIBRARY_PATH = ${MOZILLA_FIVE_HOME}:${LD_LIBRARY_PATH}
      java -Xmx134217728 -jar -Djava.library.path=/home/nico/apps/rssowl_linux_1_0_bin /home/nico/apps/rssowl_linux_1_0_bin/rssowl.jar

      I put mozilla 1.6 gtk2+&xft in my homedir, I use absolute directories so I can start rssowl from the gnome panel.

      I click on a feed, I see it's news items in the top pane, when I click a particular post, I see it's content in plain html in the bottom pane. When doing ctrl+b the JVM crashes:

      An unexpected error has been detected by HotSpot Virtual Machine:

      SIGSEGV (0xb) at pc=0x48145ffa, pid=9820, tid=1075217984

      Java VM: Java HotSpot(TM) Client VM (1.5.0_01-b08 mixed mode, sharing)

      Problematic frame:

      C [libwidget_gtk2.so+0x26ffa] _ZN12nsBaseWidget19GetRenderingContextEv+0x2e

      Anything else I can try?

       
    • Nicolas Mommaerts

      Okay,
      you can ignore my previous post, I tried it again with Mozilla 1.7 and it works for some reason now! I saw your bug report on Eclipse SWT where you stated for a user it works with Mozilla 1.6 and not 1.7, but I have the opposite case here (if you can do something with that information).

      Allright, now I can enjoy this great rss reader in my favorite OS. Thanks for the help and good luck!

       
      • Anonymous - 2005-01-22

        Great to hear that :)

         
    • Nobody/Anonymous

      Error loading internal Browser!
      No more handles (java.lang.UnsatisfiedLinkError: /usr/local/cache/rssowl/libswt-mozilla-gtk-3123.so: libstdc++.so.5:

      RHEL AS4 kernel-2.6.11-nitro0 jre 1.5
      gcc (GCC) 3.4.3 20041212 (Red Hat 3.4.3-9.EL4)

       
    • Nobody/Anonymous

      Hi all

      I'm trying to setup rssowl with mozilla firefox in ubuntu 5.04, but it says command setenv is not found... ???? does it really exists? i'm doing it in a terminal. Do i have to edit a config file instead? if so, which one?

      thnx in advance
      lluishc

       
      • Nobody/Anonymous

        Are you running RPMs oder the Linux Binary release?

        Ben

         
    • Nobody/Anonymous

      Sorry Ben, i don't understand your question... i'm very new in linux. I run the default, new and fresh ubuntu hoary install. Does this mean something for you?

      thnx
      lluishc

       
      • Anonymous - 2005-04-20

        No, I was referring to RSSOwl. Did you download Linux Binaries or Linux RPMs?

        Ben

         
    • Nobody/Anonymous

      Nicolas,

      I thought I'd spread my joy: I got the internal browsing (using Ubuntu btw). It's pretty simple.

      Just go to [tools] > [preferences] > [view]
      and under "misc", check "view newstext in browser".

      Be sure to check this, because it's not set by default if you installed RSSOwl as per the Starter Guide.

       
    • Lasse Pommerenke

      I also use ubuntu's mozilla package; Mozilla 1.7.12, it's compiled with all the gtk2 options. I also set up all the environment variables, I get nor error messages and no log file is created. I use the latest RSSOwl. However, for me it only works partially:

      I select a feed (lets say "debian planet") and then a news item ("Ross Burton: Loving Open Source"). It looks like this: http://screenshots.mine.nu/1131450365.png?offset=

      Now, when I click on that URI just below the header "http://www.burtonini.com/blog//computers/love-open-source-2005-11-08-09-58", I hear the harddisk errr doing its thing but nothing else happens. However, when I click on one of the links in the main text, an embedded mozilla is started which displays the given URI. For example it looks like this after clickin on that "This article" link: http://screenshots.mine.nu/1131450584.png?offset=

      Now this might be intended behavior, but I find it confusing to click on a link and to see nothing happen. What I expected was for rssowl to open the shown URI in the mozilla widget.

       
      • Anonymous - 2005-11-08

        Make sure you have not set to use an external Browser in preferences. It might open outside RSSOwl but somehow fails to start the process.

        Ben

         

Log in to post a comment.