Move the database to the D: drive

1 2 > >> (Page 1 of 2)
  • apometron

    apometron - 2011-12-30

    How to make RSS Owl 100% portable?

    I have RSS Owl Portable and I cant make

    the software to work with the database

    in the place the readme.txt said it would

    be detected by the software.

    How to make it detect the database?

    Volume in drive D is 833-giga Serial number is 3c67:e3c7

    Directory of

    29-12-2011 01:06 1,993 .credentials

    28-12-2011 23:45 1 format2

    29-12-2011 08:44 13 lastused

    29-12-2011 20:29 981,385,216 rssowl.db

    29-12-2011 20:02 978,239,398 rssowl.db.onlinebak

    29-12-2011 07:59 951,524,772 rssowl.db.onlinebak.weekly

    I am not able to discover what directory it should go.

    Do someone have some idea?

    Before of any response, thanks!!! =)

  • genodeftest

    genodeftest - 2011-12-30


    Let's suppose your path is given by $path/.rssowl2

    Try setting those Paths to portable (relative) Paths:



    if that doesn't work, use (additionally?)



    If those don't work, you need to change all of those:



  • genodeftest

    genodeftest - 2011-12-30

    Sorry, I forgot: you may set those paths by adding those lines in your
    RSSOwl.ini or to RSSOwl's command Line.

  • apometron

    apometron - 2011-12-30

    Now it works, Genodef!

    Thanks by the help.

    You were of much help.

    Now it is reading the news. =)

    Here are my subscriptions for you to see how much it is:

    Feel free to save my feeds. =)


  • genodeftest

    genodeftest - 2011-12-30

    You're welcome!

    which one did it? Did you have to set all of those parameters?

    I can't see anything on your link btw.

  • apometron

    apometron - 2013-03-22


    I need help.

    What values should I put here:


    And it is a problem also:

    Sorry to bother you again, but it is
    difficult to me to sort out what put
    in these fields.

    Rodrigo Cesar Banhara

  • Anonymous - 2013-03-22

    Dont forget to add "-vmargs" before you start using any of the -D arguments! For example:

    rssowl.exe -vmargs -D...

    • apometron

      apometron - 2013-03-25

      Thanks by the hint! It is very important to me, you know! =)

    • apometron

      apometron - 2013-03-25

      It is already there, Benjamin. And the error persists. Please, help...

  • Anonymous - 2013-03-25

    Just try:
    rssowl.exe -data


    • apometron

      apometron - 2013-03-26


      Help please.

  • Anonymous - 2013-03-26

    hmm, can you zip the contents of Data and make it available to me?

  • genodeftest

    genodeftest - 2013-03-26

    If the path was D:\RSSOwlPortable\Data.rssowl2\… you need to specify the full path. try running it with
    -data=D:\RSSOwlPortable\Data.rssowl2\ or move all contents from .rssowl2 to Data. the .rssowl folder (without trailing '2') is unused and can be deleted.

    • apometron

      apometron - 2013-03-27

      Thanks, Genodeftest, always a friendly hand. It works now as portable database. =D Again, thanks!!!!!!!!!!!!!!!!!!!!!!

  • genodeftest

    genodeftest - 2013-04-02

    Thanks for that. For compatibility with future versions of RSSOwl we should document all steps you did to make RSSOwl portable.
    What exactly did you change? Just the -data switch?
    It would be nice if you contributed them to
    I opened 2 issues there for what should be the biggest problem: the -data switch and the Java runtime. Please note that your RSSOwl.ini does not solve the problem since it is absolute (D:\…) which is bad for portability. Feel free to open issues on github or fork and make pull requests.

    Since I don't own any recent versions of windows I need you to test and verify all changes we are making on RSSOwl.

  • apometron

    apometron - 2013-04-03

    Genodeftest, the only thing I needed was the -data switch.

    I only dont knew what put on the switch -data.

    Thanks by alll the help!

  • apometron

    apometron - 2013-04-03

    And perhaps the switch -Dportable can have helped.

  • apometron

    apometron - 2013-04-03

    I try redo the work. It do not works!

    RSSOwl continues to put data on drive C:.


    This is ini did not helped:


    What to do? Help! =(

    Rodrigo Cesar

    Last edit: apometron 2013-04-03
  • apometron

    apometron - 2013-04-03

    Now is all right.

    Last edit: apometron 2013-04-03
  • genodeftest

    genodeftest - 2013-04-03

    Ok, can you please test this for me:
    1. change your file/directory layout to the one specified by (anything else can be omitted right now)
    1.1. RSSOwlPortable is the main folder
    1.2. RSSOwlPortable\App\RSSOwl contains anything from RSSOwl's zip files from
    1.3. RSSOwlPortable\Data contains the .rssowl2 folder

    1. change the RSSOwl.ini to look like this (you can change the -Xms and -Xmx as you want to, but don't switch lines:
    -data ..\..\Data\

    It is important that the line starting with '-data' is before the line '-vm', see for details

    1. Start RSSOwl. It should now work fine.

    2. Move the RSSOwlPortable folder somewhere else (make sure the original path does not exist any more) and try again.

    3. make Windows assign a different drive letter (different from D:) by e.g. inserting multiple USB flash drives before inserting the flash drive containing RSSOwl portable. Test again.

    4. Test on different PCs. Ideally this would include 4.

    Any problems?
    Please report them as bugs on

    (EDIT: sorry, does not like my formatting…)

    Last edit: genodeftest 2013-04-03
  • apometron

    apometron - 2013-04-04

    Do not works. -data ....\Data -vmargs do not works.

    Could you do the reporting for me?

    You are better than me on English.

  • apometron

    apometron - 2013-04-04

    Well, I will try report it.

1 2 > >> (Page 1 of 2)

Log in to post a comment.

Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:

JavaScript is required for this form.

No, thanks