RSSOwl is unable to launch the external browser

Help
John Space
2013-04-17
2013-05-12
  • John Space

    John Space - 2013-04-17

    Morning.

    I'm using 2.1.6. in Windows XP Professional 32-bit SP3. I have RSSOwl configured to open tabs in Opera (the latest version, 12.15). So, when I click on the title of the feed, the page opens in Opera.

    However, today RSSOwl is telling me that it "is unable to launch the external browser in C:\Archivos de programa [i.e. Program Files]\Opera\opera.exe". How to solve this problem? I haven't found any solution by searching in the forums; the problem seems to be more common with Linux users. Should I do the "replace the old database" trick?

    Also, in case it may be important, yesterday I updated java (7 update 21).

    Thank you!

     
  • John Space

    John Space - 2013-04-20

    Anyone?

     
  • genodeftest

    genodeftest - 2013-04-20

    I can't confirm that problem. Can you please
    1. Try changing Edit → Preferences → Browser
    2. Export a log file, see http://www.rssowl.org/help#item_5

     
  • John Space

    John Space - 2013-04-21

    Changing Browser in Preferences does nothing. Neither does replacing the old database, although I didn't expect it to.

    Here is the logfile. Thank you.

     
  • genodeftest

    genodeftest - 2013-04-24

    Does the path to your browser contain spaces?

    I ran into a problem related to that some days ago. This is a bug in some Java implementations, see https://github.com/basti1302/startexplorer/issues/23 for example.

     
    • John Space

      John Space - 2013-04-25

      Let's see:

      C:\Archivos de programa\Opera\opera.exe

      "Archivos de programa": two spaces that obviously I cannot delete. Any suggestions?

      Thanks :)

       
  • genodeftest

    genodeftest - 2013-04-26

    There is a bugfix needed. Give me some time to do that.
    As a workaround you could possibly create a link in filesystem. I don't use Windows so I can't give you a step-by-step howto. The link must be in a directory/path containing no spaces. It could e.g. reside in C:\ and link to the Opera executable.

     
  • John Space

    John Space - 2013-04-26

    I'll better wait for the fix. I don't know how to create a link in filesystem. Thanks!

     
  • ooofest

    ooofest - 2013-05-01

    Creating a hard link to the directory containing Opera's executable bypassed the problem for me on Windows 7 64-bit, btw. I tried other experiments and the issue does seem related to having space characters in the file path.

    Seems this symptom appeared only since the latest Java update on my system, come to think of it.

     
  • genodeftest

    genodeftest - 2013-05-02

    @ooofest: Thanks for the hint that this bug is related to the latest Java update. There were changes in Runtime.exec(), the method used to start applications used from Java applications. See http://www.oracle.com/technetwork/java/javase/7u21-relnotes-1932873.html#jruntime

    EDIT: The bug is in org.rssowl.ui.internal.util.BrowserUtils.java

     
    Last edit: genodeftest 2013-05-02
  • John Space

    John Space - 2013-05-04

    The problem persists in 2.2.0.

     
  • Richard Beels

    Richard Beels - 2013-05-07

    to make a link, do this: open a cmd window as administrator - right click the cmd link and pick "run as admin..." and enter in this command:

    mklink "C:\opera.exe" "C:\Archivos de programa\Opera\opera.exe"

    if that's the proper full path to opera. this is just like a link to an app on your desktop but doesn't have a long path or any spaces.

    if you care about files littering your hard drive, you can put it on your desktop, that path would be: "C:\Users\whateveryourusernameis\Desktop\" and would replace the first argument, above.

    this link will work just like a "regular" shortcut on your desktop does now.

    then, go into rssowl and change the path to the opera executable to point to the link instead and give it a whirl.

     
  • John Space

    John Space - 2013-05-10

    Sorry, I don't understand this part:

    "if you care about files littering your hard drive, you can put it on your desktop, that path would be: "C:\Users\whateveryourusernameis\Desktop\" and would replace the first argument, above."

    Do I create a folder called Desktop in the folder with my user name?

     

Log in to post a comment.