RSSOwl was unable to create a browser

Help
lerad
2010-09-08
2015-06-19
  • lerad

    lerad - 2010-09-08

    I used RSSOwl under Ubuntu 9.10, where it worked without problems. After
    upgrading to 10.04 I get the error:

    "RSSOwl was unable to create a browser for reading news. Please refer to the
    FAQ for further help.

    Click 'Ok' to open the FAQ now."

    In the FAQ I found nothing which helps me.

    I tried the advice, found in this thread, but it does not help.

    http://sourceforge.net/projects/rssowl/forums/forum/296910/topic/3754772

    • The MOZILLA_FIVE_HOME Environment Variable is set to /usr/lib/mozilla
    • Xulrunner is installed

    I deleted ~/.rssowl2 and installed rssowl again, but the error persists.

    Do you have any ideas, what is wrong?

    Greetings,

    lerad

     
  • Nicholas Knouf

    Nicholas Knouf - 2010-10-08

    I also have the same problem, also after upgrading to 10.04 Lucid. I've tried
    all manner of possibilities, including installing what would appear to be
    necessary packages, changing MOZILLA_FIVE_HOME, etc. Some settings of
    MOZILLA_FIVE_HOME (including pointing to the appropriate xulrunner folder
    under /usr/lib for Lucid) causes RSSOwl to crash when trying to open a feed.
    I've had to drop RSSOwl and move to Liferea instead because this made it
    impossible to read RSS feeds in RSSOwl.

     
  • Rafael Castellar das Neves

    I've just came from liferea, which is to slow and takes so much time to updade
    Google Reader, but I'm getting yours same problem with RSSOwl...I think I will
    have to come back to Liferea...

     
  • genodeftest

    genodeftest - 2012-07-30

    @rafaelcastellar: Which OS are you using? Do you have the correct architecture
    (32Bit RSSOwl for 32Bit Java on 32Bit OS or – 64Bit RSSOwl with 64Bit Java on
    64Bit OS)? Which version of libhunspell do you have installed (ask your
    package manager) ?

     
  • Rafael Castellar das Neves

    Hi Genodeftest!

    OS = Fedora 17 64bit

    RSSOwl 64 Bit, but I don't know the java and lihunspell version, How can I
    check? (sorry, I'm not an expert user).

    tks!!

     
  • genodeftest

    genodeftest - 2012-08-02

    Hi

    With Fedora 17 64Bit you should have java 64Bit and libhunspell 1.3.* 64Bit
    installed.

    Can you confirm this?

    for getting your Java version, type

    java -version

    to a terminal, it should give you something like

    java version "1.7.0_05-icedtea"

    OpenJDK Runtime Environment (fedora-2.2.1.fc17.9-x86_64)

    OpenJDK 64-Bit Server VM (build 23.0-b21, mixed mode)

    this is my output, as you can see 64-Bit version

    libhunspell version:

    typing

    yum info hunspell

    gives some info on hunspell package(s), with one line

    Version : 1.3.2

    (should look similar on your machine)

    If that is correct, do this to fix your problem:

    Run

    ln /usr/lib64/libhunspell-1.3.so.0 /usr/lib64/libhunspell-1.2.so.0

    as root or with sudo, then start RSSOwl again and see if it worked.

     
  • Rafael Castellar das Neves

    Hi!!

    Follows the answears:

    Java Versio:

    java version "1.7.0_03-icedtea"

    OpenJDK Runtime Environment (fedora-2.2.1.fc17.8-x86_64)

    OpenJDK 64-Bit Server VM (build 23.0-b21, mixed mode)

    libhunspell version:

    Pacotes instalados

    Nome : hunspell

    Arquitetura : x86_64

    Versão : 1.3.2

    Lançamento : 4.fc17

    Tamanho : 561 k

    Repo : installed

    Do repositório : koji-override-0

    Sumário : A spell checker and morphological analyzer library

    URL : http://hunspell.sourceforge.net/

    Licença : LGPLv2+ or GPLv2+ or MPLv1.1

    Descrição : Hunspell is a spell checker and morphological analyzer library and

    : program designed for languages with rich morphology and complex word

    : compounding or character encoding. Hunspell interfaces: Ispell-like

    : terminal interface using Curses library, Ispell pipe interface,

    : OpenOffice.org UNO module.

    Run your last command and started RSSOwl, but the problem persists...

    Tks for helping...

     
  • genodeftest

    genodeftest - 2012-08-04

    Ok, can you double-check that you have the 64Bit version of RSSOwl installed?
    Or try to reinstall it from
    http://www.rssowl.org/download

     
  • Rafael Castellar das Neves

    I don't know, but I shut my system down yeasterday and started right now. As I
    saw your message, I started RSSOwl to confirm and here is: yes, it is 64 bit
    and is working right!! I think the last steps you told me worked properly.

    Thanks!!!!!!

     
  • genodeftest

    genodeftest - 2012-08-04

    Thanks for your feedback!

     
  • Monitox

    Monitox - 2012-08-08

    I also have the "Unable to create browser" problem. This is my contact with
    Linux so I don't quite understand the FAQ. Can someone give me step-by-step
    instructions?

    I run LinuxMint 13 x64.

    java version "1.6.0_24"
    OpenJDK Runtime Environment (IcedTea6 1.11.3) (6b24-1.11.3-1ubuntu0.12.04.1)
    OpenJDK 64-Bit Server VM (build 20.0-b12, mixed mode)
    

    Thanks in advance :)

     
  • genodeftest

    genodeftest - 2012-08-12

    Hi

    do you know how to open a terminal?

     
  • genodeftest

    genodeftest - 2012-08-12

    Ok, sorry, sure you know since you got your java version…

    Try to run this in a terminal:

    sudo ln /usr/lib/x86_64/linux-gnu/libhunspell-1.3.so.0 /usr/lib/x86_64/linux-gnu/libhunspell-1.2.so.0
    

    You will need to type your sudo password since this action requires to make a
    link (with the command 'ln') in the folder where your LinuxMint stores all
    libraries.

     
  • genodeftest

    genodeftest - 2012-08-12

    please note that this command is a one-liner (no line break inbetween). Just
    copy&paste, then try to start RSSOwl again

     
  • Narayan

    Narayan - 2015-06-19

    Hello everyone. Sorry to use OP thread but I have the same problem and I have done (at least I think I have) what is stated at the FAQ.

    Here are the steps I did so far:

    -Uninstalled anything that could have been previously installed about xulrunner (I think I had something like Xulrunner-17.0 installed) with the command:

    sudo apt-get remove --purge xulrunner-17.0

    -Downloaded and untar this file

    rssowl-2.2.1.linux.x86_64.zip

    into ~/Downloads/rssowl

    -Then I have downloaded and untar this file

    xulrunner-1.9.2.19.en-US.linux-i686.tar.bz2

    into

    /opt/xulrunner/1.9.2.19/xulrunner as suggested somehwere at xulrunner site:

    and issued the following command:

    xulrunner --register-user

    -I've added the line

    -Dorg.eclipse.swt.browser.XULRunnerPath=/opt/xulrunner/1.9.2.19/xulrunner

    into file:

    /etc/eclipse.ini

    After this all I still get the error that RSSOwl can't create the browser to read the feeds.

    After reading this thread I have made the verificatiosn suggested:

    Java
    java -version
    java version "1.8.0_45"
    Java(TM) SE Runtime Environment (build 1.8.0_45-b14)
    Java HotSpot(TM) 64-Bit Server VM (build 25.45-b02, mixed mode)

    hunspell version
    hunspell --version
    @(#) International Ispell Version 3.2.06 (but really Hunspell 1.3.3)

    Copyright (C) 2002-2014 László Németh. License: MPL/GPL/LGPL.

    Based on OpenOffice.org's Myspell library.
    Myspell's copyright (C) Kevin Hendricks, 2001-2002, License: BSD.

    This is free software; see the source for copying conditions. There is NO
    warranty; not even for MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE,
    to the extent permitted by law.

    Also libhunspell-1.3.so.0 in my SO (Debian Jessie 8 64bit) is at /usr/lib/x86_64-linux-gnu/ instead of /usr/lib/x86_64/linux-gnu/(maybe it was a typo).

    ls -la /usr/lib/x86_64-linux-gnu/libhunspell-1.3.so.0*
    lrwxrwxrwx 1 root root 24 Oct 17 2014 /usr/lib/x86_64-linux-gnu/libhunspell-1.3.so.0 -> libhunspell-1.3.so.0.0.0
    -rw-r--r-- 1 root root 343528 Oct 17 2014 /usr/lib/x86_64-linux-gnu/libhunspell-1.3.so.0.0.0

    Finally I have exported an RSSOwl lof that can be visited here:
    http://pastebin.com/WSuqLEuR

     
    Last edit: Narayan 2015-06-19

Log in to post a comment.

Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:





No, thanks