sharing rssowl profile: dual boot XP/ubuntu

Help
2006-06-16
2012-08-29
  • Nobody/Anonymous

    Need a little help here, I have RSS owl on both Ubunutu and WinXP on the same computer, I want to use the same profile on both systems. All my shared data is stored on a FAT32 partition while each system has its own native fileystem patition too

    So i need to change the program under each system to read the profile from this shared disk.
    It is E:\Firefox\RSSowl\ and /mnt/share/Firefox/RSSowl , respectively.

    On windows RSS owl is installed in C:\Program Files\RSSowl, for linux it installs to the default location.

    Could someone give me detailed instructions substituting in the locations given above as to how to set this up ?

     
    • Benjamin Pasero

      Benjamin Pasero - 2006-06-16

      In order to specify the location where RSSOwl should store its profile, you can use:

      "javaw -Duser.home=[Path to Dir] -Djava.library.path=. -jar rssowl.jar"

      or on Windows: rssowl.exe "-profile [Path to Dir]"

      Ben

       
    • Nobody/Anonymous

      but how do i run the command in Windows, I tried setting the shortcut as
      "C:\Program Files\RSSOwl\rssowl.exe"-profile E:\Firefox\RSSowl"
      but Windows says its not valid, where do I set it and whats the correct syntax ?

      Thanks for your help
      Fergus

       
      • Benjamin Pasero

        Benjamin Pasero - 2006-06-17

        The syntax is correct. Make sure the folder you point to is existing.

        Ben

         
      • Benjamin Pasero

        Benjamin Pasero - 2006-06-20

        Works for me with this syntax:

        "C:\Program Files\RSSOwl\rssowl.exe" -profile C:/

        Please doublecheck the quotes you use. This is wrong because of the last quote:

        "C:\Program Files\RSSOwl\rssowl.exe"-profile E:\Firefox\RSSowl"

        You can see that it works when a folder called ".rssowl" is created in E:\Firefox\RSSowl.

        The application directory should never be used for settings. The default location for settings is the home-directory (C:/Documents and Settings/your.name/.rssowl).

        ben

         
    • Nobody/Anonymous

      Ok windows now seems to be accepting the -profile tag on the shortcut I'm no longer getting error messages when I try to lose the properties box. When I run the prrogram everything works fine but all the important files such as user.xml reman in C:\Program Files\RSSOwl directory. I need these files in the E:\RSSOwl directory so that they are accessible from Ubuntu but when I tried copying user.xml to E: the program started as if I was a new ser without any of my newsfeeds.

      Is there any way I can get it to use my settings as stored on E: ?

       
    • Nobody/Anonymous

      Ok, seems to be working fine on Windows now, however when I type:
      "javaw -Duser.home= /mnt/share/RSSOwl/ -Djava.library.path=. -jar rssowl.jar"

      into a terminal in ubuntu it tells me there's no such file or directory, again is it a case of messed up syntax ?

      Sorry about this

       
      • Benjamin Pasero

        Benjamin Pasero - 2006-06-21

        The command looks good to me, despite the fact that you have a blank " " at "-Duser.home= /mnt/share/RSSOwl/". Try

        -Duser.home=/mnt/share/RSSOwl/

        Ben

         

Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:





No, thanks