2M5a - "cannot display the webpage"

Help
Anonymous
2007-04-21
2012-08-29
  • Anonymous - 2007-04-21

    Just tried RSSOwl2 for first time - very impressive. :)

    When clicking on a news item, the preview window shows the IE-generated (?) message "This program cannot display the webpage" 99% of the time. Very occasionally the news item is displayed correctly in the preview window, but clicking away and returning to the same news item causes the error message. If I hit F5 (Refresh) repeatedly, the news item preview usually / eventually appears.

    Windows XP Pro (all latest updates), IE7, JRE6

     
    • Nobody/Anonymous

      Yeap! Likewise. Tried installation on two different W2K machines. No matter what, i get the same message "No more handles [Could not detect registered XULRunner to use]", and in NO case have I managed to get the internal browser to show anything.

      Tried both Java v5 and v6

      RSSOwl 2.0 Preview
      Version: 2.0.0
      Build id: Milestone 5a (2007-03-25)

      On the other hand, an installation on WinXP SP2, worked like charm.

      Unida :)

       
      • Nobody/Anonymous

        Problem solved!

        Right click into the internal broswer window.
        From properties, fetch URL. Should be something like:

        res://C:\WINNT\system32\shdoclc.dll/dnserror.htm#
        http://127.0.0.1:8795/?id=28026670&displayNews=2253

        This got me rolling. Never thought it could be a firewall - IE settings,
        as I thought I had them all figured out.
        Noticed port 8795, and played around with various firewall settings.
        Although I didnt find an obvious conflict, a mere higher priority in the rule, seems to ended the access bottleneck.

        Also for the shake of proper logging, I also note the following:

        • I removed previous (disabled though) settings for LAN-Proxy
          setting and restarted IE.
        • Also, dunno if the installation of XULRunner helped, (see above messages),
          but I think it should be reminded, just in case

        Notes

        Tried the following URL in Opera (see above)...works!
        http://127.0.0.1:8795/?id=28026670&displayNews=2253

        Tried it in IE...fails !!!

        Hope somebody else also benefits from all these.

        Unida :)

         
      • Nobody/Anonymous

        More ...

        Followed this
        http://dev.rssowl.org/show_bug.cgi?id=288

        and installed xulrunner on w2k as taken from here
        http://developer.mozilla.org/en/docs/XULRunner_1.8.0.4_Release_Notes

        on machine 1, also a proxy server, java v6, same problem, internal browser fails to displaying news contents. But, this time NO error message "!MESSAGE No more handles [Could not detect registered XULRunner to use]", from View Error Log.

        on machine 2, java 5, connects via proxy to machine1, fails even to connecto to
        proxy server (as before).
        Problem cannot connext to SOCKS proxy:Connection refused:Connect

        Still proxies seem to work fine with other applications.

        Unida :)

         
    • Anonymous - 2007-04-21

      P.S. Error log shows "No more handles [Could not detect registered XULRunner to use]" when I click on first feed at start up, but no error messages as I click news items.

       
      • Benjamin Pasero

        Benjamin Pasero - 2007-04-21

        Weird. The error log message is a expected one and not related. Could you please open a bug report at dev.rssowl.org about this issue so that we can further discuss.

        Thanks,
        Ben

         
    • Anonymous - 2007-04-21
       

Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:





No, thanks