HTTP 400 (bad request) when syncing with GR

Help
DavidM
2011-11-29
2012-08-29
  • DavidM

    DavidM - 2011-11-29

    When I started using RSSOwl in sync with Google Reader the synchronization was
    perfect. But, after a few days, I noticed it stopped working. The sync status
    windows always shows the same message: synchronization failed, HTTP 400 (bad
    request).

    It seems to have succeeded a couple of times afterwards, but as a general
    rule, it continues failing.

    Importing feeds from Google Reader works perfectly.

    Using RSSOwl 2.1.2 on Ubuntu 11.10.

    Log:

    !ENTRY org.rssowl.ui 4 4 2011-11-29 20:37:33.880
    !MESSAGE El servidor devolvió el estado HTTP 400 (Bad Request)
    !STACK 1
    org.rssowl.core.connection.ConnectionException: El servidor devolvió el estado HTTP 400 (Bad Request)
        at org.rssowl.core.internal.connection.DefaultProtocolHandler.internalOpenStream(DefaultProtocolHandler.java:502)
        at org.rssowl.core.internal.connection.DefaultProtocolHandler.openStream(DefaultProtocolHandler.java:388)
        at org.rssowl.core.internal.connection.DefaultProtocolHandler.openStream(DefaultProtocolHandler.java:365)
        at org.rssowl.ui.internal.services.SyncService.sync(SyncService.java:470)
        at org.rssowl.ui.internal.services.SyncService.receive(SyncService.java:313)
        at org.rssowl.core.util.BatchedBuffer$1.run(BatchedBuffer.java:192)
        at org.eclipse.core.internal.jobs.Worker.run(Worker.java:55)
    !SUBENTRY 1 org.rssowl.core 4 4 2011-11-29 20:37:33.880
    !MESSAGE El servidor devolvió el estado HTTP 400 (Bad Request)
    

    Any idea? Thanks.

     
  • Anonymous - 2011-11-29

    Not sure why, GR works fine for me. Maybe its related to your account, you can
    try logging in to Google Reader and see if there is something? If the import
    works then in general things are fine from the authentication perspective.

     
  • DavidM

    DavidM - 2011-12-02

    What should I look for? I have checked all configuration options in GR, can't
    see anything related. I have also erased the GR account in RSSOwl (though not
    the feeds) and synchronized again, introducing again the account and password;
    didn't solve problem. How could I backup my database, so that I can erase
    everything and start over?

    Now I notice that I didn't describe my problem properly:

    RSSOwl imports feeds correctly.

    RSSOwl downloads items from GR correctly.

    Actions on items in RSSOwl (tagging, sticking, reading) do not get transmitted
    to GR.

     
  • genodeftest

    genodeftest - 2011-12-02

    You can find the database location in RSSOwl's FAQ:
    http://www.rssowl.org/help#item_6. The
    easy way is to backup your .rssowl2 directory completely.

     
  • Anonymous - 2011-12-02

    Out of ideas I fear, please use a different reader like Reeder, that's a
    really good one.

     
  • DavidM

    DavidM - 2012-01-07

    I switched to Fedora and I no longer have this problem.

    Curiously, I moved the original .rssowl2 folder from Ubuntu to the new
    installation and suffered the problem again. I then deleted the folder,
    started over importing from GR and imported an OPML file with my old filters
    and preferences. Everything OK now.

     
  • DavidM

    DavidM - 2012-01-10

    Well, the problem came back, but this time I finally solved it and almost
    found its origin.

    When i started using RSSOwl I had a tag named "selección". I eventually
    noticed it had changed to "selecci�n". I think this happened when importing
    tags and filters from a Windows install to a Linux one. I corrected the
    mistake and erased the tag both in RSSOwl and Google Reader.

    Then, at some time, sync stopped working.

    When installing RSSOwl from scratch, and syncing from GR, the "selecci�n" tag
    appeared again. It had not been correctly erased in GR. So I erased it again.
    At this point exactly, sync stopped working. I repeated it three times.

    So, the problem was either the bad character, or the fact that the tag was
    deleted (but at the same time was not deleted) in Google Reader.

     
  • Anonymous - 2012-01-14

    Ah so maybe RSSOwl is struggling with non-ascii tags in Google Reader. There
    is no plans to fix this.

     
  • jocogi

    jocogi - 2012-05-20

    It seems a lot of people, including myself are having this problem. Any sign
    of a solution? I have tried reinstalling, which fixed the problem briefly. I
    have a second test install on another computer, which seems to be ok, but I
    will continue to test it.

    This is really a dealbreaker for me and a lot of others it would seem. A huge
    shame, as I love all the other features in RSSowl. Any other ways we can help?

    Both machines are running Win 7, latest RSSOwl.

     
  • Anonymous - 2012-07-28

    RSSOwl 2.1.4 is out with a fix for the "400 Bad Request" issue when RSSOwl
    tries to synchronize many news to GR. If you are still seeing this issue with
    2.1.4, a workaround is to limit the number of news per feed (using Properties

    Clean Up settings).

     

Log in to post a comment.

Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:

JavaScript is required for this form.





No, thanks