ANyone having sync issues

P Cause
2012-03-18
2012-08-29
1 2 > >> (Page 1 of 2)
  • P Cause

    P Cause - 2012-03-18

    I am having problems with RSSowl showing that it can't sync to google reader.
    I can seem to get downloaded tiems but can't seem to sync the mark read status
    back up. Getting an HTTP 400 error. Here is the log:

    !ENTRY org.rssowl.ui 4 4 2012-03-17 17:31:27.869

    !MESSAGE Server returned HTTP Status 400 (Bad Request)

    !STACK 1

    org.rssowl.core.connection.ConnectionException: Server returned HTTP Status
    400 (Bad Request)

    at org.rssowl.core.internal.connection.DefaultProtocolHandler.internalOpenStre
    am(DefaultProtocolHandler.java:502)

    at org.rssowl.core.internal.connection.DefaultProtocolHandler.openStream(Defau
    ltProtocolHandler.java:388)

    at org.rssowl.core.internal.connection.DefaultProtocolHandler.openStream(Defau
    ltProtocolHandler.java:365)

    at org.rssowl.ui.internal.services.SyncService.sync(SyncService.java:470)

    at org.rssowl.ui.internal.services.SyncService.receive(SyncService.java:313)

    at org.rssowl.core.util.BatchedBuffer$1.run(BatchedBuffer.java:192)

    at org.eclipse.core.internal.jobs.Worker.run(Worker.java:55)

    !SUBENTRY 1 org.rssowl.core 4 4 2012-03-17 17:31:27.870

    !MESSAGE Server returned HTTP Status 400 (Bad Request)

     
  • P Cause

    P Cause - 2012-03-18

    BTW, I had been using after I hadn't been on for several days, Thousand of
    items. I would see some, mark all as read and then get more, even though I
    allow 2000 items per feed and none had 2K items. I even went so far as to
    delete the .rssowl2 directory and start over again. Still getting sync errors.

     
  • P Cause

    P Cause - 2012-03-18

    Sorry, is there a queue of updates that rssowl is trying to make to google and
    perhaps a way to clear that. Would have thought deleteing and starting over
    might have fixed, but...

     
  • jocogi

    jocogi - 2012-05-20

    It seems a lot of people, including myself are having this problem. Any sign
    of a solution? I have tried reinstalling, which fixed the problem briefly. I
    have a second test install on another computer, which seems to be ok for now,
    but I will continue to test it.

    This is really a dealbreaker for me and a lot of others it would seem. A huge
    shame, as I love all the other features in RSSowl. Any other ways we can help?

    Both machines are running Win 7, latest RSSOwl.

     
  • P Cause

    P Cause - 2012-05-20

    I have tried to reinstall a number of times and it always works for a short
    while and then fails again. I am wondering if it is something that changed in
    the JVM as other feedreaders don't seem to have the issue.

     
  • genodeftest

    genodeftest - 2012-05-20

    No, this shouldn't be JVM-related. Maybe some configuration is running amok…

    Can you try starting RSSOwl with -clean parameter from command line?

     
  • jocogi

    jocogi - 2012-05-22

    I tried to run it, but it didn't fix the problem. How can I tell whether the
    command has worked? Should it be back to default settings? Do you need me to
    provide any more info for you? Thanks for your time.

     
  • genodeftest

    genodeftest - 2012-05-22

    Parameter -clean just deletes some temporary files / caches, no data should be
    deleted.

    Are you from a country possibly blocking Google Reader (China, Iran, …) ?

     
  • jocogi

    jocogi - 2012-05-23

    I'm in Australia, so it shouldn't be anything like that. I wonder if it could
    be related to firewalls? Just running standard windows one currently.

     
  • jocogi

    jocogi - 2012-05-25

    I should note that I'm running another copy of RSSOwl on a second machine as a
    test. The machine is running on the same network as my first. I actually
    imported all my settings from my first install. Currently, it has not suffered
    any of the sync problems my primary install has.

    I actually reinstalled my main copy of RSSOwl originally, and while it
    initially fixed the problem, it repeated the problem after a short period of
    time.

     
  • jocogi

    jocogi - 2012-05-29

    Some more relevant information, my test install on my other machine has
    started giving the same bug. It was installed with imported settings from my
    first install though..

    May I ask who the lead developers on this project are?

     
  • genodeftest

    genodeftest - 2012-05-29

    bpasero.

    bpasero recently did most of if not all work on programming. I don't know who
    did what before version 2.x.. But currently bpasero is mostly inactive so I'm
    trying to do some programming on RSSOwl but I just have started to understand
    how it works so I'll need some time. But you may want to help…

     
  • Benjamin Pasero

    Benjamin Pasero - 2012-06-06

    I am now running one week on RSSOwl 2.1.2 with GR and dont have any sync
    issues. So its not an easy problem for me to solve...

     
  • P Cause

    P Cause - 2012-06-07

    Understood and thanks for looking at this and spending time on it. I am using
    Wi7 x64 if that helps.

     
  • Vadim Dmitriev

    Vadim Dmitriev - 2012-06-10

    Hi!

    It my case error 400 was caused by too many items in a single call to google
    reader api. When testing syncing of one feed the limit is about 254 items (IF
    this error is triggered by items count and not POST payload size).

    Limiting maximum batch size should solve the issue.

    Do anyone else here suspect that their sync queue grew over several hundred
    items when the error began to show up?

    ~ Vadim

     
  • P Cause

    P Cause - 2012-06-10

    Yes, that could be it. I often have 300-1000 itemsin a folder and mark as read
    when I am through checking saved searches.

     
  • P Cause

    P Cause - 2012-06-14

    Ok, I can confirm that it looks like this is tied to marking read a lot of
    items. I did a clean install a few days ago and all was good. Then I went 2
    days without using. I have some saved searches and read and mark those read. I
    have a folder of stuff that I mark read after I read the article from the
    saved searches. That folder has 2500+ items. marked read and got the 400
    errors.

    I think Google limits the API to 250 items at a time (saw this in an Android
    reader app). Maybe they changed this since RSSOwl was released.

     
  • jocogi

    jocogi - 2012-06-15

    This looks like as good a lead as any. My kingdom for whoever fixes this
    problem first! (Disclaimer: I may or may not actually have a kingdom.)

     
  • Vadim Dmitriev

    Vadim Dmitriev - 2012-06-26

    Hi. Proposed patch (generated against
    org.rssowl.ui.internal.services.SyncService)

    http://pastebin.com/dG0qgB2u

    Just successfully synced 300+ changes (it may be necessary to re-import all
    feeds for sync to start working as expected again).

    I can upload patched jar, but don't know which file hosting service to use.

     
  • Anonymous - 2012-06-26

    http://www.mediafire.com/ is usually fast.

     
  • Vadim Dmitriev

    Vadim Dmitriev - 2012-06-26

    Wants me to register :(

    Found some sign-free service: http://www.filedropper.com/orgrssowlui212201206
    231628

    Place this file in /plugins and move old version to some other folder (in
    theory plugin with newer version should be picked up in any case, but I'm not
    sure).

     
  • Anonymous - 2012-06-26

    Works perfectly for me, did not need to reimport the feeds, thanks!

     
  • Anonymous - 2012-06-26

    Thanks allati, great job! Really fixed the problem!

     
  • Frank Jungclaus

    Frank Jungclaus - 2012-06-26

    Your patch works like a charm!

    The "Server returned HTTP Status 400"-error finally has gone ...

    Synchronization Status: "The total number of articles synchronized with Google
    Reader since RSSOwl was started is 17209" :-)

    Great job ... Thanks a lot ...

    Frank

     
  • genodeftest

    genodeftest - 2012-07-10

    @allati: Thanks for your help!

    Is anyone still having sync issues?

     
1 2 > >> (Page 1 of 2)

Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:





No, thanks