#928 high CPU utilization after upgraded to 1.5.0.5 (Jubilee)

closed
Dare Obasanjo
9
2012-09-23
2007-01-24
Anonymous
No

Hi,

After upgraded to 1.5.0.5 from 1.3, RSSbandit occupies 100% CPU time. My OS is WinXP Pro, Eng edition, with all patches available on windowsupdate. Let me know if you need other info or log. My email address is pirate585@gmail.com.

Regards,
Eric

Discussion

  • Logged In: NO

    it does that for me too sometimes, when it seems to get into a "Download all RSS entry images" in one go. I don't see why it tries to do that? Perhaps its try to pre-load/cache all images for me?

     
  • Logged In: NO

    I have the same issue.

    I attached the debugger and it seems that something is causing an endless loop in the "Lucene.Net.Analyses.CJK.CJKTokenizer.Next() call.

    Call stack:
    Lucene.Net.Analyses.CJK.CJKTokenizer.Next()
    Lucene.Net.Analysis.StopFilter.Next()
    Lucene.Net.Index.DocumentWriter.InvertDocument(...)
    Lucene.Net.Index.DocumentWriter.AddDocument(...)
    NewsComponents.Search.LuceneIndexModifier.AddSingleDocument(...)
    NewsComponents.Search.LuceneIndexModifier.PerformOperation(...)
    NewsComponents.Search.LuceneIndexModifier.ThreadRun()

    Tried to set a break point on all of the methods on the callstack but they never got called and CPU stayed pegged to 100% for an hour.

     
  • Logged In: YES
    user_id=714452
    Originator: NO

    Can you please provide the UI language you use? The index analyzer depends on it. This would help to track down to the causing lang. specific analyzer.

     
  • Logged In: YES
    user_id=714452
    Originator: NO

    The CJK Analyzer/Tokenizer is used for japanese ("ja") and korean ("ko") languages. So if a weblog post item states it is on one of these languages, it comes into play to analyze/tokenize the post content for index. Can you please verify you subscribed to such feed(s) that provide japanese/korean posts? Can you provide the link(s) here?

    Also: I attached a version of the lucene.net.dll for you to copy over the installation: does the CPU peg still happens? I removed one stopword I guessed causing the error: an empty one was listed (""). Please report back any issues and also the success case!
    File Added: Lucene.Net.1.9.1.2.CJK.stopwords.issue.zip

     
  • Logged In: YES
    user_id=714452
    Originator: NO

    OK, the new lucene.net.dll fix the problem