#401 GUI: Missing position indicator

CVS_version
closed
5
2012-09-23
2005-02-25
No

Today I downloaded the latest 1.3.0.22 snapshot because
it fixed a few bugs I had. Previously I was using a
built about 2 months old.

I am now experiencing that when I cycle through the
unread items via SPACE that the position indicator in
the top feedlist pane will get hidden as soon as I
leave the focus of the feedlist pane.

Thus when I cycle through the feeds via SPACE the focus
is on the bottom part with the feed contents and I
cannot see the marked item in the feedlist pane I am
currently reading.

I feel this is a bit odd and non-standard behavior
compared to all other applications. I hope this is
easily fixable and you can provide an updated snapshot? :-)

Thanks a lot,
Garvin

Discussion

  • Torsten Rendelmann

    Logged In: YES
    user_id=714452

    Dunno what exactly you mean: it does not display the
    highlighting backcolor of selected row(s) in the listview if it
    does not have the focus?
    I tested here with WinXP both manifest for visual styles
    enabled and disabled and cannot repro that. What OS U use?
    A screenshot may help.
    Thanks!

     
  • Garvin Hicking

    Garvin Hicking - 2005-02-26

    Logged In: YES
    user_id=473563

    Yes, the highlighting backcolor of selected roes is what I mean.

    I am running WinXP, latest service packs. However I'm also
    using StyleXP ( as you can see on the screenshot). But it
    works properly in my old Snapshot!

    Files attached, if you need more screenshots, tell me :)

    The first shot (Expected.jpg) shows what I want to see. This
    happens if I click on the listview of entries and leave the
    focus there.

    The second shot (Actual.jpg) shows what I get when I cycle
    through items via SPACE, without having the focus on the
    listview.

     
  • Garvin Hicking

    Garvin Hicking - 2005-02-26

    Expected Behavior

     
  • Garvin Hicking

    Garvin Hicking - 2005-02-26

    Actual Behavior

     
  • Garvin Hicking

    Garvin Hicking - 2005-02-26

    Logged In: YES
    user_id=473563

    Okay, having talked about StyleXP I found out that by
    disabling it, I get the expected behaviour.

    In my StyleXP theme the marking row is a dark blue, and
    using the Standard WinXP theme the marking row is a light
    grey. Can I affect this color somehow? I don't really want
    to drop my WinXP theme and would still like to use RSS
    Bandit. I'd hate to use an old snapshot forever now :-D

    I hope there'll be a fix? If I can/should try out anything,
    please let me know.

    Regards,
    Garvin

     
  • Torsten Rendelmann

    Logged In: YES
    user_id=714452

    What version of StyleXP U use?

     
  • Garvin Hicking

    Garvin Hicking - 2005-02-27

    Logged In: YES
    user_id=473563

    I was using 2.16 previously, but I just upgraded to latest
    3.01. But still it's the same problem.

    When hitting 'space' I see the Balken flickering over the
    active item, but then it seems to change its color to the
    list background color and I can't see it anymore...

     
  • Torsten Rendelmann

    Logged In: YES
    user_id=714452

    What StyleXP Theme you used? I cannot find it here in the
    initial install (Men)...

    Can you try this binaries again:
    http://rssbandit.sourceforge.net/builds/RssBandit.1.3.0.23.Wo
    lverine.Beta2.zip ?
    At least the Panther theme renders fine here for the issue
    you described (except some problems with form buttons
    where some texts not fit to the width of the button; dunno
    how comes, but the width itself cannot cause the problem
    here, "OK" for example is only two characters, but always
    miss the last character rendered)

     
  • Garvin Hicking

    Garvin Hicking - 2005-02-27

    Logged In: YES
    user_id=473563

    I'm using a 'Coughdrop' version theme.

    Using the built you offered sadly doesn't change a thing.

    I'll mail you a URL to get the theme. :)

     
  • Torsten Rendelmann

    Logged In: YES
    user_id=714452

    Not our issue: the custom StyleXP theme was not defined
    correctly.

     
  • Garvin Hicking

    Garvin Hicking - 2005-02-28

    Logged In: YES
    user_id=473563

    Strange only because it was working with all previous RSS
    Bandit releases. :-)

    I would be happy if you could also tell me what "was not
    defined correctly" means. Thanks.

     

Log in to post a comment.

Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:

JavaScript is required for this form.





No, thanks