Running In OSX

  • Nobody/Anonymous

    I've downloaded MapTool and am attempting to run it with OSX. I understand that the website never mentions OSX but I thought someone may have some insight into what the problem might be.

    When I try to run the program from a terminal I get this:

    jarException in thread "main" java.lang.UnsupportedClassVersionError: net/rptools/maptool/client/MapTool (Unsupported major.minor version 49.0)
            at java.lang.ClassLoader.defineClass0(Native Method)
            at java.lang.ClassLoader.defineClass(
            at Method)
            at java.lang.ClassLoader.loadClass(
            at sun.misc.Launcher$AppClassLoader.loadClass(
            at java.lang.ClassLoader.loadClass(
            at java.lang.ClassLoader.loadClassInternal(

    Could it ever be possible to run within OSX?

    • Michael Rice

      Michael Rice - 2005-11-11

      Thanks for checking out the tools! (or attempting to)

      I think one of our other posters mentioned running on OSX, so it's possible.

      I believe the error you are getting is from a Java version mismatch -- please ensure that you are using Java 1.5.   Let us know what version you are using -- if it's already 1.5 we can look into compatibility problems and warn future users.

    • Nobody/Anonymous

      Okay, a little followup. I tried using a workaround for OSX Panther to use java 1.5, which still had troubles running maptool. Upgrading to OSX Tiger and then using the official java 1.5 update worked fine, and it was able to run maptool!

      • Trevor Croft

        Trevor Croft - 2005-11-22

        That's unfortunate that Panther doesn't support 1.5 very well.  Post 1.0 I think we'll investigate that further in case others are trying to do that.

        In the mean time, let us know if you have any problems on Tiger and we'll make sure to address them !

    • Brisingre

      Brisingre - 2005-12-28

      I don't think it would hurt to put some of this in the docs, because many people don't check the forums. Esp. the bit about OSX Tiger working and Panther not.


Log in to post a comment.

Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:

JavaScript is required for this form.

No, thanks