Connection Problems

Help
Ikonoklast
2005-10-01
2013-05-23
1 2 > >> (Page 1 of 2)
  • Ikonoklast

    Ikonoklast - 2005-10-01

    When trying to connect to a friends server or he tries to connect to my server we both get.

    IO Error:java.net.ConnectException: Connection timed out: connect

    We both have opened the ports on our routers and even set our selfs as dmz hosts be we keep getting the same error.

    Does anyone have any suggestions.

     
    • Trevor Croft

      Trevor Croft - 2005-10-02

      I'm going to make an assumption that your are using windows (let me know if this isn't the case) ?  Make sure any software firewalls are disabled (I've had the worst experiences with XP artificially restricting my machine). 

      If that doesn't help, you should try bypassing the router on both ends.

      You might also try starting your server and have your friend try to 'telnet your_ip_address 4444' where 4444 is the port you started your server with on the Start Server dialog.  If you don't get a response then it's a network configuration.  If you can connect (that is, it doesn't time out, or complain in some way) then it is the game and we'll need some further diagnostics from you.

      Let me know how it goes.

       
    • Ikonoklast

      Ikonoklast - 2005-10-03

      We were able to get it working but just not on port 4444.  We never figure it out so we just ended up using a different port.

       
      • Trevor Croft

        Trevor Croft - 2005-10-03

        Weird.  Well, at least it is working :)  Let us know if you have any other problems.

        Also be sure to provide feedback ;)  We're in the middle of making significant user interface updates for M6, so let us know if there's anything you'd like to change.

         
      • Michael Rice

        Michael Rice - 2005-10-03

        What port did you eventually get it working on?

        What OS?  What router/firewalls were in the setup?

        We'd certainly like to understand the problem so that we can configure around it or warn other users.

        Thanks!

         
    • Nobody/Anonymous

      the map tool will not let a mac on i can't access map tool

       
      • Trevor Croft

        Trevor Croft - 2005-12-26

        Could you provide a couple more details ?  What version of Mac ?  What version of Java ?  When is the error happening ?  Is it before the tool comes up ?  Or just preventing you from connecting to someone else ?

         
    • Nobody/Anonymous

      Correction the error was IO error: java.net.ConnectException: Connection refused: connect which is similar but differant, to me it suggests that I left some security running, and that the pc was refusing the connection, not that the connection was not being made somewhere in the software, but I still need help.

       
      • Trevor Croft

        Trevor Croft - 2005-12-26

        So that's the error you are getting when trying to connect to a different computer ?  It sounds like they need to open up the port the server is running on.  When they "Start Server" the dialog asks which port to run on.  They need to set their router to open up that port.

         
    • Nobody/Anonymous

      For some wierd reason the post that that was a correction to didn't take, so here is the relevant bits. I am a bit of a newbie and didn't understand those directions, I got rid of the two firewalls I know about, I am connecting two different maptool windows on one pc (To see what the Player window looks like and to check if the connection software worked), I am running XP, I tried changing the port, it didn't help. I would like some help please.

       
      • Trevor Croft

        Trevor Croft - 2005-12-26

        Ahh gotcha.  Ok, trying to run two on the same computer.  Windows XP doesn't like to play nicely with unknown servers opening ports. 

        You might try disabling the firewall on the PC.  You can find instructions here:  http://www.microsoft.com/windowsxp/using/networking/learnmore/icf.mspx

        Let me know if this helps or not.  You can email me directly if you like and we can work out the kinks.

         
    • Nobody/Anonymous

      Thanx, but I had already dealt with that firewall. Quite possibly it is just trying to connect to the same computer, but the friend I tried to get to connect on his computer first tried on a clunky old mac and then on a laptop, and never called back to even say that he had got the software running, so that didn't work. I would like to know how to configure the router to open ports, as I am utterly clueless about this. Thanks.

       
      • Trevor Croft

        Trevor Croft - 2006-01-04

        Did you ever get this resolved ?  If not, contact my directly at my sourceforge email and we'll work through it :)

         
    • Nobody/Anonymous

      I'm having a slightly different connection problem.  I'm running on winxp, and am fairly sure I have the windows firewall down at the moment.  However, mIRC and ipconfig are giving me two different answers about what my IP is.  trying both, my friend gets "IO error : java.connectevception: connection refused: connect".  Oddly, when the server isn't active,  it timed out on the connection attempt.  any ideas what's happening?

       
      • Michael Rice

        Michael Rice - 2006-01-12

        Use the one from mIRC, or http://www.whatismyip.com/ for people outside your house trying to connect.  Use the one from ipconfig for machines inside your house trying to connect.

        One of the devices your PC is connected to is providing a service called either NAT or PAT.  It is likely this device is also providing firewall service.  This could be a separate device from your DSL modem but this would have to be obvious to you as it would be between your modem and your PC.  Or it could be built-in to your DSL modem.

        First: Fire up maptool on your PC twice, the first one as a GM, the second as a player.  In the player one, use 'localhost' as the IP address to connect to.  If this one can connect, disconnect and have it use the IP address as reported by ipconfig.

        Second: if you have a second machine in your house, connect to the IP address as reported by ipconfig from it.

        Third: get with someone to test connecting to a "known" working maptool.  We'd be happy to work with anyone to work out the kinks, we're all in the CST6CDT timezone.

        Fourth: Work with us to get connected to your maptool.

        If you don't have control of your firewall device it may not be possible to open _any_ ports for maptool to work.  If you rent the box you can check on this with your provider.  If you own it you may be able to post the make and model here and someone may have information to help.

         
    • emryys

      emryys - 2006-01-12

      Try this site to get your outside IP...
      http://www.whatismyip.com/
      If you have a router you have to forward the port it's using, but at least you get to choose the port you want :)

       
    • Nobody/Anonymous

      That site gave the same address as mIRC.  I don't have a router, but I think I might be effectively behind one thanks to my ISP.  its DSL if that makes any difference

       
    • emryys

      emryys - 2006-01-12

      Both the GM server, and the player server have to choose the same port. I know it sounds obviuos but hell...I did it :)  Then I caught on ;) The GM has to be up first as well...

       
    • Nobody/Anonymous

      GM server has been up, as I said, it got a different error message when it wasn't up.  and we used the default 4444 each time.  a different test setup got the same results out of both of us using port 3456.

       
    • emryys

      emryys - 2006-01-12

      I'm stumped...maybe turn on a firewall to see what it says. Maybe the info can tell you where it's blocking or if it's even reaching the computer

       
      • Trevor Croft

        Trevor Croft - 2006-01-12

        What does the network look like between the two computers ?  Are you both on the same lan (to the same hub at someone's house, for example), or across the internet (through your DSL to the other person's DSL) ?

        Do you have a skype number, or IM (AIM, MSN) ?  If so, email me the info and I"ll send you mine and we can get in touch in real time and figure it out :)

         
    • Brisingre

      Brisingre - 2006-01-12

      I was connecting two maptools by typing my own IP, rather than using Localhost. it's fixed for now.

       
      • Trevor Croft

        Trevor Croft - 2006-01-12

        On a side note, I'm working on a separate library that does service announcement and discovery. 

        Which will make it possible to have the Connect To Server dialog show a list of all other maptool instances running on your local area network (not across the internet, although that one is in the planning stages)

         
    • Killydd

      Killydd - 2006-01-13

      results of opening a second instance on the same computer: 

      I was able to connect to localhost
      I was able to connect to the ip that ipconfig gave me
      connection timed out when I attempted to connect to whatismyip's belief. 

       
      • Michael Rice

        Michael Rice - 2006-01-13

        That's great and perfectly expected, here's why:

        "I was able to connect to localhost"

        This tells us the tools are working properly.  Localhost is special in that in most OSes it is not firewalled by the OS software.  so it is the most likely to work no matter what network security is in place.

        "I was able to connect to the ip that ipconfig gave me "

        This is fantastic, this is what players on your LAN will use (they can't use 'localhost' as that would attempt to connect back to themselves).  This means that your software firewall is permissive enough on your local machine that other  players on your LAN will be able to use maptool with you.  This is a crucial first step to getting it to work with WAN players.

        "connection timed out when I attempted to connect to whatismyip's belief."

        This is fine for two reasons.  First is that if other players cannot connect to this IP address either, we know where to look for tweaks.  Second is that typically you won't be able to connect to yourself through this IP address, many firewall/router/bridges (your "modem" is one or more of these) don't handle NAT from/to the same address -- meaning  you're coming from the inside, it doesn't take your packet and put it back on the outside to let it come back through.

        Your results strongly suggest that we should be looking at your network connection (firewall/bridge/modem) to your ISP and/or your ISP for additional clues.

        Get in touch with me via email (click my name in the forums then click "Send this user a message")... we can set up a time to get together on this.

         
1 2 > >> (Page 1 of 2)

Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:





No, thanks