#90 Build fails in Cent OS 5.8

Next_release
closed
nobody
None
1
2014-01-13
2012-11-27
Anonymous
No

Build instructions are poor.

What rpm's/packages are required to build this ?

They should accurately be listed in the INSTALL
guide and where to get them from.

[root@b-17 roxterm-2.6.5]# ./mscript.py help
Traceback (most recent call last):
File "./mscript.py", line 5, in ?
from maitch import *
File "/root/roxterm-2.6.5/maitch.py", line 36
with _mprint_lock:
^

John.Donnelly@eucalyptus.com

Discussion

  • Tony Houghton

    Tony Houghton - 2012-11-27

    It looks like your version of python is too old to support the "with" statement http://docs.python.org/2/whatsnew/2.6.html#pep-343-the-with-statement. I didn't realise 2.4 was still in common use. Can you install a newer version?

    The script can be rewritten without the with statement of course, but you'd need to be reasonably familiar with python. I should probably do this for the next release seeing as python 2.4 was still in use on such recent distros.

     
  • Tony Houghton

    Tony Houghton - 2013-02-27

    I've fixed this in git and will hopefully make a release in the next few days.

     
  • Tony Houghton

    Tony Houghton - 2013-03-01
    • milestone: v1.0_(example) --> Next_release
     
  • Tony Houghton

    Tony Houghton - 2013-04-14

    Can you confirm whether 2.7.1 builds with python 2.4?

     
  • Tony Houghton

    Tony Houghton - 2014-01-13
    • status: open --> closed
     


Anonymous

Cancel  Add attachments





Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:





No, thanks