#928 Never-ending notes when using matrix editor.

closed
matrix (53)
8
2012-09-16
2006-04-29
No

Some time ago, Richard Cooper said:

Sometimes, in the matrix editor, when I click on a
note and Rosegarden plays that note,
it never sends a note off event for that note.
Usually it does, but it sometimes justgets into a mode
where it won't send note offs for any note that is
clicked on.

It seems that if you play back part of a song, then
stop playback, and then click on notes in the matrix
editor (in the grid, not the little keyboard to the
side), they play for a short 1/4 of a second, but if
you then use the playback controls to move the playback
position (either move it to the beginning of the song
or move it forward or back a measure) then clicking on
a note causes that note to play forever. If I then
clicking the play button and then the stop button, then
the notes return to their desired behaviour of
terminating after 1/4 of a second.

To be able to reproduce the problem:
1) JACK must be running before starting Rosegarden.
2) Settings -> Configure Rosegarden -> Sequencer ->
Synchronisation -> JACK transport mode == Sync

The problem looks (hears) different with MIDI
instruments and with DSSI ones. With MIDI there are
lost NoteOff events, making the notes to sound forever,
until you use the play/stop controls. With DSSI
instruments, you simply don't hear the notes when
clicking over the note rectangles, but the notes will
sound suddenly all together when you press the "play"
transport button.

Discussion

  • Pedro Lopez-Cabanillas

    Logged In: YES
    user_id=624187

    It is not only the matrix view: also the notation view has
    the same behavior, and even the preview feature of the
    metronome configuration. Hope to fix it this afternoon.

     
  • Pedro Lopez-Cabanillas

    Logged In: YES
    user_id=624187

    A preliminary fix is in trunk. Revision #7222

     
  • Pedro Lopez-Cabanillas

    Logged In: YES
    user_id=624187

    Richard Cooper reports that this issue is fixed.

    Pending to apply the same fix to stable_1_2_4

     
  • Pedro Lopez-Cabanillas

    Logged In: YES
    user_id=624187

    Applied the fix to the stable branch. Revision #7253.

     
  • SourceForge Robot

    Logged In: YES
    user_id=1312539

    This Tracker item was closed automatically by the system. It was
    previously set to a Pending status, and the original submitter
    did not respond within 14 days (the time period specified by
    the administrator of this Tracker).

     

Log in to post a comment.