install on SUSE 10.1?

Help
magicFoo
2006-12-13
2013-04-23
  • magicFoo

    magicFoo - 2006-12-13

    Hello,

    I'm looking for a hint for on installing for SUSE 10.1?

    I was able to run config and make.
    Do I need to generate a RPM and install from there?

    Thanks,
    magicFoo

     
    • kouretasgoat

      kouretasgoat - 2006-12-13

      It's been a while since I did this, but I think you're right.  You need to use something in the OS to convert the make'd file to a platform-specific RPM.

      I was never able to get communication between Ubuntu and my Nitrus, so this is about the extent of my experience.

       
    • magicFoo

      magicFoo - 2006-12-14

      I have it working now... some notes from my install...

      * I did not end up making a package, I just needed to run ./config, make, make install

      * For a reason I don't understand, I needed to reboot to get rioutil to run...
        I was getting an error about the rioutil .so lib missing at first.

      * When I went to build the kernel module, I got an error message
        "The present kernel configuration has modules disabled"...
        I did a 'make oldconfig' to get around this.

      * I honestly don't know how/why my install of rioutil is working, since I'm unable to
        load the kernel module.

        % insmod rio500
        insmod: can't read 'rio500': No such file or directory
       
        Also, I do not see anything for the rio in my /dev/usb dir

      * I can only access the device as root. Seems like there are several fixes for this
        already mentioned elsewhere on the help message board.

      I can list, delete, and upload files to my S35S, so I'm happy :)
      Next I'll probably check into a GUI for it.

      Thanks to all who help us get away from Microsoft!! MP3 player was my last hurdle.
      I loaded SUSE 3 months ago and have not needed my old Windows PC yet!

       
      • Anonymous - 2006-12-14

        Hey there!

        I had similar issues when I installe rioutil. I’m using Archlinuq so I had to find a way to package it for pacman, which was the minor issue.

        I had more problems getting rioutil to compile for me. It then worked without the module (which is in the kernel since over a year I think) but only as root. But since some days, rioutil always segfaults when I want to put some files on my Rio S35S. Formatting, listing and informing works without a flaw. Loading songs onto the Rio also works under Windows, so the problem has to be rioutil. I’ll try to install an old kernel, currently, I’m using 2.6.19-ck2.

        Which kernel are you using?

        Greetings, hellwoofa

         
    • magicFoo

      magicFoo - 2006-12-14

      Hi hellwoofa,

      My kernel is 2.6.16.13-4-smp. You are using SUSE also?

      I'm not familiar with Archlinuq, and I haven't ever re-built my kernel before.

      magicFoo

       
      • Anonymous - 2006-12-15

        Hey :)

        Sorry, I misspelled it. I’m using Archlinux, not Suse. Archlinux is a bit more ‚looking under the hood‘, but it does not need the user to compile his own kernel.

        I just tried to acces my rio on my laptop which uses still 2.6.18-serieses of kernel and it worked without a flaw, so tomorrow, I’m going to try it with an older Kernel on my Desktop and tell about the results :)

         

Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:





No, thanks