Rio Nitrus Info...

  • Jesse Raleigh

    Jesse Raleigh - 2004-12-21

    Hello all,

    I just recently purchased 2 rio nitrus' under the impression that they were supported.  I have since found that they are indeed not supported, or not well supported at least.  I've been trying to get the latest (not cvs) rioutil to see it, with no success.  I thought perhaps a dump of /proc/bus/usb/devices would help by providing some more information to someone with a better grasp of C than I posses.

    T:  Bus=01 Lev=02 Prnt=02 Port=02 Cnt=01 Dev#=  7 Spd=480 MxCh= 0
    D:  Ver= 2.00 Cls=00(>ifc ) Sub=00 Prot=00 MxPS=64 #Cfgs=  1
    P:  Vendor=045a ProdID=5220 Rev= 0.00
    S:  Manufacturer=DNNA Inc.
    S:  Product=Rio Nitrus
    S:  SerialNumber=111122223334
    C:* #Ifs= 1 Cfg#= 1 Atr=80 MxPwr=500mA
    I:  If#= 0 Alt= 0 #EPs= 2 Cls=00(>ifc ) Sub=00 Prot=00 Driver=(none)
    E:  Ad=81(I) Atr=02(Bulk) MxPS= 512 Ivl=0ms
    E:  Ad=02(O) Atr=02(Bulk) MxPS= 512 Ivl=0ms

    [root@dhcp13 usb]# rioutil -e 2 -i
    Attempting to open Rio and retrieve song list....open_rio: creating new rio instance. device: 0x00000000
    open_rio: setting usb driver verbosity level to 1
    usb_set_debug: Setting debugging level to 1 (on)
    usb_os_init: Found USB VFS at /proc/bus/usb
    USB Device: idVendor = 00000000, idProduct = 00000000
    USB Device: idVendor = 0000046d, idProduct = 0000c01b
    USB Device: idVendor = 00000000, idProduct = 00000000
    USB Device: idVendor = 00000000, idProduct = 00000000
    USB Device: idVendor = 0000045a, idProduct = 00005220
    USB Device: idVendor = 000004dd, idProduct = 00008004
    USB Device: idVendor = 0000050d, idProduct = 00000217
    USB Device: idVendor = 00000000, idProduct = 00000000
    Error -1: open_rio: could not open a Rio device

    Device not found.
    library tried to use method: libusb

    One thing to note. I changed rio_usb.h to match the product code of the nitrus, as it was the closest match.
    One thing of interest is that the vendor id is still 045a, which was already in rio_usb.h

    #define PRODUCT_RIORIOT   0x5220

    • Jesse Raleigh

      Jesse Raleigh - 2004-12-22

      Something else to note.

      Last night I went through the sources, and changed the product code for RIOCALI everywhere I could find it as follows.

      //#define PRODUCT_RIOCALI   0x500f
      #define PRODUCT_RIOCALI   0x5220

      after doing so and recompiling, I was able to get some data from the rio nitrus with rioutil -e 2 -i.  I would post the output here, but it's 47K of text.  If anyone would be interested in that output, please contact me through and I will provide it.  I would really appreciate any help anyone could provide me in trying to get nitrus support in rioutil.  My only other option is to send back my two brand new rio's.

    • kouretasgoat

      kouretasgoat - 2006-09-25

      I'm also having a connection problem with my Nitrus. 

      When I type...

      sudo rioutil -i the terminal prompt, I get...

      Attempting to open Rio and retrieve song list.... failed!
      Reason: No such file or directory.
      librioutil tried to use method: libusb

      The Nitrus is connected and displaying the "Waiting..." message.

      I'm running Ubuntu 5.10, if that matters. 

      PS: speak slowly.  total noob.


Log in to post a comment.