Rgedit with Ubuntu 12.04

  • Dryden

    Dryden - 2012-05-31


    I would like to upgrade my OS from 11.04 to 12.04, but unfortunately I've been having trouble with Rgedit when I upgrade. Also, I'm using the LXDE desktop not Unity or Gnome.

    Straight out of a fresh install (or live boot) I install gedit then go through the process of extracting the most up-to-date Rgedit to the appropriate Gnome 3 directory as stated in the help file. I subsequently open up gedit, check the "R integration" and open up an R script. I try to go to the "R" drop down menu at the top to change the R interface settings and nothing happens. As it turns out, none of the options in the "R" dropdown menu do anything. Nothing crashes, but they simply do nothing.

    I've noticed that other people have fixed problems associated with 11.10 and I would assume gedit in 12.04 hasn't changed (as it appears I'm the first to mention this problem). Is it possible it's a problem due to the LXDE desktop? I'm not a Linux expert so I don't have an idea why it doesn't work.

    Thanks for the help.

  • Dan Dediu

    Dan Dediu - 2012-06-03


    could you please post any messages that are displayed when you launch gedit from a command line? I do not know what might be casue as you seem the first to report any problems…


  • Dryden

    Dryden - 2012-06-05

    Ahhh, running programs from the terminal DOES have its advantages.
    I figured out the problem once I read the error messages from the terminal.

    Initially, when I read through the rgedit readme it stated that I should extract the files to the directory ~/.local/share/gedit/plugins for gedit3. Which I did. Then I ran gedit, and there was no option within the gedit plugin preferences for "R Integration". Then I noticed after running gedit that ~/.local/share/gedit/plugins had no other plugins within it. I knew there should be others, so I figured that the LXDE desktop must have installed the directory somewhere else. I promptly found out that the settings and plugins folder was installed in the directory ~/usr/lib/gedit/plugins. So I deleted the old folder and files that I had initially created and extracted all of the rgedit files into this new directory. I then ran gedit and incredibly the "R Integration" option was there. I enabled it and subsequently tried out the plugin within gedit.

    That is what led me to post my question. Nothing would work nor run with the plugin.

    Once I ran it in the terminal, the message said that it couldn't find the files within the ~/.local/share/gedit/plugins folder (that I had deleted). I immediately realized that you must have hard coded in that directory into your plugin. I then extracted all of the rgedit files to the ~/.local/share/gedit/plugins folder (which means that I have two duplicate sets in two locations). It fixed the problem completely the next time I ran gedit. Everything works as it had on the older OS.

    Sorry for the lengthy story, but I figured I would try to be thorough.
    Thank you very much for your terminal recommendation.

  • Dan Dediu

    Dan Dediu - 2012-06-05

    great that it worked! I didn't yet have a 12.04 install but it seems I should…



Log in to post a comment.