Rgedit in Oneiric Ocelot

Help
Pierre
2011-10-14
2013-04-05
1 2 > >> (Page 1 of 2)
  • Pierre

    Pierre - 2011-10-14

    Hi,

    When I upgrade my ubuntu version from 11 04 Natty Narwhal to 11 10 Oneiric Ocelot, the R insertion package disappeared in my gedit plugin menu. The files are still in /home/#user/.gnome2/gedit/plugins but they have no more effect. Did it happen to someone else ? Is there a fix ? I have tried to download the latest version to replace the files but it did not change anything.

     
  • Andres Gonzalez

    Andres Gonzalez - 2011-10-17

    Hi, I have the same issue. I upgrade my ubuntu version . I download and install rgedit-0.7.1.0-Gtk3 on  ~/.local/share/gedit/plugins folder, but the plugin would not work up in Gedit3. Is very important to me fix this issue……The same issue in http://ubuntuforums.org/showthread.php?p=11341123#post11341123

    Andrés

     
  • Andres Gonzalez

    Andres Gonzalez - 2011-10-17

    This is the error found when open gedit on terminal:

    Traceback (most recent call last):
      File "/home/andrew/.local/share/gedit/plugins/RCtrl.py", line 2780, in do_activate
        self._instances = RCtrlWindowHelper(self, self.window)
      File "/home/andrew/.local/share/gedit/plugins/RCtrl.py", line 1374, in __init__
        self._insert_menu()
      File "/home/andrew/.local/share/gedit/plugins/RCtrl.py", line 1817, in _insert_menu
        self.createRGeditTerminal()
      File "/home/andrew/.local/share/gedit/plugins/RCtrl.py", line 2448, in createRGeditTerminal
        self.R_widget = RGeditTerminal(self._plugin)
      File "/home/andrew/.local/share/gedit/plugins/RCtrl.py", line 221, in __init__
        self.reconfigure_vte(self._vte,1)
      File "/home/andrew/.local/share/gedit/plugins/RCtrl.py", line 301, in reconfigure_vte
        _vteN.set_colors(fg, bg, palette)
    TypeError: 'Color' object does not support indexing

    A,

     
  • Arne Henningsen

    Arne Henningsen - 2011-10-17

    Same problem after upgrading to Oneiric Ocelot on my computer :-(

    /Arne

     
  • Martin Hanel

    Martin Hanel - 2011-10-17

    Same for me … still any solution found …

     
  • Andres Gonzalez

    Andres Gonzalez - 2011-10-18

    @vincegata thanks for instructions, but these procedure is already in  RCtrl.plugin file
    I follow ReadMe installation and I can activate the plugin menu but rgedit dont work!!! this is very frustrating :/

    Dan Dediu (developer) any help please!

     
  • Dan Dediu

    Dan Dediu - 2011-10-18

    Hi guys,

    sorry for the delay but for some reason I have not been notified by this activity :(
    Anyway, it seems the problem is that the new Ubuntu switched to Gnome3/Gtk3 which is completely different thing from the previous Gtk2. However, there's a Gtk3 version of rgedit (rgedit-0.7.1.0-Gtk3.tar.bz2) - please note also the slightly different plungin paths as pointed out by vincegata above!

    This I have been using this Gtk3 version for several months now on a Feadora 15 install which also used Gnome3/Gtk3.

    Please let me know if there are still issues.

    Dan

     
  • Martin Hanel

    Martin Hanel - 2011-10-18

    Hi Dan,
    first of all thanks for the great plugin!
    As I understand, me and others already used the Gtk3 version and there is still some issue - the plugin shows in gedit, however does not work - the dialogues do not popup and it is impossible to start R tab.
    The terminal shows following (as already noted by agl001):

    Traceback (most recent call last):
      File "/home/mha/.local/share/gedit/plugins/RCtrl.py", line 2073, in on_create_new_R_tab
        self.createRGeditTerminal()
      File "/home/mha/.local/share/gedit/plugins/RCtrl.py", line 2448, in createRGeditTerminal
        self.R_widget = RGeditTerminal(self._plugin)
      File "/home/mha/.local/share/gedit/plugins/RCtrl.py", line 221, in __init__
        self.reconfigure_vte(self._vte,1)
      File "/home/mha/.local/share/gedit/plugins/RCtrl.py", line 301, in reconfigure_vte
        _vteN.set_colors(fg, bg, palette)
    TypeError: 'Color' object does not support indexing

    Something similar is described here https://bugs.launchpad.net/checkbox/+bug/839675

    Thanks for any suggestion.
    Martin

     
  • Dan Dediu

    Dan Dediu - 2011-10-19

    ah, mea culpa then: I'll install Oneiric in a VBox and try to fix it as soon as possible. I assumed that if it works on two Gtk3 distros (Fedora 15 and Arch) it should also on Ubuntu but it looks like it is not :(
    I hope to have a look this evening if I have the time.

    Best,
    Dan

     
  • Dan Dediu

    Dan Dediu - 2011-10-19

    Hi guys,

    for some reason, python + Gtk3 in Oneiric differs from that in Fedora 15 and Arch! I fixed the things and I hope the new version 0.7.1.1-Gtk3 (now the default download) works! Please test it carefully and let me know if everything's ok.

    As a side note, the version in Ubuntu's own repository is still the old Gtk2 (as opposed to Debian Sid which has the proper Gtk3 version) so all users of rgedit on Ubuntu 11.01 should somehow be made aware that the only way to have a working rgedit is by installing it manually from here (and to pay attention to the new plugins folder) - could the Ubuntu users please help spreading this message?

    Best,
    Dan

     
  • Martin Hanel

    Martin Hanel - 2011-10-19

    Thank you very much Dan,
    this version works (for me) without any problems.

    Regards
    martin

     
  • Pierre

    Pierre - 2011-10-20

    Thanks Dan, it works.

    Pierre

     
  • Dan Dediu

    Dan Dediu - 2011-10-20

    good :)

     
  • grizzlywhaler

    grizzlywhaler - 2011-10-21

    Did not work for me.  Ubuntu 10.10 amd-64.  Yes, I used the "local" location for plugins per instructions.  When R-integration is activated, editor crashes.  It will not re-open until deleting the plugin files and log-off plus log-on

     
  • Dan Dediu

    Dan Dediu - 2011-10-21

    Hi grizzlywhaler,

    sorry to hear that. Is gedit3 working on Ubuntu 10.10?

     
  • Anonymous

    Anonymous - 2011-10-28

    Sorry to say that it also doesn't work for me. I'm running Ubuntu 11.10 and gedit 3.2.1. I copied the content of rgedit-0.7.1.1-Gtk3.tar.gz to the .local/share/gedit/plugins directory.

    Gedit works fine when the RGedit plugin is not activated. But as soon as I activate it, gedit crashes. If I then try to start gedit from the terminal, I get the following message:

    ~$ gedit
    /usr/lib/python2.7/dist-packages/gobject/constants.py:24: Warning: g_boxed_type_register_static: assertion `g_type_from_name (name) == 0' failed
      import gobject._gobject
    /usr/lib/python2.7/dist-packages/gtk-2.0/gtk/__init__.py:40: Warning: specified class size for type `PyGtkGenericCellRenderer' is smaller than the parent type's `GtkCellRenderer' class size
      from gtk import _gtk
    /usr/lib/python2.7/dist-packages/gtk-2.0/gtk/__init__.py:40: Warning: g_type_get_qdata: assertion `node != NULL' failed
      from gtk import _gtk
    Erreur de segmentation
    

    I find this plugin extremely useful; I will thus be grateful if you make it work again for me!

     
  • Dan Dediu

    Dan Dediu - 2011-10-28

    Hi,

    sorry to hear that rgedit is not working for you. I just tested it on my updated vbox Oneiric and seems to have no issues.

    Unfortunately, the trace is not very helpful but seems to be some sort of conflict between gtk2 and gtk3 ??? Do you have any weird configuration for your system? I can't seem to reporduce it, as I said, on my updated out-of-the-box Oneiric VBox install :(

    Dan

     
  • Anonymous

    Anonymous - 2011-10-28

    Thanks for the fast reply.

    My install of Ubuntu is certainly not out-of-the-box but I cannot spot just now what makes the problem. Can you suggest an investigation strategy?

    Two other pieces of information:
    1- Others had the same error message trying to run different plugins (for different applications). For instance:
    https://bugs.launchpad.net/gnome-dvb-daemon/+bug/846631
    and
    https://bugs.launchpad.net/ubuntu/+source/totem/+bug/855100

    In these cases, people said it was due to "a conflict between static and dynamic pygobject bindings" and to the fact that "that plugin imports another static module which in turn imports gobject".  I don't know what that means but you might. Anyway, the problem was fixed in these two cases.

    2- Perhaps I could find the culprit if you give me the list of packages installed on your out-of-the-box Ubuntu.

    Here's my list of packages including "python" in their name:

    ~$ dpkg --get-selections | grep python
    diveintopython                  install
    krosspython                 install
    libboost-python1.35.0               deinstall
    libboost-python1.38.0               deinstall
    libboost-python1.42.0               deinstall
    libboost-python1.46.1               install
    libpython2.6                    deinstall
    libpython2.7                    install
    python                      install
    python-appindicator             install
    python-apport                   install
    python-apt                  install
    python-apt-common               install
    python-aptdaemon                install
    python-aptdaemon-gtk                install
    python-aptdaemon.gtk3widgets            install
    python-aptdaemon.gtkwidgets         install
    python-argparse                 install
    python-at-spi                   install
    python-avahi                    install
    python-avogadro                 install
    python-axiom                    install
    python-beautifulsoup                install
    python-bittorrent               install
    python-brlapi                   install
    python-cairo                    install
    python-central                  install
    python-chardet                  install
    python-cherrypy3                install
    python-clientform               install
    python-coherence                install
    python-compizconfig             install
    python-configglue               install
    python-configobj                install
    python-couchdb                  install
    python-crypto                   install
    python-cssutils                 install
    python-cssutils-doc             install
    python-cups                 install
    python-cupshelpers              install
    python-dateutil                 install
    python-dbus                 install
    python-debian                   install
    python-defer                    install
    python-desktopcouch-application         install
    python-desktopcouch-records         install
    python-django                   install
    python-django-tagging               install
    python-dnspython                install
    python-egenix-mxdatetime            install
    python-egenix-mxtools               install
    python-enchant                  install
    python-encutils                 install
    python-epsilon                  install
    python-farsight                 install
    python-feedparser               install
    python-gconf                    install
    python-gdbm                 install
    python-glade2                   install
    python-gmenu                    install
    python-gnome2                   install
    python-gnomekeyring             install
    python-gnupginterface               install
    python-gobject                  install
    python-gobject-2                install
    python-gobject-cairo                install
    python-gobject-dbg              deinstall
    python-gst0.10                  install
    python-gtk2                 install
    python-httplib2                 install
    python-ibus                 install
    python-imaging                  install
    python-imaging-tk               install
    python-indicate                 install
    python-kde4                 install
    python-keyring                  install
    python-launchpad-integration            install
    python-launchpadlib             install
    python-lazr.restfulclient           install
    python-lazr.uri                 install
    python-libproxy                 install
    python-libxml2                  install
    python-louie                    install
    python-louis                    install
    python-lxml                 install
    python-mako                 install
    python-markupsafe               install
    python-mechanize                install
    python-minimal                  install
    python-nevow                    install
    python-notify                   install
    python-numpy                    install
    python-oauth                    install
    python-openssl                  install
    python-pam                  install
    python-papyon                   install
    python-pexpect                  install
    python-piston-mini-client           install
    python-pkg-resources                install
    python-poppler                  install
    python-problem-report               install
    python-protobuf                 install
    python-pyasn1                   install
    python-pyatspi2                 install
    python-pycurl                   install
    python-pygame                   install
    python-pygoocanvas              install
    python-pyinotify                install
    python-pyorbit                  install
    python-pyparsing                install
    python-pysqlite2                install
    python-pywapi                   install
    python-qt4                  install
    python-renderpm                 install
    python-reportlab                install
    python-reportlab-accel              install
    python-routes                   install
    python-rpm                  install
    python-serial                   install
    python-simplejson               install
    python-sip                  install
    python-smartpm                  install
    python-smbc                 install
    python-software-properties          install
    python-speechd                  install
    python-sqlalchemy               install
    python-sqlite                   install
    python-sqlitecachec             install
    python-support                  install
    python-tagpy                    install
    python-talloc                   deinstall
    python-telepathy                install
    python-tk                   install
    python-twisted-bin              install
    python-twisted-conch                install
    python-twisted-core             install
    python-twisted-names                install
    python-twisted-web              install
    python-ubuntuone-client             install
    python-ubuntuone-control-panel          install
    python-ubuntuone-storageprotocol        install
    python-uniconvertor             install
    python-uno                  install
    python-urlgrabber               install
    python-utidylib                 install
    python-virtkey                  install
    python-vte                  install
    python-wadllib                  install
    python-webkit                   install
    python-webob                    install
    python-wnck                 install
    python-xapian                   install
    python-xdg                  install
    python-xkit                 install
    python-zope.interface               install
    python2.5                   deinstall
    python2.5-minimal               deinstall
    python2.6                   install
    python2.6-dbg                   deinstall
    python2.6-minimal               install
    python2.7                   install
    python2.7-minimal               install
    

    Here's my list of packages with "gtk" in their name:

    ~$ dpkg --get-selections | grep gtk
    adobe-flash-properties-gtk          install
    appmenu-gtk                 install
    appmenu-gtk3                    install
    apport-gtk                  install
    checkbox-gtk                    install
    compiz-gtk                  deinstall
    computer-janitor-gtk                install
    gir1.2-dbusmenu-gtk-0.4             install
    gir1.2-gtk-2.0                  install
    gir1.2-gtk-3.0                  install
    gir1.2-gtksource-3.0                install
    gtk2-engines                    install
    gtk2-engines-murrine                install
    gtk2-engines-pixbuf             install
    gtk3-engines-unico              install
    hwtest-gtk                  install
    ibus-gtk                    install
    ibus-gtk3                   install
    jockey-gtk                  install
    libavahi-ui-gtk3-0              install
    libcanberra-gtk-module              install
    libcanberra-gtk0                install
    libcanberra-gtk3-0              install
    libcanberra-gtk3-module             install
    libcheese-gtk18                 deinstall
    libcheese-gtk20                 install
    libclutter-gtk-0.10-0               deinstall
    libclutter-gtk-1.0-0                install
    libdbusmenu-gtk0                deinstall
    libdbusmenu-gtk1                deinstall
    libdbusmenu-gtk3                deinstall
    libdbusmenu-gtk3-4              install
    libdbusmenu-gtk4                install
    libempathy-gtk28                deinstall
    libgdu-gtk0                 install
    libgtk-3-0                  install
    libgtk-3-bin                    install
    libgtk-3-common                 install
    libgtk-sharp-beans-cil              install
    libgtk-vnc-1.0-0                deinstall
    libgtk-vnc-2.0-0                install
    libgtk2-imageview-perl              install
    libgtk2-perl                    install
    libgtk2.0-0                 install
    libgtk2.0-bin                   install
    libgtk2.0-cil                   install
    libgtk2.0-common                install
    libgtkglext1                    install
    libgtkhtml-4.0-0                install
    libgtkhtml-4.0-common               install
    libgtkhtml-editor-4.0-0             install
    libgtkhtml-editor0              deinstall
    libgtkhtml2-0                   deinstall
    libgtkhtml3.14-19               install
    libgtkhtml3.8-15                deinstall
    libgtkimageview0                install
    libgtkmm-2.4-1c2a               install
    libgtkmm-3.0-1                  install
    libgtksourceview-3.0-0              install
    libgtksourceview-3.0-common         install
    libgtksourceview1.0-0               deinstall
    libgtksourceview2.0-0               install
    libgtksourceview2.0-common          install
    libgtkspell0                    install
    libgtkspell3-0                  install
    libgwibber-gtk2                 install
    libindicate-gtk1                deinstall
    libindicate-gtk2                deinstall
    libindicate-gtk3                install
    libnm-gtk-common                install
    libnm-gtk0                  install
    libpolkit-gtk-1-0               install
    libreoffice-gtk                 install
    libseed-gtk3-0                  install
    libtracker-gtk0                 deinstall
    libwebkitgtk-1.0-0              install
    libwebkitgtk-1.0-common             install
    libwebkitgtk-3.0-0              install
    libwebkitgtk-3.0-common             install
    libwmf0.2-7-gtk                 install
    libwxgtk2.8-0                   install
    openoffice.org-gtk              install
    pinentry-gtk2                   install
    python-aptdaemon-gtk                install
    python-aptdaemon.gtk3widgets            install
    python-aptdaemon.gtkwidgets         install
    python-gtk2                 install
    r-cran-rgtk2                    install
    scim-bridge-client-gtk              install
    scim-gtk2-immodule              install
    software-properties-gtk             install
    transmission-gtk                install
    ubuntuone-control-panel-gtk         install
    usb-creator-gtk                 install
    xdg-user-dirs-gtk               install
    

    Anyway, if you have a strategy to propose, I'll listen.

    Thanks for your great work.

     
  • Dan Dediu

    Dan Dediu - 2011-10-29

    Hi,

    I can't reproduce it so I'll need your help :) To start with, could you please save the following lines in a file, say "test.py" and send me the output from "python -v test.py":

    from gi.repository import GObject, Gedit, Gtk, Gdk, GdkPixbuf, Vte, GLib, Pango, GtkSource
    import os.path
    import pickle
    import platform
    import tempfile
    import glob
    import sys
    from xml.dom import minidom
    import xml.sax.saxutils
    import re
    import signal
    import urllib2
    import webbrowser

    Maybe I can identify if on your system one of these modules loads gobject?

    Best,
    Dan

     
  • Anonymous

    Anonymous - 2011-10-29

    Thanks for your time.

    The output is quite long. I hope it is useful.

    ~$ python -v test.py
    # installing zipimport hook
    import zipimport # builtin
    # installed zipimport hook
    # /usr/lib/python2.7/site.pyc matches /usr/lib/python2.7/site.py
    import site # precompiled from /usr/lib/python2.7/site.pyc
    # /usr/lib/python2.7/os.pyc matches /usr/lib/python2.7/os.py
    import os # precompiled from /usr/lib/python2.7/os.pyc
    import errno # builtin
    import posix # builtin
    # /usr/lib/python2.7/posixpath.pyc matches /usr/lib/python2.7/posixpath.py
    import posixpath # precompiled from /usr/lib/python2.7/posixpath.pyc
    # /usr/lib/python2.7/stat.pyc matches /usr/lib/python2.7/stat.py
    import stat # precompiled from /usr/lib/python2.7/stat.pyc
    # /usr/lib/python2.7/genericpath.pyc matches /usr/lib/python2.7/genericpath.py
    import genericpath # precompiled from /usr/lib/python2.7/genericpath.pyc
    # /usr/lib/python2.7/warnings.pyc matches /usr/lib/python2.7/warnings.py
    import warnings # precompiled from /usr/lib/python2.7/warnings.pyc
    # /usr/lib/python2.7/linecache.pyc matches /usr/lib/python2.7/linecache.py
    import linecache # precompiled from /usr/lib/python2.7/linecache.pyc
    # /usr/lib/python2.7/types.pyc matches /usr/lib/python2.7/types.py
    import types # precompiled from /usr/lib/python2.7/types.pyc
    # /usr/lib/python2.7/UserDict.pyc matches /usr/lib/python2.7/UserDict.py
    import UserDict # precompiled from /usr/lib/python2.7/UserDict.pyc
    # /usr/lib/python2.7/_abcoll.pyc matches /usr/lib/python2.7/_abcoll.py
    import _abcoll # precompiled from /usr/lib/python2.7/_abcoll.pyc
    # /usr/lib/python2.7/abc.pyc matches /usr/lib/python2.7/abc.py
    import abc # precompiled from /usr/lib/python2.7/abc.pyc
    # /usr/lib/python2.7/_weakrefset.pyc matches /usr/lib/python2.7/_weakrefset.py
    import _weakrefset # precompiled from /usr/lib/python2.7/_weakrefset.pyc
    import _weakref # builtin
    # /usr/lib/python2.7/copy_reg.pyc matches /usr/lib/python2.7/copy_reg.py
    import copy_reg # precompiled from /usr/lib/python2.7/copy_reg.pyc
    # /usr/lib/python2.7/traceback.pyc matches /usr/lib/python2.7/traceback.py
    import traceback # precompiled from /usr/lib/python2.7/traceback.pyc
    # /usr/lib/python2.7/sysconfig.pyc matches /usr/lib/python2.7/sysconfig.py
    import sysconfig # precompiled from /usr/lib/python2.7/sysconfig.pyc
    # /usr/lib/python2.7/re.pyc matches /usr/lib/python2.7/re.py
    import re # precompiled from /usr/lib/python2.7/re.pyc
    # /usr/lib/python2.7/sre_compile.pyc matches /usr/lib/python2.7/sre_compile.py
    import sre_compile # precompiled from /usr/lib/python2.7/sre_compile.pyc
    import _sre # builtin
    # /usr/lib/python2.7/sre_parse.pyc matches /usr/lib/python2.7/sre_parse.py
    import sre_parse # precompiled from /usr/lib/python2.7/sre_parse.pyc
    # /usr/lib/python2.7/sre_constants.pyc matches /usr/lib/python2.7/sre_constants.py
    import sre_constants # precompiled from /usr/lib/python2.7/sre_constants.pyc
    # /usr/lib/python2.7/sitecustomize.pyc matches /usr/lib/python2.7/sitecustomize.py
    import sitecustomize # precompiled from /usr/lib/python2.7/sitecustomize.pyc
    # /usr/lib/python2.7/dist-packages/apport_python_hook.pyc matches /usr/lib/python2.7/dist-packages/apport_python_hook.py
    import apport_python_hook # precompiled from /usr/lib/python2.7/dist-packages/apport_python_hook.pyc
    import encodings # directory /usr/lib/python2.7/encodings
    # /usr/lib/python2.7/encodings/__init__.pyc matches /usr/lib/python2.7/encodings/__init__.py
    import encodings # precompiled from /usr/lib/python2.7/encodings/__init__.pyc
    # /usr/lib/python2.7/codecs.pyc matches /usr/lib/python2.7/codecs.py
    import codecs # precompiled from /usr/lib/python2.7/codecs.pyc
    import _codecs # builtin
    # /usr/lib/python2.7/encodings/aliases.pyc matches /usr/lib/python2.7/encodings/aliases.py
    import encodings.aliases # precompiled from /usr/lib/python2.7/encodings/aliases.pyc
    # /usr/lib/python2.7/encodings/utf_8.pyc matches /usr/lib/python2.7/encodings/utf_8.py
    import encodings.utf_8 # precompiled from /usr/lib/python2.7/encodings/utf_8.pyc
    Python 2.7.2+ (default, Oct  4 2011, 20:03:08) 
    [GCC 4.6.1] on linux2
    Type "help", "copyright", "credits" or "license" for more information.
    import gi # directory /usr/lib/python2.7/dist-packages/gi
    # /usr/lib/python2.7/dist-packages/gi/__init__.pyc matches /usr/lib/python2.7/dist-packages/gi/__init__.py
    import gi # precompiled from /usr/lib/python2.7/dist-packages/gi/__init__.pyc
    # /usr/lib/python2.7/__future__.pyc matches /usr/lib/python2.7/__future__.py
    import __future__ # precompiled from /usr/lib/python2.7/__future__.pyc
    dlopen("/usr/lib/python2.7/dist-packages/gi/_gi.so", 2);
    import gi._gobject # directory /usr/lib/python2.7/dist-packages/gi/_gobject
    # /usr/lib/python2.7/dist-packages/gi/_gobject/__init__.pyc matches /usr/lib/python2.7/dist-packages/gi/_gobject/__init__.py
    import gi._gobject # precompiled from /usr/lib/python2.7/dist-packages/gi/_gobject/__init__.pyc
    import gi._glib # directory /usr/lib/python2.7/dist-packages/gi/_glib
    # /usr/lib/python2.7/dist-packages/gi/_glib/__init__.pyc matches /usr/lib/python2.7/dist-packages/gi/_glib/__init__.py
    import gi._glib # precompiled from /usr/lib/python2.7/dist-packages/gi/_glib/__init__.pyc
    dlopen("/usr/lib/python2.7/dist-packages/gi/_glib/_glib.so", 2);
    import gi._glib._glib # dynamically loaded from /usr/lib/python2.7/dist-packages/gi/_glib/_glib.so
    # /usr/lib/python2.7/dist-packages/gi/_glib/option.pyc matches /usr/lib/python2.7/dist-packages/gi/_glib/option.py
    import gi._glib.option # precompiled from /usr/lib/python2.7/dist-packages/gi/_glib/option.pyc
    # /usr/lib/python2.7/optparse.pyc matches /usr/lib/python2.7/optparse.py
    import optparse # precompiled from /usr/lib/python2.7/optparse.pyc
    # /usr/lib/python2.7/textwrap.pyc matches /usr/lib/python2.7/textwrap.py
    import textwrap # precompiled from /usr/lib/python2.7/textwrap.pyc
    # /usr/lib/python2.7/string.pyc matches /usr/lib/python2.7/string.py
    import string # precompiled from /usr/lib/python2.7/string.pyc
    import strop # builtin
    # /usr/lib/python2.7/gettext.pyc matches /usr/lib/python2.7/gettext.py
    import gettext # precompiled from /usr/lib/python2.7/gettext.pyc
    # /usr/lib/python2.7/locale.pyc matches /usr/lib/python2.7/locale.py
    import locale # precompiled from /usr/lib/python2.7/locale.pyc
    import operator # builtin
    # /usr/lib/python2.7/functools.pyc matches /usr/lib/python2.7/functools.py
    import functools # precompiled from /usr/lib/python2.7/functools.pyc
    import _functools # builtin
    import _locale # builtin
    # /usr/lib/python2.7/copy.pyc matches /usr/lib/python2.7/copy.py
    import copy # precompiled from /usr/lib/python2.7/copy.pyc
    # /usr/lib/python2.7/weakref.pyc matches /usr/lib/python2.7/weakref.py
    import weakref # precompiled from /usr/lib/python2.7/weakref.pyc
    # /usr/lib/python2.7/struct.pyc matches /usr/lib/python2.7/struct.py
    import struct # precompiled from /usr/lib/python2.7/struct.pyc
    import _struct # builtin
    # /usr/lib/python2.7/dist-packages/gi/_gobject/constants.pyc matches /usr/lib/python2.7/dist-packages/gi/_gobject/constants.py
    import gi._gobject.constants # precompiled from /usr/lib/python2.7/dist-packages/gi/_gobject/constants.pyc
    dlopen("/usr/lib/python2.7/dist-packages/gi/_gobject/_gobject.so", 2);
    import gi._gobject._gobject # dynamically loaded from /usr/lib/python2.7/dist-packages/gi/_gobject/_gobject.so
    # /usr/lib/python2.7/dist-packages/gi/_gobject/propertyhelper.pyc matches /usr/lib/python2.7/dist-packages/gi/_gobject/propertyhelper.py
    import gi._gobject.propertyhelper # precompiled from /usr/lib/python2.7/dist-packages/gi/_gobject/propertyhelper.pyc
    dlopen("/usr/lib/python2.7/lib-dynload/datetime.so", 2);
    import datetime # dynamically loaded from /usr/lib/python2.7/lib-dynload/datetime.so
    import gi._gi # dynamically loaded from /usr/lib/python2.7/dist-packages/gi/_gi.so
    import gi.repository # directory /usr/lib/python2.7/dist-packages/gi/repository
    # /usr/lib/python2.7/dist-packages/gi/repository/__init__.pyc matches /usr/lib/python2.7/dist-packages/gi/repository/__init__.py
    import gi.repository # precompiled from /usr/lib/python2.7/dist-packages/gi/repository/__init__.pyc
    # /usr/lib/python2.7/dist-packages/gi/importer.pyc matches /usr/lib/python2.7/dist-packages/gi/importer.py
    import gi.importer # precompiled from /usr/lib/python2.7/dist-packages/gi/importer.pyc
    import logging # directory /usr/lib/python2.7/logging
    # /usr/lib/python2.7/logging/__init__.pyc matches /usr/lib/python2.7/logging/__init__.py
    import logging # precompiled from /usr/lib/python2.7/logging/__init__.pyc
    import time # builtin
    import cStringIO # builtin
    import thread # builtin
    # /usr/lib/python2.7/threading.pyc matches /usr/lib/python2.7/threading.py
    import threading # precompiled from /usr/lib/python2.7/threading.pyc
    # /usr/lib/python2.7/collections.pyc matches /usr/lib/python2.7/collections.py
    import collections # precompiled from /usr/lib/python2.7/collections.pyc
    import _collections # builtin
    # /usr/lib/python2.7/keyword.pyc matches /usr/lib/python2.7/keyword.py
    import keyword # precompiled from /usr/lib/python2.7/keyword.pyc
    # /usr/lib/python2.7/heapq.pyc matches /usr/lib/python2.7/heapq.py
    import heapq # precompiled from /usr/lib/python2.7/heapq.pyc
    import itertools # builtin
    # /usr/lib/python2.7/bisect.pyc matches /usr/lib/python2.7/bisect.py
    import bisect # precompiled from /usr/lib/python2.7/bisect.pyc
    import _bisect # builtin
    dlopen("/usr/lib/python2.7/lib-dynload/_heapq.so", 2);
    import _heapq # dynamically loaded from /usr/lib/python2.7/lib-dynload/_heapq.so
    # /usr/lib/python2.7/atexit.pyc matches /usr/lib/python2.7/atexit.py
    import atexit # precompiled from /usr/lib/python2.7/atexit.pyc
    # /usr/lib/python2.7/dist-packages/gi/module.pyc matches /usr/lib/python2.7/dist-packages/gi/module.py
    import gi.module # precompiled from /usr/lib/python2.7/dist-packages/gi/module.pyc
    import gi.overrides # directory /usr/lib/python2.7/dist-packages/gi/overrides
    # /usr/lib/python2.7/dist-packages/gi/overrides/__init__.pyc matches /usr/lib/python2.7/dist-packages/gi/overrides/__init__.py
    import gi.overrides # precompiled from /usr/lib/python2.7/dist-packages/gi/overrides/__init__.pyc
    # /usr/lib/python2.7/dist-packages/gi/types.pyc matches /usr/lib/python2.7/dist-packages/gi/types.py
    import gi.types # precompiled from /usr/lib/python2.7/dist-packages/gi/types.pyc
    ERROR:root:Could not find any typelib for Gedit
    # /usr/lib/python2.7/dist-packages/gi/overrides/Gtk.pyc matches /usr/lib/python2.7/dist-packages/gi/overrides/Gtk.py
    import gi.overrides.Gtk # precompiled from /usr/lib/python2.7/dist-packages/gi/overrides/Gtk.pyc
    # /usr/lib/python2.7/dist-packages/gi/overrides/Gdk.pyc matches /usr/lib/python2.7/dist-packages/gi/overrides/Gdk.py
    import gi.overrides.Gdk # precompiled from /usr/lib/python2.7/dist-packages/gi/overrides/Gdk.pyc
    # /usr/lib/python2.7/dist-packages/gi/overrides/GLib.pyc matches /usr/lib/python2.7/dist-packages/gi/overrides/GLib.py
    import gi.overrides.GLib # precompiled from /usr/lib/python2.7/dist-packages/gi/overrides/GLib.pyc
    # /usr/lib/python2.7/dist-packages/gi/overrides/Pango.pyc matches /usr/lib/python2.7/dist-packages/gi/overrides/Pango.py
    import gi.overrides.Pango # precompiled from /usr/lib/python2.7/dist-packages/gi/overrides/Pango.pyc
    Traceback (most recent call last):
      File "test.py", line 1, in <module>
        from gi.repository import GObject, Gedit, Gtk, Gdk, GdkPixbuf, Vte, GLib, Pango, GtkSource 
    ImportError: cannot import name Gedit
    # clear __builtin__._
    # clear sys.path
    # clear sys.argv
    # clear sys.ps1
    # clear sys.ps2
    # clear sys.exitfunc
    # clear sys.exc_type
    # clear sys.exc_value
    # clear sys.exc_traceback
    # clear sys.last_type
    # clear sys.last_value
    # clear sys.last_traceback
    # clear sys.path_hooks
    # clear sys.path_importer_cache
    # clear sys.meta_path
    # clear sys.flags
    # clear sys.float_info
    # restore sys.stdin
    # restore sys.stdout
    # restore sys.stderr
    # cleanup __main__
    # cleanup[1] _bisect
    # cleanup[1] datetime
    # cleanup[1] sysconfig
    # cleanup[1] collections
    # cleanup[1] zipimport
    # cleanup[1] signal
    # cleanup[1] abc
    # cleanup[1] _functools
    # cleanup[1] _locale
    # cleanup[1] itertools
    # cleanup[1] __future__
    # cleanup[1] _collections
    # cleanup[1] _heapq
    # cleanup[1] sre_constants
    # cleanup[1] _warnings
    # cleanup[1] _codecs
    # cleanup[1] _struct
    # cleanup[1] keyword
    # cleanup[1] posix
    # cleanup[1] exceptions
    # cleanup[1] site
    # cleanup[1] strop
    # cleanup[1] gettext
    # cleanup[1] sitecustomize
    # cleanup[1] _weakref
    # cleanup[1] _weakrefset
    # cleanup[1] heapq
    # cleanup[1] bisect
    # cleanup[1] locale
    # cleanup[1] encodings
    # cleanup[1] struct
    # cleanup[1] operator
    # cleanup[1] copy
    # cleanup[1] apport_python_hook
    # cleanup[1] encodings.aliases
    # cleanup[1] functools
    # cleanup[1] encodings.utf_8
    # cleanup[2] gi
    # cleanup[2] gi.importer
    # cleanup[2] gi.module
    # cleanup[2] string
    # cleanup[2] gi._gobject.option
    # cleanup[2] threading
    # cleanup[2] cStringIO
    # cleanup[2] gi._glib._glib
    # cleanup[2] stat
    # cleanup[2] atexit
    # cleanup[2] gi._gobject.propertyhelper
    # cleanup[2] re
    # cleanup[2] optparse
    # cleanup[2] UserDict
    # cleanup[2] codecs
    # cleanup[2] logging
    # cleanup[2] thread
    # cleanup[2] traceback
    # cleanup[2] weakref
    # cleanup[2] os
    # cleanup[2] gi._glib
    # cleanup[2] _sre
    # cleanup[2] gi._glib.option
    # cleanup[2] gi.overrides.Gdk
    # cleanup[2] posixpath
    # cleanup[2] errno
    # cleanup[2] os.path
    # cleanup[2] gi.repository
    # cleanup[2] gi.overrides.GLib
    # cleanup[2] gi._gobject.constants
    # cleanup[2] gi._gobject._gobject
    # cleanup[2] sre_parse
    # cleanup[2] copy_reg
    # cleanup[2] sre_compile
    # cleanup[2] linecache
    # cleanup[2] _abcoll
    # cleanup[2] gi.types
    # cleanup[2] genericpath
    # cleanup[2] gi._gobject
    # cleanup[2] warnings
    # cleanup[2] textwrap
    # cleanup[2] gi.overrides
    # cleanup[2] types
    # cleanup[2] gi.overrides.Gtk
    # cleanup[2] gi.overrides.Pango
    # cleanup[2] gi._gi
    # cleanup[2] time
    # cleanup sys
    # cleanup __builtin__
    # cleanup ints: 51 unfreed ints
    # cleanup floats: 5 unfreed floats
    
     
  • Dan Dediu

    Dan Dediu - 2011-10-30

    Hi,

    thanks for running it but because of a mistake I made (namely trying to import Gedit) it did not finish running (i.e., the output should have been much longer :) ). So, could you pls run again this:

    from gi.repository import GObject, Gtk, Gdk, GdkPixbuf, Vte, GLib, Pango, GtkSource
    import os.path
    import pickle
    import platform
    import tempfile
    import glob
    import sys
    from xml.dom import minidom
    import xml.sax.saxutils
    import re
    import signal
    import urllib2
    import webbrowser

    Thanks,
    Dan

     
  • Anonymous

    Anonymous - 2011-10-30

    ! Here's the new output:

    ~$ python -v test.py
    # installing zipimport hook
    import zipimport # builtin
    # installed zipimport hook
    # /usr/lib/python2.7/site.pyc matches /usr/lib/python2.7/site.py
    import site # precompiled from /usr/lib/python2.7/site.pyc
    # /usr/lib/python2.7/os.pyc matches /usr/lib/python2.7/os.py
    import os # precompiled from /usr/lib/python2.7/os.pyc
    import errno # builtin
    import posix # builtin
    # /usr/lib/python2.7/posixpath.pyc matches /usr/lib/python2.7/posixpath.py
    import posixpath # precompiled from /usr/lib/python2.7/posixpath.pyc
    # /usr/lib/python2.7/stat.pyc matches /usr/lib/python2.7/stat.py
    import stat # precompiled from /usr/lib/python2.7/stat.pyc
    # /usr/lib/python2.7/genericpath.pyc matches /usr/lib/python2.7/genericpath.py
    import genericpath # precompiled from /usr/lib/python2.7/genericpath.pyc
    # /usr/lib/python2.7/warnings.pyc matches /usr/lib/python2.7/warnings.py
    import warnings # precompiled from /usr/lib/python2.7/warnings.pyc
    # /usr/lib/python2.7/linecache.pyc matches /usr/lib/python2.7/linecache.py
    import linecache # precompiled from /usr/lib/python2.7/linecache.pyc
    # /usr/lib/python2.7/types.pyc matches /usr/lib/python2.7/types.py
    import types # precompiled from /usr/lib/python2.7/types.pyc
    # /usr/lib/python2.7/UserDict.pyc matches /usr/lib/python2.7/UserDict.py
    import UserDict # precompiled from /usr/lib/python2.7/UserDict.pyc
    # /usr/lib/python2.7/_abcoll.pyc matches /usr/lib/python2.7/_abcoll.py
    import _abcoll # precompiled from /usr/lib/python2.7/_abcoll.pyc
    # /usr/lib/python2.7/abc.pyc matches /usr/lib/python2.7/abc.py
    import abc # precompiled from /usr/lib/python2.7/abc.pyc
    # /usr/lib/python2.7/_weakrefset.pyc matches /usr/lib/python2.7/_weakrefset.py
    import _weakrefset # precompiled from /usr/lib/python2.7/_weakrefset.pyc
    import _weakref # builtin
    # /usr/lib/python2.7/copy_reg.pyc matches /usr/lib/python2.7/copy_reg.py
    import copy_reg # precompiled from /usr/lib/python2.7/copy_reg.pyc
    # /usr/lib/python2.7/traceback.pyc matches /usr/lib/python2.7/traceback.py
    import traceback # precompiled from /usr/lib/python2.7/traceback.pyc
    # /usr/lib/python2.7/sysconfig.pyc matches /usr/lib/python2.7/sysconfig.py
    import sysconfig # precompiled from /usr/lib/python2.7/sysconfig.pyc
    # /usr/lib/python2.7/re.pyc matches /usr/lib/python2.7/re.py
    import re # precompiled from /usr/lib/python2.7/re.pyc
    # /usr/lib/python2.7/sre_compile.pyc matches /usr/lib/python2.7/sre_compile.py
    import sre_compile # precompiled from /usr/lib/python2.7/sre_compile.pyc
    import _sre # builtin
    # /usr/lib/python2.7/sre_parse.pyc matches /usr/lib/python2.7/sre_parse.py
    import sre_parse # precompiled from /usr/lib/python2.7/sre_parse.pyc
    # /usr/lib/python2.7/sre_constants.pyc matches /usr/lib/python2.7/sre_constants.py
    import sre_constants # precompiled from /usr/lib/python2.7/sre_constants.pyc
    # /usr/lib/python2.7/sitecustomize.pyc matches /usr/lib/python2.7/sitecustomize.py
    import sitecustomize # precompiled from /usr/lib/python2.7/sitecustomize.pyc
    # /usr/lib/python2.7/dist-packages/apport_python_hook.pyc matches /usr/lib/python2.7/dist-packages/apport_python_hook.py
    import apport_python_hook # precompiled from /usr/lib/python2.7/dist-packages/apport_python_hook.pyc
    import encodings # directory /usr/lib/python2.7/encodings
    # /usr/lib/python2.7/encodings/__init__.pyc matches /usr/lib/python2.7/encodings/__init__.py
    import encodings # precompiled from /usr/lib/python2.7/encodings/__init__.pyc
    # /usr/lib/python2.7/codecs.pyc matches /usr/lib/python2.7/codecs.py
    import codecs # precompiled from /usr/lib/python2.7/codecs.pyc
    import _codecs # builtin
    # /usr/lib/python2.7/encodings/aliases.pyc matches /usr/lib/python2.7/encodings/aliases.py
    import encodings.aliases # precompiled from /usr/lib/python2.7/encodings/aliases.pyc
    # /usr/lib/python2.7/encodings/utf_8.pyc matches /usr/lib/python2.7/encodings/utf_8.py
    import encodings.utf_8 # precompiled from /usr/lib/python2.7/encodings/utf_8.pyc
    Python 2.7.2+ (default, Oct  4 2011, 20:03:08) 
    [GCC 4.6.1] on linux2
    Type "help", "copyright", "credits" or "license" for more information.
    import gi # directory /usr/lib/python2.7/dist-packages/gi
    # /usr/lib/python2.7/dist-packages/gi/__init__.pyc matches /usr/lib/python2.7/dist-packages/gi/__init__.py
    import gi # precompiled from /usr/lib/python2.7/dist-packages/gi/__init__.pyc
    # /usr/lib/python2.7/__future__.pyc matches /usr/lib/python2.7/__future__.py
    import __future__ # precompiled from /usr/lib/python2.7/__future__.pyc
    dlopen("/usr/lib/python2.7/dist-packages/gi/_gi.so", 2);
    import gi._gobject # directory /usr/lib/python2.7/dist-packages/gi/_gobject
    # /usr/lib/python2.7/dist-packages/gi/_gobject/__init__.pyc matches /usr/lib/python2.7/dist-packages/gi/_gobject/__init__.py
    import gi._gobject # precompiled from /usr/lib/python2.7/dist-packages/gi/_gobject/__init__.pyc
    import gi._glib # directory /usr/lib/python2.7/dist-packages/gi/_glib
    # /usr/lib/python2.7/dist-packages/gi/_glib/__init__.pyc matches /usr/lib/python2.7/dist-packages/gi/_glib/__init__.py
    import gi._glib # precompiled from /usr/lib/python2.7/dist-packages/gi/_glib/__init__.pyc
    dlopen("/usr/lib/python2.7/dist-packages/gi/_glib/_glib.so", 2);
    import gi._glib._glib # dynamically loaded from /usr/lib/python2.7/dist-packages/gi/_glib/_glib.so
    # /usr/lib/python2.7/dist-packages/gi/_glib/option.pyc matches /usr/lib/python2.7/dist-packages/gi/_glib/option.py
    import gi._glib.option # precompiled from /usr/lib/python2.7/dist-packages/gi/_glib/option.pyc
    # /usr/lib/python2.7/optparse.pyc matches /usr/lib/python2.7/optparse.py
    import optparse # precompiled from /usr/lib/python2.7/optparse.pyc
    # /usr/lib/python2.7/textwrap.pyc matches /usr/lib/python2.7/textwrap.py
    import textwrap # precompiled from /usr/lib/python2.7/textwrap.pyc
    # /usr/lib/python2.7/string.pyc matches /usr/lib/python2.7/string.py
    import string # precompiled from /usr/lib/python2.7/string.pyc
    import strop # builtin
    # /usr/lib/python2.7/gettext.pyc matches /usr/lib/python2.7/gettext.py
    import gettext # precompiled from /usr/lib/python2.7/gettext.pyc
    # /usr/lib/python2.7/locale.pyc matches /usr/lib/python2.7/locale.py
    import locale # precompiled from /usr/lib/python2.7/locale.pyc
    import operator # builtin
    # /usr/lib/python2.7/functools.pyc matches /usr/lib/python2.7/functools.py
    import functools # precompiled from /usr/lib/python2.7/functools.pyc
    import _functools # builtin
    import _locale # builtin
    # /usr/lib/python2.7/copy.pyc matches /usr/lib/python2.7/copy.py
    import copy # precompiled from /usr/lib/python2.7/copy.pyc
    # /usr/lib/python2.7/weakref.pyc matches /usr/lib/python2.7/weakref.py
    import weakref # precompiled from /usr/lib/python2.7/weakref.pyc
    # /usr/lib/python2.7/struct.pyc matches /usr/lib/python2.7/struct.py
    import struct # precompiled from /usr/lib/python2.7/struct.pyc
    import _struct # builtin
    # /usr/lib/python2.7/dist-packages/gi/_gobject/constants.pyc matches /usr/lib/python2.7/dist-packages/gi/_gobject/constants.py
    import gi._gobject.constants # precompiled from /usr/lib/python2.7/dist-packages/gi/_gobject/constants.pyc
    dlopen("/usr/lib/python2.7/dist-packages/gi/_gobject/_gobject.so", 2);
    import gi._gobject._gobject # dynamically loaded from /usr/lib/python2.7/dist-packages/gi/_gobject/_gobject.so
    # /usr/lib/python2.7/dist-packages/gi/_gobject/propertyhelper.pyc matches /usr/lib/python2.7/dist-packages/gi/_gobject/propertyhelper.py
    import gi._gobject.propertyhelper # precompiled from /usr/lib/python2.7/dist-packages/gi/_gobject/propertyhelper.pyc
    dlopen("/usr/lib/python2.7/lib-dynload/datetime.so", 2);
    import datetime # dynamically loaded from /usr/lib/python2.7/lib-dynload/datetime.so
    import gi._gi # dynamically loaded from /usr/lib/python2.7/dist-packages/gi/_gi.so
    import gi.repository # directory /usr/lib/python2.7/dist-packages/gi/repository
    # /usr/lib/python2.7/dist-packages/gi/repository/__init__.pyc matches /usr/lib/python2.7/dist-packages/gi/repository/__init__.py
    import gi.repository # precompiled from /usr/lib/python2.7/dist-packages/gi/repository/__init__.pyc
    # /usr/lib/python2.7/dist-packages/gi/importer.pyc matches /usr/lib/python2.7/dist-packages/gi/importer.py
    import gi.importer # precompiled from /usr/lib/python2.7/dist-packages/gi/importer.pyc
    import logging # directory /usr/lib/python2.7/logging
    # /usr/lib/python2.7/logging/__init__.pyc matches /usr/lib/python2.7/logging/__init__.py
    import logging # precompiled from /usr/lib/python2.7/logging/__init__.pyc
    import time # builtin
    import cStringIO # builtin
    import thread # builtin
    # /usr/lib/python2.7/threading.pyc matches /usr/lib/python2.7/threading.py
    import threading # precompiled from /usr/lib/python2.7/threading.pyc
    # /usr/lib/python2.7/collections.pyc matches /usr/lib/python2.7/collections.py
    import collections # precompiled from /usr/lib/python2.7/collections.pyc
    import _collections # builtin
    # /usr/lib/python2.7/keyword.pyc matches /usr/lib/python2.7/keyword.py
    import keyword # precompiled from /usr/lib/python2.7/keyword.pyc
    # /usr/lib/python2.7/heapq.pyc matches /usr/lib/python2.7/heapq.py
    import heapq # precompiled from /usr/lib/python2.7/heapq.pyc
    import itertools # builtin
    # /usr/lib/python2.7/bisect.pyc matches /usr/lib/python2.7/bisect.py
    import bisect # precompiled from /usr/lib/python2.7/bisect.pyc
    import _bisect # builtin
    dlopen("/usr/lib/python2.7/lib-dynload/_heapq.so", 2);
    import _heapq # dynamically loaded from /usr/lib/python2.7/lib-dynload/_heapq.so
    # /usr/lib/python2.7/atexit.pyc matches /usr/lib/python2.7/atexit.py
    import atexit # precompiled from /usr/lib/python2.7/atexit.pyc
    # /usr/lib/python2.7/dist-packages/gi/module.pyc matches /usr/lib/python2.7/dist-packages/gi/module.py
    import gi.module # precompiled from /usr/lib/python2.7/dist-packages/gi/module.pyc
    import gi.overrides # directory /usr/lib/python2.7/dist-packages/gi/overrides
    # /usr/lib/python2.7/dist-packages/gi/overrides/__init__.pyc matches /usr/lib/python2.7/dist-packages/gi/overrides/__init__.py
    import gi.overrides # precompiled from /usr/lib/python2.7/dist-packages/gi/overrides/__init__.pyc
    # /usr/lib/python2.7/dist-packages/gi/types.pyc matches /usr/lib/python2.7/dist-packages/gi/types.py
    import gi.types # precompiled from /usr/lib/python2.7/dist-packages/gi/types.pyc
    # /usr/lib/python2.7/dist-packages/gi/overrides/Gtk.pyc matches /usr/lib/python2.7/dist-packages/gi/overrides/Gtk.py
    import gi.overrides.Gtk # precompiled from /usr/lib/python2.7/dist-packages/gi/overrides/Gtk.pyc
    # /usr/lib/python2.7/dist-packages/gi/overrides/Gdk.pyc matches /usr/lib/python2.7/dist-packages/gi/overrides/Gdk.py
    import gi.overrides.Gdk # precompiled from /usr/lib/python2.7/dist-packages/gi/overrides/Gdk.pyc
    # /usr/lib/python2.7/dist-packages/gi/overrides/GLib.pyc matches /usr/lib/python2.7/dist-packages/gi/overrides/GLib.py
    import gi.overrides.GLib # precompiled from /usr/lib/python2.7/dist-packages/gi/overrides/GLib.pyc
    # /usr/lib/python2.7/dist-packages/gi/overrides/Pango.pyc matches /usr/lib/python2.7/dist-packages/gi/overrides/Pango.py
    import gi.overrides.Pango # precompiled from /usr/lib/python2.7/dist-packages/gi/overrides/Pango.pyc
    # /usr/lib/python2.7/pickle.pyc matches /usr/lib/python2.7/pickle.py
    import pickle # precompiled from /usr/lib/python2.7/pickle.pyc
    import marshal # builtin
    import binascii # builtin
    # /usr/lib/python2.7/platform.pyc matches /usr/lib/python2.7/platform.py
    import platform # precompiled from /usr/lib/python2.7/platform.pyc
    # /usr/lib/python2.7/tempfile.pyc matches /usr/lib/python2.7/tempfile.py
    import tempfile # precompiled from /usr/lib/python2.7/tempfile.pyc
    # /usr/lib/python2.7/random.pyc matches /usr/lib/python2.7/random.py
    import random # precompiled from /usr/lib/python2.7/random.pyc
    import math # builtin
    # /usr/lib/python2.7/hashlib.pyc matches /usr/lib/python2.7/hashlib.py
    import hashlib # precompiled from /usr/lib/python2.7/hashlib.pyc
    import _hashlib # builtin
    import _random # builtin
    import fcntl # builtin
    # /usr/lib/python2.7/glob.pyc matches /usr/lib/python2.7/glob.py
    import glob # precompiled from /usr/lib/python2.7/glob.pyc
    # /usr/lib/python2.7/fnmatch.pyc matches /usr/lib/python2.7/fnmatch.py
    import fnmatch # precompiled from /usr/lib/python2.7/fnmatch.pyc
    import xml # directory /usr/lib/python2.7/xml
    # /usr/lib/python2.7/xml/__init__.pyc matches /usr/lib/python2.7/xml/__init__.py
    import xml # precompiled from /usr/lib/python2.7/xml/__init__.pyc
    import xml.dom # directory /usr/lib/python2.7/xml/dom
    # /usr/lib/python2.7/xml/dom/__init__.pyc matches /usr/lib/python2.7/xml/dom/__init__.py
    import xml.dom # precompiled from /usr/lib/python2.7/xml/dom/__init__.pyc
    # /usr/lib/python2.7/xml/dom/domreg.pyc matches /usr/lib/python2.7/xml/dom/domreg.py
    import xml.dom.domreg # precompiled from /usr/lib/python2.7/xml/dom/domreg.pyc
    # /usr/lib/python2.7/xml/dom/minicompat.pyc matches /usr/lib/python2.7/xml/dom/minicompat.py
    import xml.dom.minicompat # precompiled from /usr/lib/python2.7/xml/dom/minicompat.pyc
    # /usr/lib/python2.7/xml/dom/minidom.pyc matches /usr/lib/python2.7/xml/dom/minidom.py
    import xml.dom.minidom # precompiled from /usr/lib/python2.7/xml/dom/minidom.pyc
    # /usr/lib/python2.7/xml/dom/xmlbuilder.pyc matches /usr/lib/python2.7/xml/dom/xmlbuilder.py
    import xml.dom.xmlbuilder # precompiled from /usr/lib/python2.7/xml/dom/xmlbuilder.pyc
    # /usr/lib/python2.7/xml/dom/NodeFilter.pyc matches /usr/lib/python2.7/xml/dom/NodeFilter.py
    import xml.dom.NodeFilter # precompiled from /usr/lib/python2.7/xml/dom/NodeFilter.pyc
    import xml.sax # directory /usr/lib/python2.7/xml/sax
    # /usr/lib/python2.7/xml/sax/__init__.pyc matches /usr/lib/python2.7/xml/sax/__init__.py
    import xml.sax # precompiled from /usr/lib/python2.7/xml/sax/__init__.pyc
    # /usr/lib/python2.7/xml/sax/xmlreader.pyc matches /usr/lib/python2.7/xml/sax/xmlreader.py
    import xml.sax.xmlreader # precompiled from /usr/lib/python2.7/xml/sax/xmlreader.pyc
    # /usr/lib/python2.7/xml/sax/handler.pyc matches /usr/lib/python2.7/xml/sax/handler.py
    import xml.sax.handler # precompiled from /usr/lib/python2.7/xml/sax/handler.pyc
    # /usr/lib/python2.7/xml/sax/_exceptions.pyc matches /usr/lib/python2.7/xml/sax/_exceptions.py
    import xml.sax._exceptions # precompiled from /usr/lib/python2.7/xml/sax/_exceptions.pyc
    # /usr/lib/python2.7/xml/sax/saxutils.pyc matches /usr/lib/python2.7/xml/sax/saxutils.py
    import xml.sax.saxutils # precompiled from /usr/lib/python2.7/xml/sax/saxutils.pyc
    # /usr/lib/python2.7/urlparse.pyc matches /usr/lib/python2.7/urlparse.py
    import urlparse # precompiled from /usr/lib/python2.7/urlparse.pyc
    # /usr/lib/python2.7/urllib.pyc matches /usr/lib/python2.7/urllib.py
    import urllib # precompiled from /usr/lib/python2.7/urllib.pyc
    # /usr/lib/python2.7/socket.pyc matches /usr/lib/python2.7/socket.py
    import socket # precompiled from /usr/lib/python2.7/socket.pyc
    import _socket # builtin
    import _ssl # builtin
    # /usr/lib/python2.7/ssl.pyc matches /usr/lib/python2.7/ssl.py
    import ssl # precompiled from /usr/lib/python2.7/ssl.pyc
    # /usr/lib/python2.7/base64.pyc matches /usr/lib/python2.7/base64.py
    import base64 # precompiled from /usr/lib/python2.7/base64.pyc
    # /usr/lib/python2.7/urllib2.pyc matches /usr/lib/python2.7/urllib2.py
    import urllib2 # precompiled from /usr/lib/python2.7/urllib2.pyc
    # /usr/lib/python2.7/httplib.pyc matches /usr/lib/python2.7/httplib.py
    import httplib # precompiled from /usr/lib/python2.7/httplib.pyc
    import array # builtin
    # /usr/lib/python2.7/mimetools.pyc matches /usr/lib/python2.7/mimetools.py
    import mimetools # precompiled from /usr/lib/python2.7/mimetools.pyc
    # /usr/lib/python2.7/rfc822.pyc matches /usr/lib/python2.7/rfc822.py
    import rfc822 # precompiled from /usr/lib/python2.7/rfc822.pyc
    # /usr/lib/python2.7/webbrowser.pyc matches /usr/lib/python2.7/webbrowser.py
    import webbrowser # precompiled from /usr/lib/python2.7/webbrowser.pyc
    # /usr/lib/python2.7/shlex.pyc matches /usr/lib/python2.7/shlex.py
    import shlex # precompiled from /usr/lib/python2.7/shlex.pyc
    # /usr/lib/python2.7/subprocess.pyc matches /usr/lib/python2.7/subprocess.py
    import subprocess # precompiled from /usr/lib/python2.7/subprocess.pyc
    import gc # builtin
    import select # builtin
    # clear __builtin__._
    # clear sys.path
    # clear sys.argv
    # clear sys.ps1
    # clear sys.ps2
    # clear sys.exitfunc
    # clear sys.exc_type
    # clear sys.exc_value
    # clear sys.exc_traceback
    # clear sys.last_type
    # clear sys.last_value
    # clear sys.last_traceback
    # clear sys.path_hooks
    # clear sys.path_importer_cache
    # clear sys.meta_path
    # clear sys.flags
    # clear sys.float_info
    # restore sys.stdin
    # restore sys.stdout
    # restore sys.stderr
    # cleanup __main__
    # cleanup[1] _bisect
    # cleanup[1] datetime
    # cleanup[1] sysconfig
    # cleanup[1] platform
    # cleanup[1] collections
    # cleanup[1] zipimport
    # cleanup[1] abc
    # cleanup[1] math
    # cleanup[1] _functools
    # cleanup[1] _locale
    # cleanup[1] itertools
    # cleanup[1] __future__
    # cleanup[1] _collections
    # cleanup[1] array
    # cleanup[1] _heapq
    # cleanup[1] sre_constants
    # cleanup[1] _warnings
    # cleanup[1] _codecs
    # cleanup[1] webbrowser
    # cleanup[1] _struct
    # cleanup[1] keyword
    # cleanup[1] posix
    # cleanup[1] exceptions
    # cleanup[1] site
    # cleanup[1] strop
    # cleanup[1] gettext
    # cleanup[1] glob
    # cleanup[1] urllib2
    # cleanup[1] sitecustomize
    # cleanup[1] _weakref
    # cleanup[1] _weakrefset
    # cleanup[1] heapq
    # cleanup[1] random
    # cleanup[1] subprocess
    # cleanup[1] httplib
    # cleanup[1] bisect
    # cleanup[1] signal
    # cleanup[1] shlex
    # cleanup[1] locale
    # cleanup[1] encodings
    # cleanup[1] fnmatch
    # cleanup[1] pickle
    # cleanup[1] marshal
    # cleanup[1] operator
    # cleanup[1] select
    # cleanup[1] hashlib
    # cleanup[1] apport_python_hook
    # cleanup[1] encodings.aliases
    # cleanup[1] mimetools
    # cleanup[1] _random
    # cleanup[1] functools
    # cleanup[1] gc
    # cleanup[1] tempfile
    # cleanup[1] encodings.utf_8
    # cleanup[1] rfc822
    # cleanup[1] fcntl
    # cleanup[1] _hashlib
    # cleanup[2] gi
    # cleanup[2] xml
    # cleanup[2] gi.importer
    # cleanup[2] gi.module
    # cleanup[2] string
    # cleanup[2] gi._gobject.option
    # cleanup[2] ssl
    # cleanup[2] threading
    # cleanup[2] cStringIO
    # cleanup[2] gi._glib._glib
    # cleanup[2] stat
    # cleanup[2] base64
    # cleanup[2] atexit
    # cleanup[2] xml.sax.saxutils
    # cleanup[2] gi._gobject.propertyhelper
    # cleanup[2] urllib
    # cleanup[2] re
    # cleanup[2] optparse
    # cleanup[2] UserDict
    # cleanup[2] codecs
    # cleanup[2] struct
    # cleanup[2] logging
    # cleanup[2] socket
    # cleanup[2] thread
    # cleanup[2] traceback
    # cleanup[2] weakref
    # cleanup[2] binascii
    # cleanup[2] xml.dom.xmlbuilder
    # cleanup[2] os
    # cleanup[2] gi._glib
    # cleanup[2] _sre
    # cleanup[2] gi._glib.option
    # cleanup[2] xml.sax.xmlreader
    # cleanup[2] xml.dom.domreg
    # cleanup[2] gi.overrides.Gdk
    # cleanup[2] posixpath
    # cleanup[2] errno
    # cleanup[2] _socket
    # cleanup[2] xml.sax.handler
    # cleanup[2] os.path
    # cleanup[2] gi.repository
    # cleanup[2] gi.overrides.GLib
    # cleanup[2] copy
    # cleanup[2] gi._gobject.constants
    # cleanup[2] gi._gobject._gobject
    # cleanup[2] xml.dom.minidom
    # cleanup[2] sre_parse
    # cleanup[2] copy_reg
    # cleanup[2] sre_compile
    # cleanup[2] xml.sax
    # cleanup[2] xml.dom.NodeFilter
    # cleanup[2] urlparse
    # cleanup[2] linecache
    # cleanup[2] _abcoll
    # cleanup[2] xml.dom.minicompat
    # cleanup[2] gi.types
    # cleanup[2] xml.sax._exceptions
    # cleanup[2] genericpath
    # cleanup[2] gi._gobject
    # cleanup[2] _ssl
    # cleanup[2] warnings
    # cleanup[2] textwrap
    # cleanup[2] gi.overrides
    # cleanup[2] types
    # cleanup[2] xml.dom
    # cleanup[2] gi.overrides.Gtk
    # cleanup[2] gi.overrides.Pango
    # cleanup[2] gi._gi
    # cleanup[2] time
    # cleanup sys
    # cleanup __builtin__
    # cleanup ints: 73 unfreed ints
    # cleanup floats: 36 unfreed floats
    
     
  • Dan Dediu

    Dan Dediu - 2011-10-31

    Hi,

    thanks for the output: I can't see anything wrong which makes me wonder if there isn't, by nay chance, something wrong in gedit? Do you have some weird plugin activated? Could you make a quick test by disabling all other plugins and see if rgedit starts?

    Sorry for pestering but I can't reproduce it here and I haven't heard of anybody else having this issue (yet)…

    Dan

     
  • Anonymous

    Anonymous - 2011-10-31

    Thanks for trying to fix what seems to be an idiosyncratic problem of mine!
    I'm ready to make any test you like (and for as long as you stay motivated to help me).

    I just tried starting rgedit with all the other plugins (nothing exotic) disabled but it still doesn't work. I get the same error message from the terminal.

    I can however provide the following extra information. If I try to start gedit (with rgedit activated) with the command "gedit -background", I get the following error message:

    ~$ gedit --background
    (gedit:17864): GLib-CRITICAL **: the GVariant format string `(u)' has a type of `(u)' but the given value has a type of `(s)'
    (gedit:17864): GLib-CRITICAL **: g_variant_get: assertion `valid_format_string (format_string, TRUE, value)' failed
    

    That might give you some ideas!

    François

     
1 2 > >> (Page 1 of 2)

Log in to post a comment.