#84 configure.ac error: 2 macros not defined

closed-out-of-date
5
2005-09-04
2005-06-08
bytenibbler
No

When trying to create the configure script with bootstrap from the
cvs-source, I get the following messages, warnings and 2 errors
having all the required packages correctly (tested) installed in their
up2date versions:

The following packages (some version at least) are required to
bootstrap:
autoconf2.5
automake1.7
m4-1.4
pkgconfig
libtool
gettext
gettext-devel
autoreconf: Entering directory `.'
autoreconf: running: autopoint --force
autoreconf: running: aclocal --force -I config/m4
config/m4/vorbis.m4:9: warning: underquoted definition of
XIPH_PATH_VORBIS
run info '(automake)Extending aclocal'
or see http://sources.redhat.com/automake/automake.
html#Extending%20aclocal
...
(lots of other 'underquoted definition' warnings, generated by each
macro definition)
...
autoreconf: running: /usr/bin/autoconf --force
configure.ac:42: error: possibly undefined macro: AC_DEFINE
If this token and others are legitimate, please use m4_pattern_allow.
See the Autoconf documentation.
configure.ac:191: error: possibly undefined macro: AC_MSG_RESULT
autoreconf: /usr/bin/autoconf failed with exit status: 1

Discussion

  • Davy Durham

    Davy Durham - 2005-06-09

    Logged In: YES
    user_id=28588

    I have to say, autoconf and related tools are probably THE
    most finnicky and precarious tools to get working I've ever
    worked with.

    I'm really not going to be able to suggest anything more
    helpful than just to play around with the versions of
    autoconf2.5 or automake and perhaps others.. m4 is pretty
    stable and pkgconfig is too.. The other's all have problems
    from time to time depending on the versions and combinations
    you use.

    It works pretty well most of the time on mandrake (my distro
    of choice), but I'm not familiar with how well it works on
    others.

    Sorry...

    The exact versions I have are (and it's working for me):

    autoconf2.5-2.59-6mdk
    automake1.7-1.7.9-2mdk
    gettext-0.14.1-10mdk
    gettext-base-0.14.1-10mdk
    gettext-devel-0.14.1-10mdk
    libgettextmisc-0.14.1-10mdk
    libtool-1.5.12-4mdk
    m4-1.4.2-1mdk
    pkgconfig-0.15.0-5mdk

     
  • Davy Durham

    Davy Durham - 2005-06-09
    • assigned_to: nobody --> ddurham
     
  • Davy Durham

    Davy Durham - 2005-09-04
    • status: open --> closed-out-of-date
     

Log in to post a comment.

Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:





No, thanks