Building rexx/curses in Red Hat Linux

Help
2009-08-20
2013-04-17
  • John Hupcey

    John Hupcey - 2009-08-20

    We have attempted to build rexx/curses using Red Hat Linux 4 & 5 at various levels. All give the same error during the link step: 
    /usr/bin/ld: /usr/lib/gcc/x86_64-redhat-linux/3.4.6/../../../../lib64/crt1.o:
    relocation R_X86_64_32S against `__libc_csu_fini' can not be used when making
    a shared object; recompile with -fPIC

    /usr/lib/gcc/x86_64-redhat-linux/3.4.6/../../../../lib64/crt1.o:
    could not read symbols: Bad value

    We have tried all sorts of changes to the Makefile as well as different gcc versions from 2.95.3 to 4.1.2. 

    If anyone else has successfully built this for any version of Linux, please let me know.
    Thanks, 
    John 

     
  • jkrim

    jkrim - 2012-09-28

    I was also not able compile a 64 bit version of Rexx/Curses, and got the same messages reported.  What I was able to do was compile a 32 bit version of it that runs on a 64 bit machine.  The 32 bit version was compiled under RHEL3 on an i386 machine , but it works on  RHEL4 x86_64 machine as well.  Of course, in order for me to do this, I also compiled PDCurses and Regina on the same 32 bit machine.

    Jordan

     

Log in to post a comment.

Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:





No, thanks