#7 java 1.5 incompatibility

closed-fixed
nobody
None
5
2007-06-04
2007-05-29
Zach Hoeken
No

this error is generated when running the host software with the java 1.5 jre:

Hoeken:~/Desktop/RepRap-v1.0 zachsmith$ ./reprap_linux
Exception in thread "main" java.lang.UnsupportedClassVersionError: Bad version number in .class file
at java.lang.ClassLoader.defineClass1(Native Method)
at java.lang.ClassLoader.defineClass(ClassLoader.java:620)
at java.security.SecureClassLoader.defineClass(SecureClassLoader.java:124)
at java.net.URLClassLoader.defineClass(URLClassLoader.java:260)
at java.net.URLClassLoader.access$100(URLClassLoader.java:56)
at java.net.URLClassLoader$1.run(URLClassLoader.java:195)
at java.security.AccessController.doPrivileged(Native Method)
at java.net.URLClassLoader.findClass(URLClassLoader.java:188)
at java.lang.ClassLoader.loadClass(ClassLoader.java:306)
at sun.misc.Launcher$AppClassLoader.loadClass(Launcher.java:268)
at java.lang.ClassLoader.loadClass(ClassLoader.java:251)
at java.lang.ClassLoader.loadClassInternal(ClassLoader.java:319)

Discussion

  • Jonathan Marsden

    Logged In: YES
    user_id=28206
    Originator: NO

    This issue was valid only for precompiled .jar files created before 20070601, which were never officially released.

    A Java 1.5.0 JDK works fine for me at present.

    Jonathan

     
  • Zach Hoeken

    Zach Hoeken - 2007-06-04
    • status: open --> closed-fixed
     

Log in to post a comment.