Regina REXX on MAC OS X

  • asmca

    asmca - 2010-01-06

    I would like to use REXX on MAC OS X.  I have used it for years (even decades) on IBM VM and OS/2 (& Warp, & eComStation), but I can't for the life of me figure out how to use Regina REXX on OS X.

    I downloaded Regina-REXX-3.4-universal.pkg.dmg from, where it is described as the "Regina Universal Package for OSX".  Executing this led to the creation of a virtual disk containing Regina-REXX.pkg which, when invoked, starts the OS X installation program.  This, after going through its machinations, presents a message indicating the installation was successful.

    However, I don't see that anything has been changed in the system.  I conclude that whatever was installed was put into the dark recesses of the Unix on which OS X is run - although I still can't find it.

    Nevertheless, I cannot see how to invoke it.  The documentation I have (regina34.pdf) seems only to talk about execution from a command line - not even a concept in OS X.  The only mention of OS X I find is in the table of Ports of Regina.

    Am I to conclude that the way to use Regina-REXX is from the Unix command line (Terminal)?  If so, how?  If not, what do I do now?

  • Toby Thurston

    Toby Thurston - 2010-01-08

    Yes your conclusion is right.  Installing the Regina package will provide you with a "rexx" command that you can access from the Terminal.

    Open up your terminal and type "rexx -v" if you have installed the latest update you will see

    REXX-Regina_3.5 5.00 31 Dec 2009

    as the response.  Then you can try "which rexx" to see that the Regina package installed a program called "rexx" in /usr/bin.

    Then try "rexx -h" to see the very short help you get.

    To do anything useful you are going to have to get a plain text editor on Mac OS X.  There are lots.  If you want to spend money you can try Textmate or BBEdit.  If you want something free,  try "textwrangler" or "macvim".

    Once you have chosen one - I am using MacVim - you need to create a few programs, and then run them from the Terminal
    using "rexx yourprog.rex".

    There are ways to make GUI programs but that's not really what rexx is good for.


  • Toby Thurston

    Toby Thurston - 2010-01-08

    The installation also will have added various examples - some more helpful than others - in "/usr/share/regina".

    doing "rexx /usr/share/regina/rexxcps.rexx" on my system shows that Regina 5 processes a whopping 3139028 REXX clauses per second.


  • Toby Thurston

    Toby Thurston - 2010-01-08

    Although now I look slightly more carefully, I see that it *has* installed a GUI application for me called "Regina-Launcher" look in the Utilities folder under Applications…

    Here is the complete list of files installed by the latest 3.5 pkg for Mac



  • asmca

    asmca - 2010-01-14


    First, I must apologize for taking so long to reply your response.  We've been very busy here preparing for and hosting a cello master class in our music room.  Now that it's over, I can get back to computer problems.

    I'm afraid what I write will reflect my lack of knowledge of and experience with Unix/Linux.  I've worked with a considerable number of operating systems in my time, but Unix is not one of them.

    So, anyway, I did finally find rexx and regina in /usr/bin/ as you said.  (Although I'm not sure why I couldn't find them with ls except by specifying the directory explicitly.  I'm sure I'll work it out sometime.)

    However, when I enter "rexx -v" or "rexx -h" or even just "rexx", whether from my home directory or from /usr/bin/, all I get is "Bus error", which means nothing to me.

    I assume it really means that Regina-REXX is not installed properly, even though the OS X installer reported that the installation was successful.  I did try reinstalling a few times telling the installer to replace what was there.  I also downloaded the Regina-REXX-3.5.universal.pkg.dmg package again and installed it.  Each time I was told the installation was successful - still only "Bus error".

    Any idea what I'm doing wrong ?

    Incidentally, I don't seem to have the directories and files you list.  For example, there is no in /Applications/Utilities/.  Sounds like something didn't work right.

    Many thanks


  • Mark Hessling

    Mark Hessling - 2010-01-14

    Hi Stratton,

    Are you by any chance running OS X Tiger or Panther?
    The Universal binary is only intended for OS X Leopard or Snow Leopard.

    Cheers, Mark

  • asmca

    asmca - 2010-01-15

    I suppose that may be the problem.  But I did manage to take this into consideration when I started - contrary to what I wrote in my last post, it is the 3.4-universal that I've been working with rather than 3.5.  I can't seem to find it on the SourceForge site now, but as I recall, somewhere it says that 3.4 is the most recent version that should run on Tiger (which is what I am using).

    Now, it IS possible that at some point in all this I did inadvertently download and try 3.5, although everything I can find on the disk says 3.4.  Anyway, to be sure, I just downloaded 3.4 again.  Unfortunately, still the "Bus error" message.

    Do you think it might help to "uninstall" whatever I have on the disk now ?  How would I do that ?  I haven't found any uninstall instructions.  Just delete the rexx and regina items in /usr/ and /usr/bin/ ? 

    I appreciate your help.


  • Toby Thurston

    Toby Thurston - 2010-01-22

    You probably need to remove everything from both packages and start again.

    I'd recommend upgrading to Snow Leopard and getting Regina V3.5, but if you are on an older version of Mac OS X you'll need to stick with 3.4

    Here is a list of all the files in the 3.4 package


    You can get this list for your self for any package with the "lsbom" command.
    Mount the .dmg file and then do

    lsbom /Volumes/Regina-REXX/Regina-REXX.pkg/Contents/

    I guess it would not be too hard to make a little shell script to automate removing them all.


  • Alan Ackerman

    Alan Ackerman - 2011-12-03

    Has anyone tried Regina REXX with Mac OS X 10.7 (Lion) yet? Does it work?


Log in to post a comment.