Refind Flashdrive - Shell opening the downloaded Shell 2

  • bunnybooboo

    bunnybooboo - 2014-04-14

    I'm attempting to get Crunchbang Linux on my iMac 5,7 from 2006. A recent attempt at loading the install bricked my OSX (Snow Leopard 10.6) boot.

    Needing to install refind manually I run into needing the Shell 2 file. How do I do this using 2 different usb's ? I can only dd refind on one usb. Then I have the shell 2 file for the 32 bit architecture on another.

    I can locate them both using the fs navigation in shell. I have got as far as step 12 where I start needing bcfg commands.

    How do I load this shell 2 efi file to work using the shell 1 from within the refind flashdrive?

  • Roderick W. Smith

    I'm afraid I'm not following most of your post:

    • You say you bricked your computer. That means it's useless, at least until it's been repaired. Yet you continue your post as if nothing had happened. This has me scratching my head.
    • An EFI shell should not be needed to install either Linux or rEFInd on a Mac. Some methods of installation can use an EFI shell to register rEFInd with a PC's UEFI, but those methods aren't likely to be helpful on a Mac.
    • You refer to "step 12," but not the document in which "step 12" exists. This makes it difficult to understand what you're trying to do.
  • bunnybooboo

    bunnybooboo - 2014-04-15

    Thanks for your response Roderick.

    "A recent attempt at loading the install bricked my OSX"

    The iMac will not go beyond the apple symbol. There is a spinning icon and sometimes there is progress bar that goes nowhere. In my language at least that is bricked. The only way I can proceed further is in single user mode or getting into the boot EFI via refind. I've never had to do all these steps before but happy to work through step by steps to achieve the ultimate goal. Linux on this Mac.

    "An EFI shell should not be needed to install either Linux or rEFInd on a Mac"

    Yes, well. I have tried at least a dozen ways and various flavours of Linux on the usb. This is me journalling some of the journey so far...
    Most can not even be found when attempting a boot load. When I use refind the usb is usually at least recognised. Which I see as progress...

    .."step 12"..

    oops my bad..
    Step 12 is when you start needing bcfg commands and the tha flashdrive only has shell 1 so I need shell 2 to achieve those later steps.

    Heck I am playing blind here and not entirely sure WHAT will eventually work but after nearly a week of trying to get this Mac working I am at least appreciative that refind is giving me a few options to play with. I am just seeking a method that WORKS.

    Most methods work on Macs with LION (10.7) installed or are newer architecture than my Imac. I am using a 2006 Imac 5,1 with Snow Leopard (10.6). I once had triple booted on this machine so I know ultimately it can be achieved BUT locating the method that work via USB on my particular architecture is proving a journey.

    Last edit: bunnybooboo 2014-04-15
  • Roderick W. Smith

    The word "bricked," in this context, means that the device is completely unresponsive and useless -- it's no better than a brick. The most common cause of this is damage to the firmware, necessitating taking the computer apart and replacing a chip to fix the damage. What you've described is not a bricked computer. Chances are you've damaged your OS X installation, and this can be fixed by re-installing OS X. You'll need to get an OS X installation disc to do this, though. I recommend you start with that, since it's best to install rEFInd from OS X.

    That brings me to my next point: Do not attempt to follow the procedure you referenced, involving installing rEFInd from an EFI shell. At best, it won't work. At worst, the Mac's EFI might react badly and cause more problems, but I don't know that for a fact.

    If installing from OS X is impossible, you could try using the Linux port of bless, which is becoming more widely available than it was a few months ago. I don't have explicit instructions on how to use it, though. (I need to look into that myself.)


Log in to post a comment.