Can't hide Recovery HD option

2012-09-20
2015-04-05
  • Matthew Petch

    Matthew Petch - 2012-09-20

    I've added (what I believe to be) the directory of the boot.efi to dont_scan dirs, yet the option still persists when I reboot.

    Some brief info: Retina MBP, 10.8.1/Windows 7, rEFInd 0.4.5

    I think the directory for the.efi is /Recovery HD/System/Library/CoreServices/, so I've tried adding several things to dont_scan_dirs, non of which work. This is what I'm currently trying.

    dont_scan_dirs EFI/boot,EFI/Dell,Recovery HD

    I assume I'm doing something terribly wrong here (either I have the wrong directory for the .efi, or I'm inserting it into the .conf incorrectly). Any help much appreciated.

     
    Last edit: Matthew Petch 2012-09-20
  • Roderick W. Smith

    It sounds to me as if you're trying to keep some sort of recovery version of OS X from appearing. (My own Mac system is pretty ancient, so I'm afraid I have no personal experience with this type of setup.) If so, I don't believe it's possible to do this with the current version of rEFInd -- at least, not with auto-scanning of OSes enabled. You could, though, disable auto-scanning and enable manual scanning, as in "scanfor manual" or "scanfor manual,external,optical". You could then create a manual boot stanza for just the version of OS X that you want to appear in the menu.

     
  • Matthew Petch

    Matthew Petch - 2012-10-13

    Thanks, I'll try this later and post if it worked.

     
  • Matthew Petch

    Matthew Petch - 2012-10-13

    Ignore this; double post.

     
    Last edit: Matthew Petch 2012-10-13
  • Roderick W. Smith

    I've added a new option to rEFInd 0.6.0 that should help with this type of problem: dont_scan_volumes. Set this to the name of the filesystem(s) that you don't want scanned and rEFInd won't scan them for boot loaders. For instance, IIRC the standard name for the volume with the recovery installation is Recovery HD, so you'd set it:

    dont_scan_volumes "Recovery HD"
    

    Note that this affects only the boot loader scanning, not the tools scanning. There's an apple_recovery tool (active by default) that should boot the recovery system properly.

     
  • Jack

    Jack - 2012-12-25

    I tried every trick to not see this second boot (intrusion) without success. This is not a duplicate but wrong.

    Has anyone solved this problem delete the second icon Apple (Boot Mac OS X from Recovery HD)?

    Thanks.

     
  • Roderick W. Smith

    When you select the unwanted icon (just using the arrow keys, not pressing Enter to launch it), what does the text read below the icons? It should read "Boot X from Y", where "X" is an OS description or filename and "Y" is a volume name or description. It's "Y" that you need to place in the dont_scan_volumes token. Also, note again that the dont_scan_volumes token is new with rEFInd 0.6.0, so you must be using that version or later.

    If that's still not working, please cut-and-paste that line from your refind.conf file and show me a screen shot of rEFInd's main menu with the offending tag highlighted. (You can take a screen shot with F10, if rEFInd is installed on the ESP. The resulting file is called screenshot.bmp in the ESP's root. If rEFInd is on your OS X partition, you'll have to use a physical camera.)

     
  • Jack

    Jack - 2012-12-29

    I just uninstalled properly using the Terminal command. And I downloaded the latest version 0.6.1 refind.
    Boot Mac OS X Recovery from HD
    I took in the Recovery HD online dont_scan_volumes but it does not change anything, the icon is still present.
    I joined my current reFind.conf: http://d.pr/f/Cpl2

    And to better summarize my situation, here's a video: http://d.pr/v/pzA0

    Thanks.

     
  • Jack

    Jack - 2013-01-13

    ?

     
  • Roderick W. Smith

    You need to enclose the volume name Recovery HD in quotes, as in:

    dont_scan_volumes "Recovery HD"
    

    Without the quotes, rEFInd is interpreting Recovery HD as two separate volume names, Recovery and HD.

    Alternatively, you could rename the Recovery HD volume to something that doesn't include a space in its name.

     
    • Matthew Petch

      Matthew Petch - 2013-01-29

      I've just upgraded from 5.x to the latest version, and this feature doesn't seem to work for me (with quotation marks).

      I love the rest of the features though, and thanks for the hard work keeping this updated

       
  • Jack

    Jack - 2013-01-19

    Hi,
    I finally found the solution. So I decided to go and check that includes the Recovery HD partition. So I mounted the disk with this command (Debug Menu Disk Utility) :
    defaults write com.apple.DiskUtility DUDebugMenuEnabled -string YES
    and I could compare the version Macbook Pro 4.1 & Macbook Pro 10.1.
    It is the rMBP 10.1 containing other folders than my old MBP 4.1.
    Here are the files found (which I deleted):
    com.apple.boot.s
    System
    I finally kept com.apple.recovery.boot file. Besides, I still do not understand how these issues have to be there!
    Restarting the apple logo that second boot Recovery HD no longer appears. What a relief ... Thanks to Roderick have tried to help me.

     
  • Roderick W. Smith

    Matthew,

    Please post the following:

    • Your refind.conf file (a link to it is probably best)
    • The name of the volume on which the unwanted boot loader is stored
    • Precisely how rEFInd identifies the unwanted boot entry (for instance, "Boot EFI/foo/bar.efi from BarFoo" or "Boot Mac OS X from BarFoo")
     
  • Roderick W. Smith

    Actually, I've just had another look at the code, and I think I may have found the problem. The test version is up in source code in the git repository, and a binary is here:

    http://www.rodsbooks.com/refind-bin-0.6.6.7.zip

    Please try that and tell me if it works -- setting dont_scan_volumes to the name of the volume that holds the offending entry should do the trick.

     
  • Matthew Petch

    Matthew Petch - 2013-02-18

    Just updated the to latest release, works perfectly now.

    Thanks!

     
  • dro

    dro - 2015-04-04

    Hi,
    I'm using refind to dualboot osx(yosemite) and linux on a macbook pro early 2015. I'm trying to hide the second bootloader (osx-Recovery Hd) from the menu and can't get it to work with the "dont_scan_volumes" option. I guess it's related to mounting at the esp, because it used to work on my old laptop (yosemite) with the -ownhfs option.
    Am I doing something wrong?

    Cheers

    Doro

     
  • Roderick W. Smith

    By default, Yosemite boots from the "Recovery HD" option, so you should not normally try to hide it. If you're seeing some other behavior, or if there's a duplicate entry, then I need some further information. Most importantly, I need to know the exact text associated with all of your boot options, as well as which ones work and which ones you want to hide.

     
  • dro

    dro - 2015-04-05

    I see three entries:

    "Boot Mac OS X from Macintosh HD"
    "Boot Mac OS X from Recovery HD"
    "Boot Archlinux from Arch"

    All three entries work. I want to hide one of the OSX's.

     
  • dro

    dro - 2015-04-05

    Ok, so I obviously should have tried to hide the "Macintosh HD" entry, which I successfully did with the "dont_scan_volumes" option. Yosemite booting from "Recovery HD" as default makes the second line option to boot from "Apple Recovery" redundant, doesn't it?

    Thx

     

Log in to post a comment.

Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:

JavaScript is required for this form.





No, thanks