Request for information from EFI-mode Windows users

2013-12-31
2014-02-25
  • Roderick W. Smith

    I'm currently adding a new feature to rEFInd, the intent of which is to kick the Windows recovery boot options off of the main list of OSes and into the second row. The trouble is that I suspect there's a lot of variability in what the recovery boot loader is called. On a lot of computers with Windows 8 pre-installed, there seem to be recovery tools on a second non-ESP FAT partition, but I don't know what these tools are called in all cases. Thus, I'd appreciate it if those of you with Windows 8 EFI/UEFI installations could get back to me with this information. What I'd like is the filesystem label and complete file path to any Windows recovery tool(s) on your computer. For instance, "EFI/Manufacturer/bootmgfw.efi on the FOO filesystem boots to a Windows recovery tool." Note that the filesystem label is critical and it varies between manufacturers. It appears in the rEFInd menu (if rEFInd picks up the tool) and should be revealed by "blkid" under Linux. (I need the LABEL= value, not the PARTLABEL= value.) My intention is to incorporate all the known names as defaults in rEFInd, and give an override option to add to or replace that default list of filenames.

    You can post here or e-mail me (rodsmith@rodsbooks.com). Thanks in advance for any responses.

     
  • mcloaked

    mcloaked - 2014-02-17

    I have just seen this this post and am not sure if I can help here - but I am in the process of planning a dual boot arch linux install on a laptop which arrived with Windows 8 pre-installed, and I have recently upgraded to Windows 8.1. I need to understand what is necessary in the config files for rEFInd which will allow it to boot both arch linux and Windows 8.1 (fastboot is switched off and secure boot will be switched off before the arch install). I have looked at the current partition structure and notice there is more than one recovery partition on the disk, so I am still feeling my way with this. The machine concerned is a Lenovo Y510p. When I start to do the work on this system to get arch installed I will likely be able to help in providing the information about this laptop concerning recovery tools/partitions that exist on the drive if this will be of use even after a couple of months from the original post? (Rod, you gave me invaluable help in getting my first rEFInd boot set up about a year ago and I am happy to help where I can with your quest for info).

     
  • Vic_J

    Vic_J - 2014-02-18

    I have a HP pavilion g7 laptop. It came with Windows8 in secure boot.

    HP made the EFI partition the second (/sda2). That partition doesnt have a label.

    Refind doesnt display any recovery boot option on either line.

    Grub shows the following recovery entries:
    /EF/HP/BIOSUpdate/CryptRSA32.efi
    /EF/HP/BIOSUpdate/CryptRSA.efi
    /EF/HP/BIOSUpdate/HpBiosUpdate32.efi
    /EF/HP/BIOSUpdate/HpBiosUpdate.efi
    /EF/HP/boot/bootmgfw.efi
    /EF/HP/SystemDiags/CryptRSA32.efi
    /EF/HP/SystemDiags/CryptRSA.efi
    /EF/HP/SystemDiags/SystemDiags32.efi
    /EF/HP/SystemDiags/SystemDiags.efi

    output of sudo blkid on the system is now:

    /dev/sda1: LABEL="WINRE" UUID="ECFEDBECFEDBACD8" TYPE="ntfs"
    /dev/sda2: UUID="9C9C-3342" TYPE="vfat"
    /dev/sda4: UUID="92D44D49D44D30B1" TYPE="ntfs"

    I previously deleted the HP recovery tools partition to save space, which may explain why refind doesn't show any manufacturers boot option. When I first got the machine I recorded the layout with gdisk, which may help. However, that doesnt record the labels. Fortunately, clonezilla ran lshw. I've included both just in case I'm reading it wrong.

    The HP tools partition label (/sda5- "volume:4") was 'RECOVERY'

    Let me know if you need anything else.

     
    Last edit: Vic_J 2014-02-18
  • mcloaked

    mcloaked - 2014-02-20

    I have the blkid output for the Y510p that I mentioned in my post from 3 days ago now. The output is as follows:

    /dev/sdb1: LABEL="WINRE_DRV" UUID="1436EE8836EE6A66" TYPE="ntfs" PARTLABEL="Basic data partition" PARTUUID="8366a6cb-c763-48c5-8aec-9e6a0c568188"
    /dev/sdb2: LABEL="SYSTEM_DRV" UUID="A8F1-3FBD" TYPE="vfat" PARTLABEL="EFI system partition" PARTUUID="f845bf32-3164-419e-95f2-ec5d5d8cf832"
    /dev/sdb3: LABEL="LRS_ESP" UUID="84F2-3F4C" TYPE="vfat" PARTLABEL="Basic data partition" PARTUUID="5ccd5391-a326-4468-a08a-e905ce3e2951"
    /dev/sdb4: PARTLABEL="Microsoft reserved partition" PARTUUID="6e594563-2f89-40f9-9b26-5a16444e8530"
    /dev/sdb5: LABEL="Windows8_OS" UUID="9E84F72A84F70395" TYPE="ntfs" PARTLABEL="Basic data partition" PARTUUID="f8f79a5b-84b2-4caf-a4f7-792e6ab36ca3"
    /dev/sdb6: UUID="646EA1616EA12CAC" TYPE="ntfs" PARTUUID="db6d055e-a459-4c24-b202-028a6a75184e"
    /dev/sdb7: LABEL="LENOVO" UUID="3065003664FFFBFA" TYPE="ntfs" PARTLABEL="Basic data partition" PARTUUID="4ba75eb8-6f7e-44cb-a378-742d8c0f4246"
    /dev/sdb8: LABEL="PBR_DRV" UUID="EAE2FAE7E2FAB743" TYPE="ntfs" PARTLABEL="Basic data partition" PARTUUID="a83f8fa3-771d-4b09-8b6f-412cf0c599d6"
    /dev/sdb9: UUID="7ca56a4d-53d8-4b15-9d31-b303b2e50061" TYPE="ext4" PARTLABEL="Linux Root filesystem" PARTUUID="850c708f-e49d-4644-b2a5-2e7f2e4f179a"
    /dev/sdb10: PARTLABEL="Linux swap" PARTUUID="09362d68-f17f-47fd-9789-2ee867c3a558"
    /dev/sdb11: UUID="43341233-4387-46f4-bb58-fe54898a9ecd" TYPE="ext4" PARTLABEL="Linux Opt filesystem" PARTUUID="6ce647c7-781c-4c1d-944c-0145da207c75"

    The corresponding gdisk output is:

    Number Start (sector) End (sector) Size Code Name
    1 2048 2050047 1000.0 MiB 2700 Basic data partition
    2 2050048 2582527 260.0 MiB EF00 EFI system partition
    3 2582528 4630527 1000.0 MiB FFFF Basic data partition
    4 4630528 4892671 128.0 MiB 0C01 Microsoft reserved part
    5 4892672 948645887 450.0 GiB 0700 Basic data partition
    6 1870245888 1870962687 350.0 MiB 2700
    7 1870962688 1923391487 25.0 GiB 0700 Basic data partition
    8 1923391488 1953523711 14.4 GiB 2700 Basic data partition
    9 948645888 1022046207 35.0 GiB 8300 Linux Root filesystem
    10 1022046208 1055600639 16.0 GiB 8200 Linux swap
    11 1055600640 1870245887 388.5 GiB 8300 Linux Opt filesystem

    Partitions 1, 6 and 8 seem to be Recovery Partitions as listed by the Windows 8.1 disk management facility. However partition 6 does not seem to have a LABEL on it so maybe it is some kind of special partition and not a normal recovery partition?

    I don't yet have the path to efi files within those three partitions, but I expect that when I run the arch install iso again I may be able to mount them and have a look at the directory structures? Perhaps this helps at least partly?

     
  • mcloaked

    mcloaked - 2014-02-20

    Here is a screenshot of the partitions as Windows disk management sees them. I noticed that partition 4 (128Mib) which is a Microsoft Reserved Partition seems to not be seen by Windows in this screenshot. It is also interesting that it thinks that the recovery partitions are all 100% free space!

     
    Last edit: mcloaked 2014-02-20
  • Roderick W. Smith

    mcloaked: I've got a Lenovo myself, and so that's about the only computer line for which rEFInd should already work with respect to this new feature. If you can try the latest version of rEFInd, you can check this yourself -- you should see an icon on the second row that will kick off the Lenovo recovery tool. (This icon might be absent depending on your refind.conf settings, though -- the showtools line needs to be commented out or include the windows_recovery token.) If you try this and the Windows recovery icon does not appear, then could you please try to identify what program launches this tool (it's probably on your /dev/sdb3, which is probably fs1: in an EFI shell) and give me its filename? Thanks. Also, bear in mind that this tool is designed to restore your system to factory defaults, so don't play with it randomly; just go in, read the prompts to verify that it's what I think it is, and get out.

    Vic_J: It's possible that one of the programs you mention is a candidate for adding to this slot, but I'm not positive of that. Could you try running them to see what they do? (Keep in mind, though, that some of these programs could be dangerous to run!) I'd say that /EFI/HP/boot/bootmgfw.efi and /EFI/HP/SystemDiags/SystemDiags.efi are the most likely candidates for recovery tools. It's also conceivable that the recovery tool is something that GRUB did not pick up. You could use find in Linux to look for more, as in find /boot -iname "*.efi". Thanks.

     
  • mcloaked

    mcloaked - 2014-02-21

    Thank you for the feedback on the Lenovo laptop, Rod. I am hoping to do the arch install in the next couple of days on this new Lenovo. I'll try to get the info you ask for and post the filename but it may be a few days.

     
  • mcloaked

    mcloaked - 2014-02-21

    I have booted the arch install iso and mounted the possible recovery partitions to look at the files in them. It seems that you are right that partition 3 is the only one of the set of partition 1,3,6 and 8 which contains any .efi files.

    The details I have for the four partitions is as below:

    Partition 1:

    ls /mnt1
    Recovery/ System\ Volume\ Information/

    No efi files

    Partition 3:

    Directories in partition 3:
    Boot/ bootmgr bootmgr.efi EFI/ OneKey/ Version.txt*

    cat Version.txt:

    version 7.0.1.8:

    release notes:

    1. Version 7.0.1.6:

    1) \ESP\Updates\OneKey\main\lrsboot.exe update to v1.0.0.11
    2) \PBR\Onekey\Main\ModifyLang.exe update
    3) \PBR\Onekey\Main\LRS-Config-Org.xml update for following lrsboot.exe
    4) \PBR\Onekey\OsImage\Osimage.exe and Osimagedll.dll update to v7.2.1.104

    1. Version 7.0.1.8:

    1) \ESP\Onekey* all boot files update to RTM Winpe v9200.
    2) \ESP\Onekey\OneKey\winpe\lrs.wim update to RTM winpe V9200.

    find /mnt3 -iname *.efi
    /mnt3/bootmgr.efi
    /mnt3/EFI/Boot/bootx64.efi
    /mnt3/EFI/Microsoft/Boot/bootmgr.efi
    /mnt3/EFI/Microsoft/Boot/LrsBootmgr.efi
    /mnt3/EFI/Microsoft/Boot/memtest.efi

    Partition 6:

    ls /mnt6
    Recovery/ System\ Volume\ Information/

    find /mnt6 -iname *.efi
    .. no output..

    ls /mnt6/Recovery/WindowsRE
    boot.sdi ReAgent.xml Winre.wim*

    Partition 8:

    ls /mnt8
    OKRBackup/ onekey/ System\ Volume\ Information/

    ls /mnt8/OKRBackup/Factory
    Boot.okr install.wim LrsEsp.okr ReCreatePartitions.txt Winre.okr
    Info.ini
    LENOVO/ MBR.okr ResetConfig.xml

    No .efi files

    So it seems that the partition which contains the recovery efi files is partition 3, but that the other partitions contain system images - these may have been created when I ran backup or system recovery creation from within Windows but one I guess is the Factory reset image that the Recovery that booting with the (Novo) OneKey Recovery button would use?

    I hope that this helps.

     
  • mcloaked

    mcloaked - 2014-02-21

    Having just completed an arch base install with refind as the bootloader the efibootmgr output is:

    [root@lenovo2 ~]# efibootmgr
    BootCurrent: 0005
    Timeout: 0 seconds
    BootOrder: 0005,0002,2003,0004,2001,2002
    Boot0000 EFI Network 0 for IPv4 (28-D2-44-32-4D-85)
    Boot0001
    EFI Network 0 for IPv6 (28-D2-44-32-4D-85)
    Boot0002 Windows Boot Manager
    Boot0004
    Lenovo Recovery System
    Boot0005 rEFInd
    Boot2001
    EFI USB Device
    Boot2002 EFI DVD/CDROM
    Boot2003
    EFI Network

     
  • mcloaked

    mcloaked - 2014-02-22

    I am attaching the rEFInd graphical boot screen in my laptop. I presume that the neat icon at bottom left with the lifejacket and Windows logo is the Windows recovery boot?

     
  • Roderick W. Smith

    Yes, that's the Windows recovery item. If you select it, you should then see Lenovo's recovery tools. (Be careful with that, though; they're used mainly for restoring a system to its factory defaults, so don't play with it randomly!)

     
  • mcloaked

    mcloaked - 2014-02-25

    If you have enough information already then I will only play with the recovery tools as a last resort if the system fails. Since I don't know the sequence of screens and actions if I start the recovery boot, and at what point it actually begins to change the disk structure I would prefer to avoid going into it. If I can boot Recovery, and see some information that you need but then get out of it safely, then I can do so.

     

Log in to post a comment.