Extremely Slow Boot Mac Mini 6,2

beatmag
2013-01-27
2013-09-08
  • beatmag

    beatmag - 2013-01-27

    I've been trying to install rEFInd boot manager and it's working in a really strange way.

    I have a 1TB Hitachi 4k sector advanced format hd.

    The issue I'm getting is that after selecting the OS if its not Mac OS. The boot loader sits on the grey penguin or grey windows icon, assuming these are rEFInd display screens. It sits there for 30 seconds to 1 minute. Before the screen blacks out and the boot process starts. This happens for USB media too. This applies to Windows 8 and Ubuntu 12.10 special amd64+Mac ISO install.

    I have 6 gpt partitions.
    1 efi
    2 osx
    3 osx recovery.
    4 win8 ntfs
    5 Ubuntu ext4
    6 data fat32

    My hybrid MBR is
    1 efi
    2 win8
    3 Ubuntu
    4 data

    When I press ALT to use the Apple boot menu. Booting into windows is extremely quick. Select the windows 8 partition and the boot starts straight away. This doesn't seem to boot Ubuntu as in it doesn't detect Ubuntu at all. I can install grub on master boot record and this will make the Windows partition boot grub first then I can select windows or Linux in there.

    Would you be aware of any reason to the very long delay before the actual boot takes place? I did read a forum post in the project page that it might be a firmware issue. but it's strange that apple boot loader can boot so quick. While refind sits there for 1 minute before booting.

    The other question I wanted to ask you is what causes rEFInd to disappear? I've read alot of information on the rEFInd rEFIt and know that if the system gets blessed with something else this can happen. What other things can cause it? Why would the system decide to bless back to the apple boot loader?

    Thanks

    I have been using the 0.65 version.
    However upgraded to 0.66 yesterday. Its still waiting about 30seconds before booting.

     
    Last edit: beatmag 2013-01-27
  • Roderick W. Smith

    The delay before rEFInd starts is fairly common, and I don't fully understand it; but you're reporting a delay when launching an OS, which could well have an entirely different cause. I suspect in your case the problem has something to do with activating the compatibility support module (CSM), which is the EFI firmware's way of simulating a BIOS. I don't know of an easy fix for this, and I'm not even sure offhand of how to help you find the cause. I can, however, suggest a possible workaround for Ubuntu (and perhaps even for Windows): Boot in EFI mode rather than in BIOS mode. The easiest way to get started with Ubuntu is as follows:

    1. In Ubuntu, run the mkrlconf.sh script that comes with rEFInd.
    2. Install the rEFInd filesystem driver for ext4fs.

    Thereafter, you should see one or more new rEFInd entries for Ubuntu, which should launch Ubuntu without using GRUB, and with any luck they'll be much quicker, too. Each entry launches a particular kernel, so you probably want to launch the one with the highest number, if you've got more than one. If this works, you can eliminate the no-longer-necessary BIOS-mode Ubuntu entry from rEFInd by overwriting the BIOS-mode boot loader code in your Ubuntu partition, as in (from Ubuntu):

    sudo dd if=/dev/zero of=/dev/sda5 bs=512 count=1
    

    Note that this command is potentially quite dangerous, especially if you get details wrong like specifying the wrong partition or omitting or specifying the wrong values for the bs= or count= options, so be careful!

    If this works, you might consider reconfiguring Windows to boot in EFI mode, too, but that's trickier. This article describes the conversion process, but it's intended for PCs, and Macs have significant quirks on this score. Therefore, I strongly recommend asking about this on a Mac forum before attempting to get Windows booting in EFI mode.

     
  • beatmag

    beatmag - 2013-01-28

    Hi Roderick,
    Thanks for the help. I sent a similar email to you a week or so ago but maybe it got caught in the spam folder.

    Anyway. I know that efi booting of win8 and Ubuntu has been working. But because its still in its early stages. I prefer the stability of old bios emulation boot for now.

    Is it worth to add some debug output onto the screen to see if we can localize the slow portion of the boot process?

    Because pressing ALT can boot so fast I'm wondering if its the efi to bios wait or something else. Pressing ALT does have a 5 second pause before the selection screen comes up. Then after selecting windows. It will wait another 5 seconds which I think is the bios emulation time the. Booting starts.

    Version 0.66 felt a little faster. If refind is doing the same as a ALT key boot. We should be able to match the same speed. It is very strange indeed. Any other users with newer MacBooks or Mac hardware reporting the same??

    By the way great work on refind!!!!!! Refit must have had the same lag. Because when I first tried refit. I thought it wouldn't boot so I force shutdown and just booted with ALT key. The wait was easily 30 to one minute with no disk activity. Looked idle.

     
  • Roderick W. Smith

    Try the EFI-mode booting of Ubuntu. The probable worst-case scenario is that you'll waste a few minutes trying to set up something that won't work to your satisfaction. You can't do any real harm with it, and you can easily switch back to BIOS-mode booting if it doesn't work. It's far from new or early; I've been doing it on my own Mac since I got it over two years ago (albeit not in quite the way I suggested in my earlier post). EFI-mode booting of Windows 8, OTOH, is pretty "bleeding-edge," so I understand your reluctance to try that.

    Unfortunately, I don't have access to Apple's source code, so I don't know how they're triggering a BIOS-mode boot, so I can't compare that to what rEFInd does. I've barely touched that code from rEFIt, so it's not surprising that rEFIt has the same problem. I suspect that the problem occurs after rEFInd hands control over to the EFI, but if you wanted to test that I could certainly provide you with a test version that prints a few messages along the way. Of course, even if I'm right that the delay occurs in the EFI, that's not to say that it's not rEFInd's fault; it could be that rEFInd is doing something wrong in setting up the system calls. (I don't fully understand that part of the code, which is one of the reasons I've barely touched it!)

     
  • Joe van Tunen

    Joe van Tunen - 2013-04-19

    One thing rEFInd does that the Startup Manager (ALT at boot) doesn't do when booting a legacy OS is update the active partition of the MBR (otherwise the partition that was set as active would boot). Could that be a problem on 4k drives?

    Note that the Startup Manager only lists one Windows option per disk. The BIOS emulation will execute the code in the MBR which executes the code in the boot block of the partition that is set as the active partition in the MBR. So you'll need a different way to switch between Ubuntu and Windows if you're not going to use rEFInd (either edit the MBR before switching or add boot menu items for the other OS - use grub for Ubuntu and EasyBCD for Windows).

    Maybe an option that makes rEFInd work like the Startup Manager might be useful. The option would disable MBR changes, and would make rEFInd list one Legacy OS option per hard drive. At least the option could be used to test if the MBR write is the problem.

     
  • Roderick W. Smith

    Changing the contents of the MBR is unlikely to be any more or less of a problem on Advanced Format drives (those with 4KiB physical sectors) than with "regular" drives. From a software perspective, the two disk types are often identical. Furthermore, both rEFIt and rEFInd actually change the MBR only if certain conditions are met, mainly if the partition being booted is not marked as being active. Thus, if you're BIOS-booting just one partition, you'll never change the MBR -- at least, not after the first time you boot that OS.

     
  • Winfried

    Winfried - 2013-04-29

    The delay before rEFInd starts is fairly common, and I don't fully
    understand it;

    Adding my 2c to that comment: I have a Debian/AMD64 setup with an encrypted (root)partition. Refind was starting up very slow until I emptied the /boot/efi/EFI/refind/drivers_x64/ directory. Everything fine since then.

     
  • Brett Keller

    Brett Keller - 2013-08-12

    I'm experiencing the same problem as the OP: booting to a legacy OS hangs at the gray OS icon screen for about thirty seconds before continuing the boot process. In my case, I'm on an iMac 13,1 dual-booting both Mac OS X 10.8.4 and Windows 7 x64 using the latest available rEFInd version (0.7.3). I have a 512GB SSD as the only drive in the system. Mac OS X boots normally with only about 5 seconds on the gray Apple icon, but a Windows boot sits at the gray Windows icon for about 35 seconds. After the hang, Windows proceeds to boot normally and at a normal pace.

    Like previous posters, I can confirm that the built-in Mac firmware boot manager (accessible via holding the Option key at boot) only takes about 5 seconds between selecting the Windows option and displaying the Windows boot splash, which matches the performance of Mac OS X booting. The problem only seems to occur in rEFInd. I activated text mode in rEFInd to see if I could find any debugging messages, but all that displayed were the two usual lines of text.

    I did find one temporary fix to the problem, which perhaps might help shed some light on things. If I clear the Mac's NVRAM at boot by holding Command-Option-P-R on the keyboard, and on the next immediate boot I select Windows in rEFInd, the hang is gone and the gray Windows icon is only displayed for the usual 5 seconds! However, if I reboot again right after that and again select Windows in rEFInd, the hang returns and I'm back to 35 seconds of wait.

    Other information that might be helpful: when I first installed rEFInd, there was no hang problem. Only at some unknown point later on, probably after a bunch of OS updates on either side plus software installations, did the problem appear. Also, I tried to see if Winfried's advice would help, but I don't have any drivers folder in my rEFInd installation at all. I tried reblessing rEFInd as well using the command as listed in the documentation, but that had no effect either. Note that I have installed rEFInd to my HFS+ boot volume, not the EFI partition, and I just let the install script use defaults during installation under Mac OS X.

    If you need any more information, I'll be happy to provide it. Any suggestions or tests you'd like me to run would be most welcome.

    I certainly appreciate the hard work you've put into rEFInd and thank you for keeping it FOSS. Also, your research into Apple's "hybrid MBR" has proven invaluable to me as I build my custom system image for use in our educational lab environment. Your website should be required reading for anyone who wants to multi-boot a Mac and do anything more than the simple "Boot Camp Assistant" will let you do.

    Thank you so much for your efforts and any help you might be able to provide.

     
  • patricebeutler

    patricebeutler - 2013-09-08

    Hello

    I have exactly the same problem. As Brett Keller mentioned, everything works fine for one boot after resetting the NVRAM. Any news on this thing? A solution would be really great!

    rEFIt is great, thanks!

     

Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:





No, thanks