rMBP & ext4 driver issues

  • ende42

    ende42 - 2013-11-08

    Hi there,

    I tried installing rEFInd on a late 2013 rMBP. I partitioned with DiskUtility and installed rEFInd from OSX with install.sh onto the OSX boot volume. Then I booted an Arch USB key, formatted the linux partition ext4 and installed Arch on it.

    It took me some time to realise that I have to install the ext4 driver into the /EFI/refind/drivers_x64 folder. Right? At least rEFInd doesn't seem to find the linux kernel otherwise.

    Anyway… after putting the ext4 driver into /EFI/refind/drivers_x64 the box hangs on reboot. It plays the startup sound once normally and then repeats playing the very first part of the startup sound infinitely with about a 3 seconds gaps and at lower volume. I verified the culprit is indeed the ext4 driver. The ext2 driver would have no effect: The box boots but I still can't see the linux kernel in the rEFInd menu.

    Is there any way around this? Like making a FAT partition just for the kernel so that rEFInd would see it without drivers? Or putting the kernel onto the OSX volume? But how should rEFInd be configured then that the kernel knows which partition to boot?

    As you can see I'm really new to all this. Any help would be highly appreciated.

    Best regards, Niko.

  • ende42

    ende42 - 2013-11-08

    Ok, I found this http://www.rodsbooks.com/refind/linux.html#reconfigure and I'm about to try the ESP option.

    Still I'd consider rEFInd with ext driver more convenient. I's using rEFInd version 0.7.4 btw. (forgot to mention above).

  • ende42

    ende42 - 2013-11-09

    I managed to work around the issue by placing the kernel, the ram image and a refind_linux.conf directly on the Apple EFI partition (vfat) and mounted this in /boo/efi. Other than the Apple EFI partition being only 200MB I like this solution.

    Although I found a work around the ext4 driver still doesn't work.


  • Roderick W. Smith

    I've just released version 0.7.5, which includes a fix for some driver-loading issues on some Macs. You might want to give it a try. I can't guarantee that it will fix your problem, but it might. (Most of the problem reports I've seen relate to loading multiple filesystem drivers, rather than the ext4fs driver specifically.)

  • eternalhack

    eternalhack - 2013-11-21

    I have a late 2013 MBP 11,3 and had no issues with using the ext4 driver with version 0.7.5. rEFInd found kernel and ramdisk on my ext4 partition just fine.


Log in to post a comment.