New citation input screen blanking out.

Help
Pat Gehrke
2009-02-11
2013-05-28
  • Pat Gehrke

    Pat Gehrke - 2009-02-11

    Here's an interesting problem reported by two of our users that I cannot replicate for myself:

    This is in Internet Explorer.

    They click to add a citation and the new citation input screen comes up, looks great.

    They click in any text input box and start typing and just a couple letters in almost the whole screen blanks out.  Sometimes a few input boxes or dropdown boxes remain but are unusable and all the text is gone.

    Our guess is that this was caused by the autocomplete function and one user turned his off (along with making a bunch of other untracked changes to his desktop) and it worked fine.  The other turned his off and still the same problem.

    Any ideas?

     
    • Matthias Steffens

      Hi Pat, thanks for the report.

      > This is in Internet Explorer.
      >
      > They click to add a citation and the new citation input screen
      > comes up, looks great.
      >
      > They click in any text input box and start typing and just a
      > couple letters in almost the whole screen blanks out.

      Hmm, strange. I've never heard about that one before.

      Which versions of Internet Explorer are they using? And does the same IE version work fine for other users?

      Also, does it happen with other versions of IE?

      I assume this only happens with IE? I.e., have the users who were facing this problems tried another browser?

      It seems reasonable to assume that the auto-complete functionality might be the culprit here, since other than that, the refbase "Add Record" form is just plain old HTML (a table with a form) -- all standard & valid.

      Matthias

       
    • Pat Gehrke

      Pat Gehrke - 2009-02-25

      It looks like the culprit is the autocomplete function in RefBase.  If the user goes into options in their refbase user account and turns off AutoComplete, it works just fine.  So, it is not the Internet Explorer autocomplete that causes problems, but it is the functionality inside of the refbase system.

      For now I'm just having our few people who enter citations turn that off and we are doing fine.  Just fyi in case others encounter the same issue.

      -Pat

       
    • Matthias Steffens

      Hi Pat, thanks for the feedback.

      Answering these questions may help us further to track this issue down:

      Which versions of Internet Explorer are your users using? And does the same IE version work fine for other users?

      Also, does it happen with other versions of IE?

      I assume this only happens with IE? I.e., have the users who were facing this problem tried another browser?

      Thanks again,

      Matthias

       
    • Pat Gehrke

      Pat Gehrke - 2009-03-04

      I did manage to get this into a stable state, that is to say, I can 100% control and predict its occurrence.  As long as we leave the autocomplete function inside refbase off it never happens.  When it is on, it will always happen in Internet Explorer for any entry that triggers the refbase autocomplete [...] to appear.

      Chrome (my default browser at home) does not ever encounter this problem.

      Firefox also is flawless (and the refbase autcomplete function is gorgeous in this browser).

      So, it looks like only IE has this problem.  The IE version I am using is 7.0.5730.11.  Other users are all running some manifestation of version 7.  I have not had a chance to test is against other versions of IE, but I will see if I can get onto a machine with another version # of IE and try it out some time next week.

      This is really not even a minor annoyance for us now, as no one on our system needs the autocomplete function, but I am more than happy to continue testing and providing feedback.  Matthias, if you would like entry access to the database to see it in operation I would gladly set up an account for you as well.  Let me know anything I can do to help the refbase crew out.

      Thanks again for all the help with this.

       
    • Matthias Steffens

      Hi Pat, thanks for further testing this issue and for reporting back to us. This is helpful information.

      I fear that I lack the time and JavaScript knowledge to find a good workaround for IE. refbase uses the Prototype & script.aculo.us JavaScript frameworks for its auto-complete functionality. I'm not sure whether these are compatable with IE at all (but I had thought so).

      Anyways, many thanks for your offerings to help out. I'll let you know if we need someone for testing purposes etc.

      Best, Matthias

       
    • Pat Gehrke

      Pat Gehrke - 2009-03-07

      One more question on this:  Is there a way to disable the autocomplete function in the "Simple Search" system for users who are not logged in / do not have accounts?  Most of our users do not have logins but are simply searching our system for citations, so I don't have user settings to tinker with for most folks searching the database.

      Thanks,

      Pat

       
    • Matthias Steffens

      Hi Pat,

      Normally, the admin is able to set options for every one who's not logged in via this URL:

      user_options.php?userID=0

      refbase internally gives the anonymous user a user ID of zero ('userID=0'). See also:

      http://www.refbase.net/index.php/Configuring_refbase#How_can_I_change_options_.26_permissions_for_everyone_who.27s_not_logged_in.3F

      However, in case of the auto-complete option, the setting isn't available as an individual option for anonymous users -- instead, it is taken directly from variable '$autoCompleteUserInput' in file 'initialize/ini.inc.php'.

      So, the solution would be to globally switch of auto-completions in 'ini.inc.php':

      $autoCompleteUserInput = "no";

      Then, login as admin and re-enable auto-completions for all users (on their respective user options pages) that should see auto-completions.

      HTH, Matthias

       

Log in to post a comment.

Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:





No, thanks