unable to import BibTex record

  • I have refbase installed with bibutils (path to bibutils: /usr/local/bibutils/) but I'm unable to import records with this format.
    The record I'm trying to import is:

    @book{Royce Beckett and James Hurt-1983,
    ISBN = {0898744156},
    author = {Royce Beckett and James Hurt},
    title = {Numerical Calculations and Algorithms},
    publisher = {Krieger Pub Co},
    year = {1983},

    I tried using the web page and the console client (refbase_import), and always get the message:

    There were validation errors regarding the data you entered:

    Unrecognized data format!

    If I transform the record to RIS format, using bibutils (bib2xml, xml2ris), then there is no problem importing the data.

    This is the record I get with bibutils:

    TY  - BOOK
    AU  - Beckett, Royce
    AU  - Hurt, James
    PY  - 1983//
    TI  - Numerical Calculations and Algorithms
    PB  - Krieger Pub Co
    SN  - 0898744156
    ID  - RoyceBeckettandJamesHurt-1983
    ER  -

    I'm using refbase 0.90 and bibutils 3.35.

    something must be happening during the format conversion, but the bibutils utilities are working fine, and the bibutils path in refbase is alright:

    mysql> select * from depends;
    | depends_id | depends_external | depends_enabled | depends_path         |
    |          1 | refbase          | true            | NULL                 |
    |          2 | bibutils         | true            | /usr/local/bibutils/ |
    2 rows in set (0.00 sec)

    What might be the problem, or how can I find out?

    • ... by the way: safe_mode is off in php.ini

    • Hi, thanks for the clear problem description.

      Try removing whitespace from the cite key in your BibTeX record, i.e. the following BibTeX record should import fine (if Bibutils has been installed correctly):

      ISBN = {0898744156},
      author = {Royce Beckett and James Hurt},
      title = {Numerical Calculations and Algorithms},
      publisher = {Krieger Pub Co},
      year = {1983},

      I don't think that whitespace is allowed in BibTeX cite keys, but I could be wrong. refbase currently assumes that BibTeX cite keys don't contain any whitespace. I could change this if whitespace is really allowed within BibTeX cite keys.


    • Matthias: Thanks! It worked! Thank you for the prompt answer and for the tip!
      By the way: refbase seem to be a a very nice package, I think it'll become a very useful tool in our lab. Thanks for the good work!
      Best regards

      • Hi Kenneth, I'm glad to hear this did solve your BibTeX import problems, and thanks for the kind words!

        Let us know if you run into any further issues.