"you have no permission to perform this query!" with new user

Help
2014-05-04
2015-01-16
  • Dear friends,

    it's my first time using refbase and I'm encountering some problems after installation. After having created my first user, I keep getting the error message "you have no permission to perform this query!" when I try to access the Detail View of any of the records. This only happens when I'm logged in with the new user (not with the refbase user) and, although I have checked the permissions of the new user, I haven't been able to find the cause of this error (Detail View is enabled for the new user). What I find more puzzling is that I did not get this error the first time I installed refbase and messed a little bit around with it (I had to reinstall it).

    Does anyone know why this could be happening?

    Thank you very much in advance for your help.

     
  • That may be the issue fixed in this commit:
    http://sourceforge.net/p/refbase/code/1389
    Perhaps you can upgrade to the SVN bleeding-edge branch version?

     
  • Thank you very much, Richard!

    I do not know why, but it worked perfectly. Now I am fighting with a further error (new post coming, I am afraid), but this has been totally solved.

     
  • Tom Cobbaert
    Tom Cobbaert
    2015-01-16

    Had the same problem, but the commit fixed it here as well. Perfect, thx!