RIS export in www.refbase.org

  • Cecilia Lopez

    Cecilia Lopez - 2010-12-01


    I played for some time in the demo database (http://www.refbase.org) before installing refbase for my research group.

    I have "my" refbase running well so far, but I would like to add the records I entered to the demo database.

    When I try to do a RIS export from the demo database (NOT the one I installed, but the public one), I get a blank page.

    What is missing in my computer for this to work? The RIS export actually works fine from the database I installed in that same computer.

    I have tried doing it in different computers (Ubuntu, openSuse, Windows) and different browsers (Firefox, Internet explorer). Btw Zotero works fine on Firefox in all the cases, and it can do a RIS export fine.

    Thanks in advance, and thanks for such a great software.


  • Richard Karnesky

    RIS export works for me.  Which records are you trying to export?  Have you tried another format (particularly MODS XML)?


  • Cecilia Lopez

    Cecilia Lopez - 2010-12-02

    Typically I log in with my user (cecilia.lopez@icn.cat) and I try to export "My refs".

    For example, the one with serial number 27268 (Authors Araya, Omedo, Bastus… 2008).

    None of the export formats work for me actually. I get blank pages with RIS and Bibtex and some others, and with MODS XML, I get some text that when I copy it into the "import record" gives me an error.

    Can you give me a serial number of a record that you can successfully export? What could be wrong with my records, or my browser/computer?

    Thanks a lot for your help,

  • Richard Karnesky

    27677 had worked for me yesterday, but now does not.  There must be something wonky going on with the host, but I'm afraid Matthias may have to consult them on this issue.

    MODS XML export always works.  What import error do you get on your own server?  Do you have bibutils installed?

  • Cecilia Lopez

    Cecilia Lopez - 2010-12-02

    So, I exported 27677 as MODS XML, which produced a file mods_export.xml. Then I try to import that file into the demo database at www.refbase.org (not my database), by choosing that file with "Browse" and then clicking "Import". Then I get an error message in red saying:

    There were validation errors regarding the data you entered:

    However I did the following: I imported that xml file into Zotero, successfully. Then I exported it as RIS from Zotero. Then I imported the ris file that Zotero gave me into the demo database (by copy+pasting the contents into the "Records" field) and it worked. I will try that tomorrow in my database (I don't have remote access to it).

    So all that was only in the demo database - not mine. In my database/server I have installed bibutils… I'm not sure how well it is installed (I followed the instructions on the refbase webpage, but honestly I didn't understand what I was doing), but at least I can export/import RIS successfully between my database and Zotero.

    Still, I don't understand how MODS XML exported out and then imported into the demo database works fine for you and not for me :-(


Log in to post a comment.