Bibutils

Help
2009-03-31
2013-05-28
  • die weberin

    die weberin - 2009-03-31

    Dear all,
    I try to install refbase to manage and share my PhD bibliography. I'm not expert with php and mysql and have a problem to import my existing files. In the demo-database, it works verry well.
    Where and how should I creat my bibutils-path. I've downloaded bibutils 3.35.  I find two bibutils folders, one in the export folder and one in the import folder. Should I install it there?
    i'm using MAMP on MAC OS X.
    What can I do?
    Thanks,
    die weberin

     
    • Matthias Steffens

      Hi,

      installation of Bibutils isn't really double click and forget, sorry for the trouble! I'll try to give detailed installation instructions below.

      > Where and how should I creat my bibutils-path.

      In general, you can install the Bibutils programs wherever you like as long as the
      programs are eaccessible and can be executed by your webserver.

      To install Bibutils on Mac OS X you could either install it via MacPorts (MacPorts.org), or you could do it manually:

      1. Download the Bibutils binaries for your system.

      2. Extract the archive and copy the contained programs to a directory that can be accessed by your webserver.

      A typical directory location on Mac OS X would be '/usr/local/bin/'. So you could:

      a) Open Terminal.app from your /Applications/Utilities/ folder (the folder is called "Dienstprogramme" in German).

      b) Type 'cd ' (note the trailing space) in Terminal.app and then drag the folder which contains your Bibutils programs from the Finder into your Terminal.app window. This should insert the path to your Bibutils folder into your Terminal window.

      c) Press Return. This will make your Bibutils folder the active directory in your Terminal window.

      d) Type 'sudo chmod 755 *' your Terminal.app window and press Return. When asked, enter your user login password and hit Return again. This will make sure that the programs are readable & executable.

      e) Type 'sudo cp * /usr/local/bin/' in your Terminal.app window and hit Return. This should copy your Bibutils programs to the /usr/local/bin/ directory.

      3. You now need to tell refbase about the location of the Bibutils programs. You can do so during installation of refbase, or if you've got refbase installed already, you could follow the instructions given at:

      http://www.refbase.net/index.php/Bibutils#Installing_Bibutils_for_use_with_refbase

      When you're logged into refbase as admin, you should be able to enter the two UPDATE commands into the refbase 'sql_search.php' form, i.e.:

      4. Open refbase in your browser, login as admin, and click on the "SQL Search" link in the page footer. In the upcoming form, enter the following command into the SQL Query text entry field and hit the "Search" button:

      UPDATE depends SET depends_path = "/usr/local/bin/" WHERE depends_external = "bibutils";

      5. Similarly, click again the "SQL Search" link, enter the below command and hit the "Search" button:

      UPDATE depends SET depends_enabled = "true" WHERE depends_external = "bibutils";

      You're done. Let us know if import/export via Bibutils still doesn't work for you.

      Hope this helps,

      Matthias

       
    • die weberin

      die weberin - 2009-04-02

      Dear Matthias,
      thank you very much for this very detailed description. It was very helpful and now everything is runnig.
      :)
      die weberin

       
    • Matthias Steffens

      I'm glad that this solved your problem. And thanks for reporting back.

      Let us know if you run into anything else.

      Regards, Matthias

       
    • Daniel Taghioff

      Daniel Taghioff - 2009-06-08

      Hi Mattias

      I have a similar problem. I am using refbase (which looks excellent by the way) to help build an academic network site, iframed into Joomla*.

      http://media-anthropology.net/index.php

      I cannot get bibutils working, on a reseller account on Rochenhost, who host joomla.org (they are open-source friendly in other words.)

      I have checked my server type (they are linux) they have the following setup:

      Apache version    2.2.11 (Unix)
      PHP version    5.2.9
      MySQL version    5.0.67-community
      Architecture    x86_64
      Operating system    Linux
      Shared Ip Address    206.123.87.201

      They have magic quotes on, safe-mode off, my files are in an executable directory, with executable permissions.

      I set the path to the directory with the correct absolute path, using the sql command you gave, with a slash on the end.

      I told bibutils that the dependency was there with the second command you gave.

      I even queried the "depends" table, and it looks like you said it should.

      I tried your sample bits of formatting (for bibtex) from your site, and it still did not recognise the format, though it accepts references in non bibutils formats, and it took an arXiv ID.

      I am very puzzled, and don't know what next to check. Any ideas?

      Daniel

      *( BTW A joomla integrate via Jfusion would be great, as that is also already integrated into Moodle, so then you would have a full CMS, LM, and Ref system, a nice dream...  http://www.jfusion.org/\)

       
      • Richard Karnesky

        Do you have shell access to the system to verify that your bibutils executable work as expected when they are executed manually?  In the past, I had usually compiled my own binaries when on x86_64.

        It would help to enable error logging on the server & see what happens.  It would also help to know more about what you see in the browser when it fails (e.g. a blank page?).

        --Rick

         
    • Daniel Taghioff

      Daniel Taghioff - 2009-06-09

      OK, I am asking my ISP about shell access and error logging, but on the face of it I do not have that as I am using a reseller account on a managed server.

      The error on the web-page is the standard

      "Validation error,, your format is not recognised." error.

      I am assuming this is a bibutils issue, as it is the same message people seem to get in the forums etc... in relation to a Bibutils problem, and the non-bibutils formats work ok.

       
      • Richard Karnesky

        It would be useful if you used the error message verbatim (rather than paraphrasing it).  It sounds as if you are kept at import.php & that you have "There were validation errors regarding the data you entered:" in the header & "Unrecognized data format!" above the "Records:" box.  If this is inaccurate, please be more precise in saying what you see.

        The "Unrecognized data format!" should only appear when your data does not match the regular expressions used to automagically import data.  This happens before the data is sent to bibutils, so bibutils may not be the culprit here.  Which formats (other than BibTeX) have you tried to use that lead to this error?  Do they work in the demo databases?

        --Rick

         
    • Matthias Steffens

      Hi Daniel,

      which version of Bibutils are you using? If you are currently using Bibutils v4.x, please try again using Bibutils v3.4 which you can get here:

      http://bibutils.refbase.org/

      Does that version work better?

      Also, please check with your ISP that the PHP 'exec()' command is not blocked for your account, and that the active PHP temp/session directory is readable/writable.

      There were users who were able to run Bibutils successfully only after compiling it themselves from source. If you have a very nice ISP, they might even do it for you...

      Btw, you might be also interested in this thread:

      https://sourceforge.net/forum/forum.php?thread_id=1276761&forum_id=218757

      Matthias

       

Log in to post a comment.

Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:

JavaScript is required for this form.





No, thanks