Error when adding new record

Help
2005-06-02
2013-05-28
  • Nobody/Anonymous

    When adding a new record refbase returns the following error:
    "You did login elsewhere leaving this page in an out-dated state!
    Record data had to be reloaded omitting your changes. Please re-edit this record:"

    The error message is permanent, so it is impossible to add any record at this time.

    Any ideas what has been done wrong or how to resolve the "out-date state"?

     
    • Matthias Steffens

      Hmm, not sure what's going wrong here.

      The error message you're describing is a prevention mechanism that tries to prevent that possibly outdated data get written to the database. This error message does normally occur if you opened a browser window with the Add/Edit Record form but did NOT log in, then opened refbase again in another browser window or tab and logged in there. When switching back to the first window you must reload the page first to update its login state. If not, you'll receive the error message you're describing.

      Does this error also happen when you're properly logged in the current window (as indicated by the login status message in the upper right corner of the window)?

      If the login status message in the upper right corner still says "You must be logged in to submit this form!" then you won't be able to successfully add/edit the record.

      What platform, browser (naem & version) and PHP version are you using?

      Matthias

       
    • Nobody/Anonymous

      I logged in with the administrative user and tried to add some initial references to the database. I did not open any other connection to the refbase server neither at my client pc (in a second browser) nor from another pc.

      The error occured using firefox 1.0.4. but is also existend when using IE. The server is a suse 9.2 running apache 2.0.50 and php 4.3.8.

      ***I just tried to add an entry from another machine and succeded, beeing logged in under the same account, using the same browser and the same cookie-settings.***

       
    • Matthias Steffens

      Strange.

      When using refbase on the machine that produces the error, can you successfully login? I.e., do you see the login status message in the upper right corner of the window saying "Welcome <USERNAME>! You're logged in as <EMAILADDRESS>"?

      A problem with the cookie management would have been my next guess, but obviously, that can't be the problem if cookie settings are identical on both machines.

      I have no idea what else could cause this problem. I wish I could be more helpful!

      Matthias

       
    • Nobody/Anonymous

      The login has been succesful and the status message is as predicted.

      Thank you very much for your quick response.
      You are doing a great work!

       

Log in to post a comment.