Error 403 Forbidden

  • Eugen Glavan

    Eugen Glavan - 2012-10-01

    I try to install refbase 0.9.5 on my webserver (Apache 2.2, PHP 2.5, MySQL 5.0) but I keep receive the ”403 forbidden error” when I launch http://…/install.php. I changed the permissions of the files but with no success.  Any suggestions?

  • Richard Karnesky

    PHP 2.5 is ancient.  Are you sure that's right?  refbase requires version 4.4 (available since 2005) or above.

    403 is most often caused by incorrect ownership or permissions on the files or directories that are needed.  This is not something special to refbase & you might be able to see if this is the problem by accessing the 'index.php' that ships with refbase and/or by accessing another file in that directory.  You can also often consult your file logs to get more details on the error.

  • Eugen Glavan

    Eugen Glavan - 2012-10-02

    Thank you for your quick response. Indeed, the correct version for PHP is 5.2.
    I was able to install manually refbase but I keep getting the following errors:

    PHP Warning:  session_start() : Cannot send session cache limiter - headers already sent (output started at /home/rsocio10/public_html/references/initialize/ in /home/rsocio10/public_html/references/includes/ on line 73

    PHP Warning:  fopen( : failed to open stream: HTTP request failed! HTTP/1.0 403 Forbidden
    in /home/rsocio10/public_html/references/includes/ on line 5213

    What can I do?

  • Richard Karnesky

    Indeed:  your 'index.php' seems to be the only page that doesn't lead to 403 errors right now.  What are the permissions and user/group ownership of, for example, show.php and index.php?

  • Eugen Glavan

    Eugen Glavan - 2012-10-02

    The permissions for files are set to 644 and for the folder 755.

  • Richard Karnesky

    And what about the ownership of the files?

    I can think of no issues with the refbase distribution that would make index.php work & show.php NOT work.  You might contact your hosting provider for assistance.  If the files have the same permissions, they may not have the same user/group owner.  If they have the same user/group, the next thing to check would be if you had some sort of setting that explicitly allowed index.php, but disallowed other files (copy/rename index.php to index2.php & see if you can load that).  Some hosts are mis-configured (e.g. in httpd.ini or .htaccess) to disallow may files by default.

  • Eugen Glavan

    Eugen Glavan - 2012-10-04

    It's the same.
    I installed on the server other applications such as Wordpress or Open Journal Harvester without problems. The thing is I want really bad to install refbase because I liked the facilities and I think will help me a lot at work. At the research institute where I'm employed it's currently undertaking a strategy to publish online the academic papers. Is there a possibility to receive assistance in exchange to a fee or a donation?

  • Richard Karnesky

    Money is  a good motivation for getting stuff done somewhat quickly.

    Either direct access to the server or "extreme handholding" would be needed to troubleshoot this: we haven't seen it reported in the past and there's not much to go on still.  It is unclear to me if you've inspected/changed httpd.ini or .htaccess files.  It is also unclear if you tried other troubleshooting (copying index.php to another name and seen it work, for example).  More detailed logs would certainly make things much easier.

    If you want to go  that route, contact me by email outside of these forums so we can work something out.


Log in to post a comment.

Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:

JavaScript is required for this form.

No, thanks