Pbs with PHP

  • Nobody/Anonymous

    It's very strange, my PHP cannot interpret the files. I downloaded the refbase 0.8. I put the files in a folder named biblio. And when I point my browser on them, it's like they are not recongnized as PHP but as text files. But if I put a phpinfo.php file in the same folder, no problem to see all the php details.

    Did I miss something ?
    I'm using Ubuntu 5.10 and WAMPP.

    It's a shame, your software look very nice and it's exactly what I need ...

    • Matthias Steffens

      Hmm, that's very strange.

      Hust to make sure: have you tried another browser or accessing the refbase scripts from another machine?

      Are you accessing your biblio folder locally (i.e. is it located on the same machine?) or on a remote server?

      Could this be a permission problem or that your refbase scripts are not marked as 'executable' files?

      Best regards, Matthias

    • Nobody/Anonymous

      Thank you for your answer !

      Everything is on the same machine, I access it locally, I have "chmod" 777 the whole folder to be sure. It's the same if I access it on the machine with Firefox or from a remote machine with IE or Firefox.

      I tried to copy the files on my windows machine and it seems to work (bad config of the sessions but at least I have PHP errors, not the code written like it's text).

      Could it be a caracter encoding problem ? When I open the file and save it again, it works one time  but with an error, it's like it didn't include the include.inc.php file
      and then if I actualize it comes back to text.

      Never seen that, it's weird ..

    • Nobody/Anonymous

      It seems that the character encoding could be the problem : I tried to remove all the comments (sorry for you) and save again the install.php file and some of the includes files, and it interpreted until include.inc.php, where it stopped and displayed the code.
      On which kind of machine did you save all the files ?

      • Richard Karnesky

        The files were written on PowerPC machines running OS X & x86 boxes running win32, FreeBSD, and Linux.  They have also worked under all said operating systems.

        When you chmoded the directory, did you do so recursively (dumb question, but...)?  Does 'ls -l' show anything different for files which you've edited compared to files you haven't (different perms or different owner)?  Can you possibly do a diff between a file you edited & the original?

    • Nobody/Anonymous

      I chmoded like that : chmod -R 777 folder
      I don't see any difference with ls -l between the files. A diff shows all the comments I deleted.

      I think the problem is specific to include.inc.php.
      When I try to open install.php with gedit, it's ok.
      When I try to open include.inc.php with gedit, it says that the character encoding is wrong and don't want to open it. I tried with specifying different character encoding, ISO-8859-1, ISO-8859-15, UTF-8, UTF-16 and even chinese :)
      But vi opens it without problem, so do nano.

      Firefox shows only a part of the include.inc.php file :
      From the beginning to line 143, it's in the source code but in pink, like html comments .. and then it shows this :

      \n caused the following error:", $oldQuery); return $result; } // -------------------------------------------------------------------- // Disconnect from the MySQL database: function disconn ... and so on ...

      Maybe you could send me again this one file and then we'll see if it resolves the problem ?
      (my email : llby at free dot fr )

      It's really too bad,

      • Richard Karnesky

        I can send you the file.  Are you using the 0.8.0 release?

        I'm still concerned that the files show up as text when they are commented!  This suggests a deeper configuration problem of your LAMP stack.

        You said you are using "WAMPP."  Did you mean XAMPP?  If so, which version?  If not, can you please post me to "WAMPP?" (I'm aware of wampserver for win32, but no stack on Linux.)

        The character encoding problem seems to be line 433:

        $queryNewOrder = eregi_replace('LIMIT','¥LIMIT',$query); // put a unique delimiter in front of the 'LIMIT'... parameter (in order to keep any 'LIMIT' parameter)

        where the unique delimiter is, perhaps, "too unique."  If you replace this character in vim, it might be OK (at least you'd be able to use iconv/trans/recode with no problems and should be able to edit in gedit).

        • Richard Karnesky

          oops..the yen is higher level iso-8859-1.  for some reason, iconv choked on it for me (as did gedit).

          Anyway--I think you have a deeper problem than character encoding.

    • Matthias Steffens


      AFAIK, the character encoding shouldn't pose any problems. Character encoding of the refbase script files should be ISO-8859-1 (aka Western ISO-Latin-1) and files are saved with UNIX line endings. You should be able to open these files in a standard text editor, otherwise something went wrong, probably when downloading/unpacking the archive?

      How did you download and unpack the archive? Have you tried re-downloading the archive (possibly with another tool)?

      Regards, Matthias

      • Richard Karnesky

        You are correct w.r.t. encodings & line endings.  Mostly.

        As I posted, the unique LIMIT delimiter in include.inc.php isn't ISO-8869-1.  I wouldn't expect this to break things, but we should probably fix it.


    • Matthias Steffens

      I've sent you a modified copy of the refbase-0.8.0 'include.inc.php' script privately.

      This script did in fact contain some control and one null character, which may have caused your problems.

      Please replace the original file at 'includes/include.inc.php' with the attached copy.

      Let us know if this makes for any difference.

      HTH, Matthias

    • Nobody/Anonymous

      Are you in Australia or somewhere at the other end of the world ? Because of your time stamps ..

      YES, it worked ! I can get now the installation interface, thank you very much !

      I'm battling with a SQL error now but I hope to find the solution.

      (Yes it's XAMPP, LAMPP for Linux, sorry ..)

    • Matthias Steffens

      Nice to hear that the scripts are now parsed by PHP!

      I'm currently sitting in rainy old Germany but I think the SF servers are in the Pacific area...

      Let us know if you run into other problems.

      Best regards, Matthias

    • Nobody/Anonymous

      Well, just to let know that everything works fine. I will now try to figure out how to import all our existant database in batch mode. Maybe bibutils will help me.

      Grüsse aus Niger, wo die Sonne scheint :)

      • Matthias Steffens

        Hmm, Niger, nice... :)

        As you may know, support for batch import and common bibliographic formats is still in development, but there are ways to accomplish this.

        As an example, if you're coming from Endnote you may want to try out the Endnote style file and PHP script that's included with refbase. This style file and php script allows Endnote users to transfer data into refbase at the command line (see the readme file in the contrib/endnote directory for further information).

        With some text munging, it may be also possible to directly load any text-based data file into the refbase MySQL database.

        Let us know if you require help with batch import.

        Best, Matthias


Log in to post a comment.

Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:

JavaScript is required for this form.

No, thanks