Error 1146

  • Nobody/Anonymous

    I have tried to install RefBase many, many times - after filling in the installation form on my browser I receive the following message:

    Error 1146 : Table 'esind.depends' doesn't exist

    When I select one of the links (such as "Home" or "Show All") the following text appears:

    Your query:

    SELECT format_name FROM formats LEFT JOIN user_formats on formats.format_id = user_formats.format_id LEFT JOIN depends ON formats.depends_id = depends.depends_id WHERE format_type = "export" AND format_enabled = 'true' AND depends_enabled = 'true' AND user_id = 0 AND show_format = 'true' ORDER BY formats.order_by, formats.format_name

    caused the following error:

    Error 1146 : Table 'esind.depends' doesn't exist

    My server is the Apache server from XAMPP. The only thing I can think of is that installation file didn't automatically create the new dabatabase. However, I have configured the configuration files and the php.ini settings look fine.

    I would be very obliged could someone help me out.



    • Richard Karnesky

      XAMPP ships with phpmyadmin.  Can you please use this to take a look at your database structure?  Also check to make sure that your database setting match what is in initialize/

      Can you please let us know which O.S. and the version number of XAMPP and if there is anything relevant in your log files?


    • Nobody/Anonymous

      Hi Rick, thanks for the reply.

      The OS is Windows XP; I'm using the latest version of XAMPP, i.e. XAMPP Windows 1.5.4a which has Apache HTTPD 2.2.3, MySQL 5.0.24a, PHP 5.1.6 + 4.4.4 + PEAR + Switch, MiniPerl 5.8.7, Openssl 0.9.8d, phpMyAdmin, XAMPP Control Panel 2.3

      I know about phpmyadmin but am not sure what to look for in there. The database (ESIND) looks created but has no tables.

      In \xampp\apache\logs\access - I found the following: - - [21/Nov/2006:21:06:30 +0000] "POST /refbase-0.9.0/install.php HTTP/1.1" 302 - - - [21/Nov/2006:21:06:31 +0000] "GET /refbase-0.9.0/error.php?errorNo=1146&errorMsg=Table%20%27esind.depends%27%20doesn%27t%20exist&headerMsg=The%20following%20error%20occurred%20while%20trying%20to%20query%20the%20database%3A&oldQuery= HTTP/1.1" 200 3875

      I hope that's of any help...



      PS: I would love to make RefBase work. My research is centred upon an annotated bibliography (in Endnote and Procite) which has 720 entries, and growing.

      • Richard Karnesky

        For what it is worth, I've tested in XAMPP on win32 and can't replicate your error.

        I started with a stock install of XAMPP, set the MySQL root password <http://localhost/security/xamppsecurity.php>, set '$databaseName = "ESIND";' in 'initialize/', loaded <http://localhost/refbase-0.9.0/install.php>, put in the MySQL root password, and it then installed fine.

        The access log tells us nothing except that you tried to access index.php and then accessed an error page.  Please look in 'xampp\apache\logs\error.log'

        You may try dropping the ESIND database (assuming you don't have any non-refbase data in there & try install.php again.


    • Matthias Steffens

      Hi Raf,

      I'm not sure but maybe your issue is due to some incorrect permissions?

      If you can successfully access and manage your MySQL database(s) from within phpMAdmin, then you could also install refbase from within phpMyAdmin:

      1. Create the database that you're going to use in conjunction with refbase (if it exists already, then that should be fine)

      2. Select your database in the phpMyAdmin interface and choose the SQL tab

      3. Browse and select the 'install.php' file (in the main refbase directory) and click the "OK" button (alternatively, you could open 'install.php' within a text editor, copy all of it's contents and paste them into the SQL command text entry form in phpMyAdmin.

      This should add all required tables to your MySQL database.

      Then proceed with adding your own admin user, as is outlined here:

      Hope this helps, Matthias

    • Nobody/Anonymous

      It works!!!!

      Thank you so much!

      • Matthias Steffens

        That's great to hear!

        Could you tell us what steps where required to make it work so that we can improve things if necessary?

        Thanks, Matthias

    • Nobody/Anonymous

      Hi Mathias,

      After the Database configuration I used my browser for the web-based installation with 'install.php' I received the Error 1146 message as qouted in my first post: "Error 1146 : Table 'esind.depends' doesn't exist"

      Using the latest version of XAMPP, in phpMyAdmin I could see that the database ESIND was created, yet did not contain any tables.

      I followed your directions. I opened the file 'install_utf8' (in the main refbase directory) and copied the entire content into the SQL command text entry form in phpMyAdmin.

      That's it - I hope you can do something with this.


      • Matthias Steffens

        Hi Raf,

        thanks for the explanation! The only thing I can imagine is some issues around permissions. Could it be that the MySQL user which you used for the web-based installation of refbase is different from the MySQL user that is used when phpMyAdmin accesses your MySQL tables? Maybe the first user does not have privileges to create MySQL tables?

        Anyways, I'm glad that you could solve your problem! We'll try to further ease the installation process in future versions of refbase.

        Thanks for your patience, Matthias

    • Nobody/Anonymous

      Hi Mathias - nope... I used the same user for the web-based installation as the one who has access to phpMyAdmin, i.e. "root", with the same password

      Good luck with further developments!


Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:

No, thanks