#253 Invalid Credentials

pending-works-for-me
5
2012-01-28
2012-01-02
Anonymous
No

Since a few days ago, I am unable to log in to Redmine from the Eclipse plugin - the credentials are no longer considered valid. A couple things have happened in the meantime (I have changed Eclipse installation, and Redmine has been upgraded to 1.3) so I don't know what is causing the issue: is there a debug log for the Eclipse plugin somewhere so that I can figure out if the problem is the Redmine upgrade or if there is a problem with my installation?

Discussion

  • Comment has been marked as spam. 
    Undo

    You can see all pending comments posted by this user  here

    Anonymous - 2012-01-03

    I tested the connection using a different system, whose Eclipse installation wasn't updated, and I can confirm the issue is related to the Redmine upgrade.
    I also attempted a connection using curl and my credentials and everything seems in order (ie. I can retrieve the requested JSON).
    Please let me know if there is anything else I can do to help fix this.

     
  • Comment has been marked as spam. 
    Undo

    You can see all pending comments posted by this user  here

    Anonymous - 2012-01-05

    I'm having the same issue. The problem is with redmine 1.3.

     
  • Sven Krzyzak

    Sven Krzyzak - 2012-01-11
    • status: open --> open-works-for-me
     
  • Comment has been marked as spam. 
    Undo

    You can see all pending comments posted by this user  here

    Anonymous - 2012-01-13

    When logged out, mylyn/version results in a request for credentials (HTTP Basic-like dialog); the corresponding log entry is:
    x.x.x.x - - [13/Jan/2012:12:37:35 +0100] "GET /mylyn/version HTTP/1.1" 401 630 "-" "Mozilla/5.0 (Macintosh; Intel Mac OS X 10.7; rv:8.0.1) Gecko/20100101 Firefox/8.0.1"

    When logged in, the same page results in the following:

    <?xml version="1.0" encoding="UTF-8"?>
    <version api="2.7.2.stable" authenticated="true" authenticatedAs="xxxxx" xmlns="http://redmin-mylyncon.sf.net/api">
    <plugin tiny="2" minor="7" major="2">2.7.2.stable</plugin>
    <redmine>1.3.0.stable.8438</redmine>
    <rails>2.3.14</rails>
    </version>

    When logged in, /mylyn/authtest results in the same popup; entering my credentials the output is a page with "Hello xxxxx - your HTTP-Basic-Authentication does work properly."
    When logged out, authtest redirects to the login page (with HTTP code 302 Found).

    I am currently unable to attach the full server log, I hope this information is enough; if such is not the case, please let me know and I'll try to retrieve any other information you might require.

     
  • Sven Krzyzak

    Sven Krzyzak - 2012-01-15

    Have you the "REST web service" enabled ?

    Do you use username and password or the API-key?

     
  • Comment has been marked as spam. 
    Undo

    You can see all pending comments posted by this user  here

    Anonymous - 2012-01-16

    Yes, the REST API is active, and I've tried using both API-Key and User/pass auth to connect (I didn't try using curl with the API key, let me know if I should).

     
  • Sven Krzyzak

    Sven Krzyzak - 2012-01-16

    OK, the REST-API is active, the Redmine plugin is installed and work without any problems together with HTTP-Auth - I have not really a idea what's the problem.

    But we can check the logfiles.

    The Eclipse plugin writes some log entries in <WORKSPACE>/.metadata/.plugins/net.sf.redmine_mylyn.common/redmine_connector.log.

    Please delete this file and validate the RepositorySettings again.

     
  • Comment has been marked as spam. 
    Undo

    You can see all pending comments posted by this user  here

    Anonymous - 2012-01-17

    Here's what the logfile looks like after trying to validate the settings; please note that the last line followed an atttempt using user/pass.

    2012-01-17 15:38:47,796 INFO RedmineConnector BundleEvent STARTED
    2012-01-17 15:38:47,801 INFO RedmineConnector BundleEvent STARTED
    2012-01-17 15:38:48,666 INFO RedmineConnector BundleEvent STARTED
    2012-01-17 15:40:12,353 DEBUG n.s.r.i.a.c.AbstractClient Execute HTTP GET-Method /mylyn/version key=a9da9c9295b2024d85488364304df8059cbcb2b0
    2012-01-17 15:40:53,857 DEBUG n.s.r.i.a.c.AbstractClient Execute HTTP GET-Method /mylyn/customfields key=a9da9c9295b2024d85488364304df8059cbcb2b0
    2012-01-17 15:40:59,129 DEBUG n.s.r.i.a.c.AbstractClient Execute HTTP GET-Method /mylyn/customfields key=a9da9c9295b2024d85488364304df8059cbcb2b0&key=a9da9c9295b2024d85488364304df8059cbcb2b0

     
  • Sven Krzyzak

    Sven Krzyzak - 2012-01-18
    • milestone: --> Redmine 1.3 (STABLE)
     
  • Sven Krzyzak

    Sven Krzyzak - 2012-01-18

    > version api="2.7.2.stable" ...

    Your Redmine plugin is outdated. Please update it first.

     
  • Sven Krzyzak

    Sven Krzyzak - 2012-01-28
    • status: open-works-for-me --> pending-works-for-me
     
  • Sven Krzyzak

    Sven Krzyzak - 2012-03-07

    Have you still this problem?

     
  • Alaak

    Alaak - 2012-03-14

    I do encounter the same problem after having updated to redmine 1.3. Is there already a solution available?

     
  • Sven Krzyzak

    Sven Krzyzak - 2012-03-17

    versions? kind of authentication? cgi yes/no?

     
  • Alaak

    Alaak - 2012-03-17

    Redmine ist Version 1.3.1.stable
    Redmine Mylyn Connector in version: 0.3.7.201203072118

    I tried authentification via API key as well as via Credentials. Same error for both.

    What do you mean by CGI yes/no?

    thanks for your work.

     
  • Sven Krzyzak

    Sven Krzyzak - 2012-03-18

    What's the version of the Redmine plugin?

    Do you use cgi on server side?

     
  • Alaak

    Alaak - 2012-03-18

    I guess you mean the plugin on the server. The version is: 2.7.1.stable

    On the server side runs an Apache Web Server and Ubuntu 10.04.4. However Redmine is not installed using apt. I followed the steps on the Redmine Website to connect a version directly downloaded from the Redmine website to my Apache Web Server. Since I am no Ruby Programmer I do not fully understand what happened there, but it worked in the end.

     
  • Sven Krzyzak

    Sven Krzyzak - 2012-03-18

    2.7.1 is a little bit outdated. The current version is 2.7.6.

     
  • Alaak

    Alaak - 2012-04-01

    2.7.6 seems to work. Thanks for your support.

     

Log in to post a comment.

Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:





No, thanks