#161 Error when trying to install plugin into Zend Studio

closed-invalid
5
2010-12-30
2010-12-15
Anonymous
No

Is Zend Studio supported?

Cannot complete the install because one or more required items could not be found.
Software being installed: Mylyn Connector: Redmine 0.1.0.201012080643 (net.sf.redmine_mylyn.feature.feature.group 0.1.0.201012080643)
Missing requirement: Mylyn Connector: Redmine 0.1.0.201012080643 (net.sf.redmine_mylyn.feature.feature.group 0.1.0.201012080643) requires 'ch.qos.logback.core [0.9.19.v20100419-1216]' but it could not be found

Discussion

  • Gennaro Vietri

    Gennaro Vietri - 2010-12-16

    Similar issue for me, on Zend Studio 8.0 (based on Eclipse 3.6):

    Cannot complete the install because one or more required items could not be found.
    Software being installed: Mylyn Connector: Redmine 0.1.0.201012080643 (net.sf.redmine_mylyn.feature.feature.group 0.1.0.201012080643)
    Missing requirement: Redmine-Mylyn-Connector API 0.1.0.201012080643 (net.sf.redmine_mylyn.api 0.1.0.201012080643) requires 'bundle org.json 1.0.0' but it could not be found
    Cannot satisfy dependency:
    From: Mylyn Connector: Redmine 0.1.0.201012080643 (net.sf.redmine_mylyn.feature.feature.group 0.1.0.201012080643)
    To: net.sf.redmine_mylyn.ui [0.1.0.201012080643]
    Cannot satisfy dependency:
    From: Redmine-Mylyn-Connector UI 0.1.0.201012080643 (net.sf.redmine_mylyn.ui 0.1.0.201012080643)
    To: bundle net.sf.redmine_mylyn.api 0.1.0

     
  • Gennaro Vietri

    Gennaro Vietri - 2010-12-16

    Yes! Enabling Helios site under Preferences -> Install / Update -> Available Software sites Redmine Mylyn Connector install succerful!

     
  • Nobody/Anonymous

    I have added the Helios server (this fixed the requirement for the ch.qos.logback.core, but now i get this error:

    Cannot complete the install because one or more required items could not be found.
    Software being installed: Mylyn Connector: Redmine 0.1.0.201012080643 (net.sf.redmine_mylyn.feature.feature.group 0.1.0.201012080643)
    Missing requirement: Mylyn Connector: Redmine 0.1.0.201012080643 (net.sf.redmine_mylyn.feature.feature.group 0.1.0.201012080643) requires 'org.eclipse.core.runtime 3.6.0' but it could not be found

    Would it not be possible to define a list of servers that are required in order to get this to install with all the dependencies?

     
  • Nobody/Anonymous

    Aaah, just realised this means i must be using Galileo rather than helios, seems like i would need to install zend studio 8 (latest version) to get the right version of eclipse!

    Maybe adding this to the wiki on the first page would be a good idea?

     
  • Sven Krzyzak

    Sven Krzyzak - 2010-12-30
    • status: open --> closed-invalid
     

Log in to post a comment.

Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:

JavaScript is required for this form.





No, thanks