SourceForge has been redesigned. Learn more.

really slow recording (<1 fps) on fas...

  • Soren Harward

    Soren Harward - 2010-03-14

    I'm trying to record a video on a reasonably fast machine (quad-core Xeon), but I can't get recordmydesktop- to capture more than 1 frame about every 3-5 seconds.  I have disabled compositing, I have made sure that the DAMAGE extension is enabled.  I have tried capturing the whole desktop, a specific screen area, and a specific window.  I have tried with sound on and off.  I have tried recording to disk, and recording to RAM.  None of these result in acceptable frame rates.

    My hardware:
    - 4-core Xeon 2.5GHz
    - 10GB RAM
    - Gentoo 64-bit
    - nVidia Quadro w/ proprietary drivers

    Any ideas what I could tweak to get recordmydesktop to work properly?

  • Nobody/Anonymous

    I have similar problem. I tired recording speed painting but it was really slow.
    I'm using: Ubuntu 9.10 64-bit
    AMD X2 Athlon II 215, 2MB 64Bit 2.7GHz
    4GB 800MHz Dual Channel RAM
    VGA ATI Radeon 4650 1GB

  • AnotherUser

    AnotherUser - 2011-10-22

    Hello, I have a similar problem - the screen does not seem to be being captured - CPU usage is nowhere near maxed out. I have used this system before (a long while ago) to successfully generate video sequences

    I am running opensuse 11.3 -  could it be the encoding stage? The img.out file is generated, and I get 79 "FRAM" entries in the generated file.

    Python 2.6.5 (r265:79063, May  6 2011, 17:25:59)
    [GCC 4.5.0 20100604 ] on linux2
    Type "help", "copyright", "credits" or "license" for more information.
    >>> s=open("img.out")
    >>> len(fileContents)
    >>> import re
    >>> re.findall("FRAM",fileContents)

    >>> length(re.findall("FRAM",fileContents))

    So the frames appear to be different, and there are quite a few of them - Could it be the encoding step? Does rmd provide any API for dumping these "FRAM" elements to something like a PNG?

  • AnotherUser

    AnotherUser - 2011-10-22

    OK, so its this bug:

    Can one of the maintainers please apply the patch "patch to use sane defaults", or release a fixed stable tarball??


Log in to post a comment.