problem with open source radeon driver

Help
2007-07-02
2013-06-03
  • Nobody/Anonymous

    I dont know if the problem is with the "radeon" driver, but Im assuming it is.

    Once I load gtk-recordmydesktop, Xorg process takes up about 60% of my cpu. (even while not doing anything)

    If I start recording, Im lucky if recordmydesktop can capture 1 fps. (whether run from gtk-record or just normal recordmydesktop from a prompt).  Tried all the options, doesnt make a difference.  Window manager doesnt seem to make a differnce, from beryl to metacity to fluxbox...

    This is on a amd64/3200 X800 Ati card, 1 gig ram (32 bit linux installed though).

    Conversly, my 2nd box, a p3-800/192 megs ram with an old nvidia card can record the desktop just fine.

    Any ideas, or just blame the radeon driver?? :)

    Maybe radeon doesnt play nicely with libXdamage?

    I searched google, but couldnt find any reference or anything anywhere.

    (havent tried fglrx, and dont really plan on it)

     
    • John Varouhakis

      John Varouhakis - 2007-07-03

      Hi,

      If Xorg needs 60% to get ~1fps, then the problem is most likely
      to be in your driver/card configuration.
      I'm afraid though, that I can't offer any advice on this, as I
      don't have any experience in a similar hardware setup.

      John.-

       
    • Nobody/Anonymous

      Its just so weird, this is the only application I have found that doesnt perform that well.

      All normal 2d applications work right, 3d works right (quake3, ut2004, etc).

      I know the oss radeon driver isnt 100% done, so it must be missing something that recordmydesktop uses.

      Oh well, thanks for the response.

       

Log in to post a comment.

Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:

JavaScript is required for this form.





No, thanks