Can't make video and sound together

Help
2007-04-05
2013-06-03
  • Eustaquio Rangel de Oliveira Jr.

    Hi there.

    Yesterday I made a cool video of my desktop with recordmydesktop.
    Today I bought a little mic to use with my laptop and noticed that there were no sound coming from it, so I called alsamixer and changed some options there.
    Then I tried to record some stuff with video and audio, but unfortunelly I can't make both works. I get a message like

    Written 588444 bytes
    (304848 of which were video data and 283596 audio data)

    but when trying to play it with Mplayer I get

    AO: [oss] 44100Hz 2ch s16le (2 bytes per sample)
    Video: no video

    and no video is displayed. Seems that everything is ok and I didn't changed nothing more than the alsamixer from yesterday - I wonder if alsa will have something related to video - BUT I just turned on the laptop coming from the hibernate mode. Yesterday when I made the video it was turned off. Maybe a tip? There are just few free megabytes on RAM - Firefox is eating a lot - but there is a lot on the swap. Maybe when I turn it off and on something related to video can works, really don't know ...

    Btw, sometimes I get a 'Broken pipe: underrun occurred' message.

    Thank you for your attention!

     
    • Eustaquio Rangel de Oliveira Jr.

      I forgot to say: when using --no-sound, I can record the video.

       
    • John Varouhakis

      John Varouhakis - 2007-04-05

      Hi,

      >Written 588444 bytes
      >(304848 of which were video data and 283596 audio data)

      This doesn't seem normal (video data normally takes up the largest part of the file).
      So it's likely that video data isn't recorded at all, except from a couple of frames.
      I could go on guessing on the nature of the problem, but since you say that the problem
      occurs after hibernating, I will ask that you perform a clean reboot and retry.
      If the problem persists, please post back with the following information:

      i)    CPU model and architecture
      ii)   Graphics card and drivers you are using
      iii)  Distribution
      iv)   Anything else you consider important or
            less common in your setup (e.g. compiz/beryl)
      v)    version of recordMyDesktop

      Also, swap memory is many times slower than RAM. You should make sure to have enough memory
      free prior to starting a recording.

      >Btw, sometimes I get a 'Broken pipe: underrun occurred' message.

      Underruns can happen sometimes. Generally, they shouldn't cause any trouble
      and no action is required.
      If you are getting this error a lot, you should increase the sound buffer size
      (option -buffer-size). This will lead to increased latency, though.

      Let me know of what happened.

      Regards,
      John

       
    • Fajar Priyanto

      Fajar Priyanto - 2007-05-29

      Hello,
      First of all, I'm completely amazed by your work. This is absolutely all we have been searching in FOSS related to capturing screen into video. Thanks.

      However, I cannot record any sound at all. Video is ok, but no sound.

      This is my spec:
      Opensuse 10.2
      recordmydesktop-0.3.4-1.guru.suse102
      Installed on: Compaq Presario V3000
      Intel Dual Core 1.7GHz
      RAM 1GB
      00:00.0 Host bridge: Intel Corporation Mobile 945GM/PM/GMS/940GML and 945GT Express Memory Controller Hub (rev 03)
      00:02.0 VGA compatible controller: Intel Corporation Mobile 945GM/GMS/940GML Express Integrated Graphics Controller (rev 03)
      00:02.1 Display controller: Intel Corporation Mobile 945GM/GMS/940GML Express Integrated Graphics Controller (rev 03)

      I suspect that the HSF modem driver that I installed is interfering with recordMydesktop, because after I install the HSF modem driver, the only way I can adjust the volume is through the PCM channel, not the Master volume. Is it related? How do I resolve it?

      Thank you very much,
      Fajar.

       
      • John Varouhakis

        John Varouhakis - 2007-06-02

        In the majority of the cases I've seen where sound was missing, the
        problem was in the mixer configuration. recordMyDesktop just
        captures the preselected source of recording, whichever that is.
        So you must make sure that there is at least one input enabled for
        recording (mic, wave-mix, line in).

        >I suspect that the HSF modem driver that I installed ...
        >... Is it related? How do I resolve it?

        I don't see how I'm qualified to help you in a
        (hardware conflict?) problem.

        Also, please try to report on more relevant threads(or start new).
        This thread was originally started on an issue about video not getting
        captured when audio recording is enabled (which was probably caused by
        a hibernate, though due to insufficient feedback I can't say for sure).

         
    • Nobody/Anonymous

      hm I just realized that I'm having the same problem my self..now I have a pretty updated system so.. I don't think that can be the case.. but anyways.. I will keep trying to see what I can get.. also.. is there away to set it to run for a certain amount of time? becaue I cant seem to get the gtk one working correct. command line works though.

       
      • John Varouhakis

        John Varouhakis - 2007-06-02

        > hm I just realized that I'm having the same problem my self.

        Can you be more specific please? Are you reporting on the same issue
        that user taq had (no video at all, when capturing audio)?

        > is there away to set it to run for a certain amount of time?

        No, but you can use a combination of the sleep and killall commands
        to easily achieve that i.e.:
        ~$ sleep 5m; killall recordmydesktop
        This will send a SIGINT which makes recording stop and starts the
        encoding.

         
    • Nobody/Anonymous

      > Can you be more specific please? Are you reporting on the same issue
      that user taq had (no video at all, when capturing audio)?

      sorry, Ya.. I do not get video when capturing audio, but if I append the --no-sound on there.. then the video recording works fine.

       
      • John Varouhakis

        John Varouhakis - 2007-06-05

        > sorry, Ya.. I do not get video when capturing audio, but if I append the --no-sound on there.. then the video recording works fine. 

        Sorry, but I don't have the slightest idea of the reason right now.
        It also can't be some thread lockup issue, because in that case the
        program would get stuck (it wouldn't encode anything and it would
        refuse to shutdown).

        I'll look into any possible causes further when I have some free time.

        John.-

         
    • TKD

      TKD - 2007-06-05

      Ok I figured out what to do, currently.. my mplayer plays ogg files, as far as my knowledge goes *.ogg files are only audio files (correct me if I'm wrong). When I play the ogg file created by recordmydesktop all I get is sound but no video, so I though that maybe we need to convert it or something.. unless I'm missing a plugging for mplayer.. this is how I did it.

      firt I ran,
      recordmydesktop --quick-subsampling --zero-compression --no-wm-check
      then.
      ffmpeg -i out.ogg out.avi

      but I cant seem to get good quality audio out of it yet, also the video quality sux so its going to take me a minute to work my way around ffmepg. Unless someone here can get something better for me.
      now I dont know if this is supported as the author of recordmydesktop stated that he wants to bring *.ogg forward and I support his judgment. I would like to get a nice sharp video though :) now I'm not to sharp but.. I will keep trying.

      Maybe you guys can help me out here.. I uploaded an example so you guys can see for your self

      http://www.projects.vdrives.net/tmp/

      now.. the video quality has nothing to do with recordmydesktop. Recordmydesktop is a brilliant program and I must say.. the video quality is great :-)

       
      • John Varouhakis

        John Varouhakis - 2007-06-05

        > as far as my knowledge goes *.ogg files are only audio files

        No, that's a common misconception. The ogg format is only a container.
        The audio is encoded in vorbis and the video in the theora codec.
        Which means that a *.ogg file can have only video,only audio or both.
        You can't tell from the extension alone.

        > all I get is sound but no video, so I though that maybe we need to convert it

        Normally it should be playable, without any convertions(what would be
        the purpose of rendering an unplayable file?). As you say there's something
        missing from your mplayer compilation. As far as I know, reasons for this can be
        a) You are using gentoo and haven't compiled mplayer with theora support
        b) You are using an older distribution, since theora support is universal
        in all the new ones I know of.
        I also seem to recall that some slackware derivative distro was late at adding
        support for theora.

        Anyway, the easiest way to solve this is to get the cross-platform, Free-software
        vlc player, available at http://www.videolan.org/, as it will play back the files
        with no problems.

        Also, why are you adding the --no-wm-check option?
        Since you are using beryl, this option will destroy your recording(it might make cpu
        usage go down, but that's because it doesn't get any changes, other than cursor movement).
        Unfortunately, compiz/beryl recording is still a very heavy operation with recordMyDesktop.

        > but I cant seem to get good quality audio out of it yet
        You can't get good audio quality on the transcoded file or does the problem exist
        on the initial ogg file, too?

        If it exists on the ogg file:
        a) Check that your CPU isn't choked by the recording operation
        b) Keep playing with the mixer settings(don't set them at full)
        c) Adjust recordMyDesktop's -buffer-size option
        The default is 4096. Try doubling it (recordmydesktop -buffer-size 8192 ...).

        >also the video quality sux so its going to take me a minute to work my way around ffmepg

        Like I said above, when you use the --no-wm-check option you  aren't really
        recording anything. And also transcoding from a lossy format to another also lossy
        (theora to xvid), will noticeably degrade the video, so it's better to keep the original.

        John.-

         
    • John Varouhakis

      John Varouhakis - 2007-06-05

      > Anyway, the easiest way to solve this is to get the cross-platform, Free-software 
      > vlc player, available at http://www.videolan.org/, as it will play back the files 
      > with no problems.

      Sf does links on its own and the one above came out wrong. The correct is:
      http://www.videolan.org/

       
    • TKD

      TKD - 2007-06-05

      cool thanx, I will check that out.. and see what I can get. sorry for the inconvenience.

       

Log in to post a comment.

Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:





No, thanks