"I can't find a cache directory"

  • Nobody/Anonymous

    I am having trouble with this.

    I keep getting the message "I can't find a cache directory, or a current database. Have you tried installing Refeed?"

    When I click the word "refeed" it tells me that "Your cache directory exists, and is writeable." it also says:

    "If you got this far, Refeed was successfully installed.

    Head over the front page and start adding some feeds. "

    And if I click "front page" or "adding some feeds" it brings me back to the "I can't find a cache directory, or a current database. Have you tried installing Refeed?"  page!!

    I just don't know what I'm doing wrong, can anyone help?

    I kept getting that "line 230" too (i'm trying to install the WP plugin) but I thought I'd better work on the refeeds first.

    • Evan B

      Evan B - 2004-12-18
    • Nobody/Anonymous

      oh, sorry to duplicate your post!   i hope someone can help us, because I am utterly confused.

    • Michal Migurski

      Michal Migurski - 2004-12-18

      Anonymous - yours appears to be a slightly different problem. I'll have a look at what's up with Nitsky's installation, maybe that will help you as well. In the meantime, what is your server environment like? OS, shared, etc.?

    • Aron Miller

      Aron Miller - 2005-01-27

      I had the same problem.

      I believe that in \refeed\library\RF\install.functions.php the describe_table is returning an array and is subsequently used in isfeed() in a boolean operation and in my installation this apparently is treated as false whereas perhaps it is expecting true. If I hardwire it to return true (or perhaps true when columns greater then 0) then everything works.

      I also had to make all the join() functions for paths Windows-compatible.. maybe I have the wrong code? ;)

      I'm a novice at php so treat this as just a lead..

    • Nobody/Anonymous

      same problem here, installation happens quickly, no errors returned, "Head over the front page and start adding some feeds. " comes then when clicked
      this comes up:

      I can't find a cache directory, or a current database. Have you tried installing Refeed?

      cache directory is world-readable etc.

      • Michael Frumin

        Michael Frumin - 2005-01-31

        is it world-writeable too?

      • Michal Migurski

        Michal Migurski - 2005-01-31

        What version of MySQL are you running? This may be the same problem that aron_miller describes in this thread, in which case I would guess that you are running MySQL 4.0+, which returns column descriptions for timestamps in a slightly different format.

        I patched this problem in CVS; Michael, is the latest patched version up on reblog.org?

        • Michael Frumin

          Michael Frumin - 2005-01-31

          yes, now they are.  and stay tuned for MySQL 4.1 handling of timestamps.

      • Nobody/Anonymous

        Im fearfull that the cache folder may be open to extreeme vulnerablility. Is there any way around giving full permissions to this folder?

        • Michael Frumin

          Michael Frumin - 2006-11-15

          any way that the webserver can write to that directory is fine.  there are probably fancy ways to configure apache to let this happen. or you can make the cache directory the same group as apache, and chmod g+w


Log in to post a comment.

Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:

No, thanks