#189 Rdesktop NO SOUND Windows2008

closed
None
5
2010-12-27
2009-03-27
Andyal15
No

Hi to all,
we didn't get any Sound with rdesktop 1.6 from a MSServer2008 !
rdesktop servername -r sound:local --> works on Server2003 but did not work on Server 2008 !!

MS RDP Client works on both Versions !
Andy Ideas ??
Thanks
Andyal15

Discussion

  • Tobias Abt

    Tobias Abt - 2009-03-27

    I had the same problem.

    Try adding a disk resource, too. ("-r disk:tmp=/tmp")

    This opens a virtual channel that sound then can use, too.

    2008 seems to have changed something in that direction.

     
  • Nobody/Anonymous

    Hi Tobias,
    excuse me for the late reply (vacation).
    Thank you very much for your hint -> IT's WORKING !! THANK YOU VERY MUCH (Andyal15) !!!
    Other Question:
    Have you ever tryed Rdesktop 1.6 with Session Broker Server 2008 Load Balancing !
    I think redirection is not implemented in Rdesktop 1.6 !
    Error:
    NOT IMPLEMENTED: System pointer message 0x7f00
    WARNING: server sent an unexpectedly long string, truncating

    If i try it offten enough some time i'm routed to the right server (Round Robin) and Session is OK !

    Any Ideas ?
    Thanks
    Andyal15

     
  • Nobody/Anonymous

    I've tried this patch and the Server 2008 side does now report a Microsoft RDP Audio Transport Device, although I still don't have sound.

     
  • Comment has been marked as spam. 
    Undo

    You can see all pending comments posted by this user  here

    Anonymous - 2010-02-16

    Thank you for this hint!
    Now sound is working (rdesktop 1.6.0) with Windows 7 prof.

     
  • Henrik Andersson

    Fix commited, rev 1604.

     
  • Henrik Andersson

    • assigned_to: nobody --> hean01
     
  • Henrik Andersson

    • status: open --> closed
     

Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:





No, thanks