I am getting the following error message when trying to connect to a Windows 2008 server. I have no control over the server so I can't install anything or disable network authentication.

I use:
rdesktop -a 16 -k en-gb -g 1280x768 -u username -d myserver.example.com

I have tried this with both 1.6.0 and with 1.7.1 on Ubuntu, kernel:  2.6.38-15-generic

When I run strace I get :
read(3, 0x91603b0, 4096)                = -1 EAGAIN (Resource temporarily unavailable)

not really sure what that means, you might need more context.

I do not have a .rdesktop directory and I have cleaned out my .tsclient directory just in case. I also tried to create a .rdesktop directory in case the software wants that and tried running rdesktop as root but non of this has work

I have even tried xfreerdp as an alternative client but no luck. 

So basically all I am after is a confirmation that this does not work because of the requirement for network authentication or even better a solution to the problem.

rdesktop does not have a verbose or debug flag that I could see.

Any help would be appreciated and I would gladly supply all the information that I can

Gerhardus Geldenhuis