On 6/30/2014 12:11 AM, Henrik Andersson wrote:
On Fri, 27 Jun 2014 10:43:47 -0600
George Sexton <georges@mhsoftware.com> wrote:


On 6/27/2014 6:27 AM, John Friend wrote:
I think its an rdesktop bug related to pointer shadowing. Try to 
disable "pointer shadow" at control panel/mouse for a temp.
solution. I have not observed this problem w/ freerdp or mstsc

Thanks. Changing that setting does seem to have worked.

Just out of curiosity, commit r1792 should fix this and set this flag
per default when connecting to the server. This fix was verified
working and is included in release 1.8.2.
I tried using 1.8.2 compiled from source on OpenSUSE 12.3. Logging in as an administrator, if I enabled mouse pointer shadowing in control panel, the cursor stayed stuck on an hourglass. When I opened control panel, and changed it back to disabled, the cursor resumed normal operation.

I can reproduce these steps about 80% of the time.

The server is running Windows Server 2012 R2 with all patches applied and the connection is via WAN, or LAN.

You mentioned that you tested 1.8.2 and could produce this issue, could
you please double check if that is the case. If so, could it be that
you had a domain policy that overrided the pointer shadow settings ?

It's a new server, and I haven't created such a thing. Users can turn this setting on and off.

From: elizabeth.a.greene@gmail.com
Date: Thu, 26 Jun 2014 20:17:19 -0500
To: georges@mhsoftware.com
CC: rdesktop-users@lists.sourceforge.net
Subject: Re: [rdesktop-users] 1.8.2 - No Cursor w/ Windows Server
2012 R2

FWIW, I experienced this behavior intermittently last week on
Windows 8.1 to Server 2012R2 using the windows built-in mstsc.exe.
I.e. It may not be a rdesktop issue.

Elizabeth Greene

George Sexton
MH Software, Inc.
Voice: 303 438 9585