#311 connecting to win2008 ssesion broker

v1.8.2
closed-fixed
None
5
2014-05-21
2009-08-27
Anonymous
No

when connecting to Session Broker Server 2008 Load
Balancing !, some of the times it connects and some exit from the rdesktop and gives an error

error:
WARNING: rdp_in_unistr: iconv fail, errno 84
WARNING: server sent an unexpected long string, truncating
Segmentation fault

Discussion

1 2 > >> (Page 1 of 2)
  • Nobody/Anonymous

    we have the same problem. if the session broker move the rdp connection to an other server (the reason is load balancing) the rdp connection faild. we try it with a "igel" thin client and rdesktop v1.6. we get no error, the client simply close. there are solutions?

     
  • Comment has been marked as spam. 
    Undo

    You can see all pending comments posted by this user  here

    Anonymous - 2009-11-12

    We also have the same problem, the other problem is that you have to log on two times. As you first log on to the loadbalancing master and when it has choosen a server for you it doesn't remember the username and password.

     
    Last edit: Anonymous 2014-09-03
  • Nobody/Anonymous

    Same here when trying connect to Vista 64bit (RDP 6.1)

     
  • Amelia Nilsson

    Amelia Nilsson - 2009-12-18

    We also have this problem. When we try to access out TS-environment that are using Session Broker Load Balancing on Windows 2008 rdesktop would seg fault every time with the following reason:

    WARNING: rdp_in_unistr: iconv fail, errno 22
    WARNING: Unexpectedly large redirection cookie
    WARNING: server sent an unexpectedly long string, truncating
    Segmentation fault

    It would be great if you could assign this bug to someone and give it a bit higher priority since Windows 2008 TS-environments with Session Broker Load Balacing is more often seen at companies all over the world. Thanks in advance!

     
  • Nikolaj Sheller

    Nikolaj Sheller - 2009-12-22

    We are seeing the same problem here.
    Could this have something to do with localisation? I.e. conversion from one locale/codepage to another causes the string form the server to become an unexpected length?

    The error occurs in "rdp.c" in the method:
    rdp_in_unistr(STREAM s, char *string, in WINDOWS_CODEPAGE, g_codepage, (int) iconv_h);

     
  • wnyrodeo

    wnyrodeo - 2010-01-04

    we have the same issue. Can someone from the rdesktop dev. team please look into this issue?

    Thanks in advance, your help is always appreciated!

     
  • Peter Åstrand

    Peter Åstrand - 2010-01-21

    The patch has been comitted to Subversion. Hopefully fixes this bug, reopen if still problems.

     
  • Peter Åstrand

    Peter Åstrand - 2010-01-21
    • status: open --> closed-fixed
     
  • Nobody/Anonymous

    I am still having a problem with this in my environment. Session broker server is running on server 2008r2, and the terminal server farm is running server 2003. I am using a hardware load balancer from kemp, and ip address redirection is disabled. I built the lastest svn version of rdesktop, and now see:

    WARNING: server sent an unexpectedly long string, truncating
    ERROR: getaddrinfo: Name or service not known

    When I try to reconnect to an existing session.

    Thanks,
    Trent

     
  • Nobody/Anonymous

    The same for me on 2008 R2 :(

     
  • Nobody/Anonymous

    I have the same
    WARNING: server sent an unexpectedly long string, truncating

     
  • Peter Åstrand

    Peter Åstrand - 2011-04-13

    To the last 3 anonymous reporters: Are you trying with rdesktop 1.6.0 or the latest Subversion version?

     
  • Anna Martynova

    Anna Martynova - 2011-04-27

    I tried to connect to terminal farm of Windows 2008R2 servers with rdesktop 1.7.0. Sometimes rdesktop connects (I suppose when session broker doesn't redirect you to another server), and sometimes I receive a message:

    WARNING: server sent an unexpectedly long string, truncating

    At that moment rdesktop window is all black or shows frozen "welcome" windows logo.

     
  • Anna Martynova

    Anna Martynova - 2011-05-17

    The problem still exists with rdesktop 1.7.0.
    When I try to connect to existing session through Session Broker, I get such message:

    WARNING: rdp_in_unistr: iconv fail, errno 84

    rdesktop window is all black, and if it runs in fullscreen, you can't do anything (ctrl-alt-enter doesn't work).

     
  • William Seemann

    William Seemann - 2011-06-07

    I also encountered "WARNING: rdp_in_unistr: iconv fail, errno 84" when using a current trunk build of rdesktop. Can someone change the status of this bug since the problem isn't fixed.

     
  • Pierre Ossman

    Pierre Ossman - 2011-06-08
    • status: closed-fixed --> open-fixed
     
  • Pierre Ossman

    Pierre Ossman - 2011-06-08

    Reopening bug. Thanks for reporting, even though it might not have been the result we were hoping for.

     
  • Comment has been marked as spam. 
    Undo

    You can see all pending comments posted by this user  here

    Anonymous - 2011-06-24

    I was hoping that version 1.7.0 fixed this issue. However it looks like it doesn't. Its such a shame as it would solve a lot of issues and make this product really good. However it doesn't suite what we need and will have to look at alternatives until it is done.

     
  • Comment has been marked as spam. 
    Undo

    You can see all pending comments posted by this user  here

    Anonymous - 2011-08-05

    I've the same bug on a TSE Farm. It's very annoying :(

     
  • William Seemann

    William Seemann - 2011-12-13

    Any update on this bug? The status says "Open" but the resolution is marked as "Fixed". This bug is a pretty annoying for someone who relies on rDesktop daily.

     
  • DIMITRIOU

    DIMITRIOU - 2012-02-21

    Does anyone has find an issue to this bug?

    rdesktop -r scard 192.168.20.201

    Autoselected keyboard map fr
    WARNING: Remote desktop does not support colour depth 24; falling back to 16
    WARNING: server sent an unexpectedly long string, truncating

     
  • Stefano Girolimetti

    I get this issue too:

    # rdesktop -u <username> -d <domain> -f -b -z -k en-gb <host>
    WARNING: Remote desktop does not support colour depth 24; falling back to 15
    WARNING: rdp_in_unistr: iconv fail, errno 84
    ERROR: getaddrinfo: Name or service not known

    Windows Server 2008 shows an initial screen where I can login as DOMAIN\username (myself) or Other User.
    I select my user and enter my passwod, at which point rdesktop crashes.

    Any plans to fix this?
    I'm on version 1.7.1.

     
  • Comment has been marked as spam. 
    Undo

    You can see all pending comments posted by this user  here

    Anonymous - 2012-10-09

    Hello,

    Please see: https://sourceforge.net/tracker/?func=detail&aid=3575645&group_id=24366&atid=381349 (tracker patches item 3575645)

    Cheers

    Jarek

     
    Last edit: Anonymous 2015-02-28
  • Henrik Andersson

    • Group: --> NextRelease
     
1 2 > >> (Page 1 of 2)