#191 crash when using specific application

open
nobody
Internals (36)
5
2006-04-12
2006-04-11
Jordan T.
No

We are using a peice of software called RMS
(Reservation Management Software) which looks to be
made in Visual Basic inside a Windows 2003 Terminal
Server environment.

Using the application is fine, but when we click on a
certain button to open a new section of the program,
rdesktop crashes out - no core file is created however
it prints this to stdout:

X Error of failed request: BadValue (integer parameter
out of range for operation)
Major opcode of failed request: 56 (X_ChangeGC)
Value in failed request: 0x70
Serial number of failed request: 5699
Current serial number in output stream: 6289

There is nothing in syslog or the Xorg log files.

I have tried enabling/disabling all the options i can
think of (bitmap caching, color depth etc..) but it
doesn't help.

Discussion

  • Peter Åstrand

    Peter Åstrand - 2006-04-12

    Logged In: YES
    user_id=344921

    Which version of rdesktop are you using? Can you re-test
    with the latest CVS version?

     
  • Jordan T.

    Jordan T. - 2006-04-12

    Logged In: YES
    user_id=758476

    Using non-cvs Version 1.4.1 (from Mandriva 2006.0 RPMS)

    Just compiled CVS version (is there meant to be no
    configure? - i generated one using autoconf) and it seems to
    be working fine.

    Are there any known issues with currect CVS or can I role
    this out to our thin clients in the field ?

     
  • Peter Åstrand

    Peter Åstrand - 2006-04-12
    • status: open --> closed-fixed
     
  • Peter Åstrand

    Peter Åstrand - 2006-04-12

    Logged In: YES
    user_id=344921

    The CVS version should be fine.

    Since it solves this problem, I'm closing this bug.

     
  • Jordan T.

    Jordan T. - 2006-04-12

    Logged In: YES
    user_id=758476

    I can fix this problem by compiling CVS with dynamically
    linked libs, but if compiled statically it exhibits the same
    problem.

    The following binaries were produced from the same CVS tree:

    rdesktop: ELF 32-bit LSB executable, Intel 80386, version 1
    (SYSV), for GNU/Linux 2.2.5, dynamically linked (uses shared
    libs), not stripped <-- DOES NOT CRASH

    rdesktop: ELF 32-bit LSB executable, Intel 80386, version 1
    (SYSV), for GNU/Linux 2.2.5, statically linked, not stripped
    <-- STILL CRASHES

    The error is:
    X Error of failed request: BadValue (integer parameter out
    of range for operation)
    Major opcode of failed request: 56 (X_ChangeGC)
    Value in failed request: 0x86
    Serial number of failed request: 6127
    Current serial number in output stream: 6719

    I am statically compiling with glibc-2.3.5,
    libopenssl0.9.7-static-devel and libxorg-x11-static-devel-6.9.0

    CFLAGS = -m32 -static -g -O2 -Wall -I/usr/include
    -I/usr/X11R6/include -DPACKAGE_NAME=\"rdesktop\"
    -DPACKAGE_TARNAME=\"rdesktop\" -DPACKAGE_VERSION=\"1.4.1\"
    -DPACKAGE_STRING=\"rdesktop\ 1.4.1\"
    -DPACKAGE_BUGREPORT=\"\" -DSTDC_HEADERS=1 -DL_ENDIAN=1
    -DHAVE_SYS_TYPES_H=1 -DHAVE_SYS_STAT_H=1 -DHAVE_STDLIB_H=1
    -DHAVE_STRING_H=1 -DHAVE_MEMORY_H=1 -DHAVE_STRINGS_H=1
    -DHAVE_INTTYPES_H=1 -DHAVE_STDINT_H=1 -DHAVE_UNISTD_H=1
    -DHAVE_SYS_SELECT_H=1 -DHAVE_LOCALE_H=1 -DHAVE_LANGINFO_H=1
    -Dssldir=\"/usr\" -DEGD_SOCKET=\"/var/run/egd-pool\"
    -DWITH_RDPSND=1 -DHAVE_DIRENT_H=1 -DHAVE_DIRFD=1
    -DHAVE_DECL_DIRFD=1 -DHAVE_ICONV_H=1 -DHAVE_ICONV=1
    -DICONV_CONST= -DHAVE_SYS_VFS_H=1 -DHAVE_SYS_STATVFS_H=1
    -DHAVE_SYS_STATFS_H=1 -DHAVE_SYS_PARAM_H=1
    -DHAVE_SYS_MOUNT_H=1 -DSTAT_STATVFS=1
    -DHAVE_STRUCT_STATVFS_F_NAMEMAX=1
    -DHAVE_STRUCT_STATFS_F_NAMELEN=1 -DHAVE_MNTENT_H=1
    -DHAVE_SETMNTENT=1 -DKEYMAP_PATH=\"$(KEYMAP_PATH)\"

    LDFLAGS = -L/usr/lib -lcrypto -lpthread -L/usr/X11R6/lib

     
  • Jordan T.

    Jordan T. - 2006-04-12
    • status: closed-fixed --> open
     
  • Peter Åstrand

    Peter Åstrand - 2006-04-12

    Logged In: YES
    user_id=344921

    Interesting. By using
    http://www.rahul.net/kenton/xproto/xproto2xlib.html, I've
    found out that the crash is caused by any of these functions:

    XChangeGC
    XSetBackground
    XSetFillRule
    XSetFillStyle
    XSetFont
    XSetForeground
    XSetFunction
    XSetStipple
    XSetTSOrigin

    I have no idea which, though. Is the RMS software available?

     
  • Jordan T.

    Jordan T. - 2006-04-13

    Logged In: YES
    user_id=758476

    In this case im assuming its XChangeGC (as per the error),
    but why would dynamically compiling rdesktop fix it, while
    statically does not?

    Unfortunately RMS is proprietary software, the website is
    http://www.rms.com.au then products -> australia -> park

     
  • Peter Åstrand

    Peter Åstrand - 2006-04-13

    Logged In: YES
    user_id=344921

    >In this case im assuming its XChangeGC (as per the error)

    Actually, my list was incorrect: XChangeGC should not be
    included; rdesktop never calls this library function. So, it
    must be some of the other functions.

    >but why would dynamically compiling rdesktop fix it, while
    >statically does not?

    This is a very good question. I have no idea. It could be a
    race condition or something like that.

     
  • Nobody/Anonymous

    Dear all,

    I get this issue in recent days as i was using Allegro Design Entry CIS with a gridded ellipse component.

    I found that it crashed in the function 'ui_ellipse' in xwin.c with 'Hatch' style.

    After marked XSetStipple(...) and DRAW_ELLIPSE(...) in ui_ellipse, rdesktop works well but i can get only a ellipse without grid.

    Is there any way to solve it?

    Thx.