#153 RDesktop influences on KDE taskbar

open
None
5
2005-11-11
2005-05-10
sonic1234
No

I've noticed this behavior when running RDesktop
(1.3.1, 1.4.1) in KDE 3.3 environment. Most of the time
it looks like clicks on KDE taskbar are accumulated and
played back after some significant amount of time when
one or more RDesktop session are active. Other KDE and
non-KDE applications are working fine, including
application and screen switcher. When all RDesktop
sessions are closed, KDE taskbar returns to be alive.
At the same machine, RDesktop is working fine under
Gnome, no freezes, no issues. Please, advise, what is a
reason? Does it relate to RDesktop itself?

Discussion

  • Max Baker

    Max Baker - 2005-09-14

    Logged In: YES
    user_id=19674

    I can confirm the same problem using 1.4.1 with the KDE 3.2
    that ships in Red Hat Enterprise Linux WS release 3 (Taroon
    Update 3).

    Untested on other versions/platforms. Any ideas on this one?

     
  • Max Baker

    Max Baker - 2005-09-15

    Logged In: YES
    user_id=19674

    sonic1234 - Can you confirm wether turning off sound helps
    the situation?

    -r sound:local -> -r sound:off

    -m

     
  • Dale Martin

    Dale Martin - 2005-09-15

    Logged In: YES
    user_id=1266984

    My theory about this has been that rdesktop is incorrectly
    utlizing the xwindows clipboard and that calls to the
    clipboard subsquently hang. See the discussion I tried to
    start about this [1].

    One reason I developed this theory is that if you disable
    "klipper" in your toolbar, you'll see that the KDE hangs
    become far less noticeable. But other applications that
    make blocking calls to the clipboard still have issues. In
    [1] and [2] you will find traces of rdesktop clipboard
    debugging output that might provide some insight.

    [1] -
    https://sourceforge.net/mailarchive/forum.php?thread_id=8032382&forum_id=8865
    [2] -
    https://sourceforge.net/mailarchive/forum.php?thread_id=8073260&forum_id=8865

     
  • Nobody/Anonymous

    Logged In: NO

    I have found that when using rdesktop 1.4.1 running a
    session to a remote windows xp machine using rdp 5 it causes
    konqueror to take several seconds to switch from one folder
    to another. Eclipse hangs for a much longer time. If I run
    in rdp 4 mode this does not occur.
    Wendell Nichols

     
  • Ilya Konstantinov

    Logged In: YES
    user_id=335423

    In the next weeks, I'll be making sure our clipboard code
    changes so no matter what happens, it'll never leave an
    application requesting clipboard unanswered. Therefore, I'm
    assigning this bug to myself.

     
  • Ilya Konstantinov

    • assigned_to: nobody --> ikonst
     
  • Nobody/Anonymous

    Logged In: NO

    I am using rdesktop 1.3.1 with the KDE 3.2 and turning the
    sound off really helped me out.

     

Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:





No, thanks